[Release] Google Home Assistant Relay Driver - text to speech on Google Home devices

community_driver

#141

REALLY hope Google gives us a way to not have this pre-announcement. It was working perfectly with just the little bleeping before the message. Definitely got everyone's attention. Now it's kind of annoying.


#142

Me too ... only about a day of good ole' GA messages ... now it says the prefix :frowning:


#143

I've moved on. Assistant Relay still works for control, and so everything I was controlling with it is fine.

This takes more setup, but really I'm not creating new announcements everyday, and I only had 9 to convert. Took me about 30 minutes. Once you have the basics setup, it takes less than 5 minutes of your time to create a new announcement, and there's no cookie to ever expire.


#144

Why would you have to recreate announcements everyday?? This has been working great for months. Even with the added phrase, it still works just fine.

As for that other setup, if it works for you... go for it but the requirements are STEEP. lol

I only own the original echo, lives in the basement. Only there in case Amazon has a sale via speech. They have done that before! I won't plug my ST back in. Nope, just won't do it.

Amazon echo, NO ... ST, ... NO ... Google Assistant, Yes and still works great!


#145

You don't, and that's my point why this is a viable solution for Alexa owners. We can hope that google will get rid of that, or hope for a solution from the ether, or take action.

:rofl: It's a bunny slope. You've write groovy code. This a walk in park my friend.

Yeah, neither will I. Because I don't own one anymore! :stuck_out_tongue_winking_eye:
This is cloud to cloud to cloud solution. Just add two clouds and stir :wink:
Works great. I use it every day for door announcements. Never fails, response time is pretty much the same as Google Assistant announcements. Maybe 1-2 seconds slower at times. Fine for my uses. It's the only Samsung cloud instance that I've not experienced a failure with so far. :grin:


#146

Cast api does not suffer from this. Just have to deal with the chirp. Also allows you pick individual speakers.

Didn't @mike.maxwell mention there was an official cast driver in the works?


#147

I used to use CastAPI on ST is there a working version here?


#148

Yes. Should find what you need in this thread.


#149

One of my favorite @mike.maxwell quotes :grin:


#150

Only problem with Cast-api is that if listening to music, it will stop when the announcement is being made and doesn't start back up after the announcement.


#152

And that is the reason I can deal with the prefix for now.


#153

Thank you for re-posting this, it worked fine for me. The added prefix from Google was KILLIN' ME! I was getting sick of hearing my name all day "Announcement from John...The Cat's are F@#$ing off in the Laundry Room", etc... Haaaaa!


#154

No worries there are ups and Downs to both implementations. I used to run them both myself.


#155

So, i got the broadcast to say "broadcast from hubitat" by setting up another google account and linking it to my speakers. I set the first name of the account to Hubitat. But that didn't quite work. It kept saying Hue-bi-tat. As in phillips hue. I finally got it by spelling it out like "Hub-a-tat". That's the closest I got it to sounding correct with the American English voice.


#156

I got assistant to pronounce it correctly by using "Hub-itat" but the relay doesn't use it when it broadcasts. It simply says "incoming broadcast, it says". However when I restart the relay on my server it says "assistant relay running for hubitat" properly, not sure where I went wrong?


#157

Yeah, that one works too.

I'm using Cast-Web-API, so there must be a difference with how the broadcasts are passes to the assistant SDK. That's very interesting. What do you get if you try to pass the phrase "wake up" in a notification to assistant-relay? Does it say "wake up" or does it do the rooster and the whole thing?


#158

The full rooster thing


#159

Yeah...mine too. But you don't get "Broadcast from and then the name? When you set up the google account, did you give the account a name or did you just set up the name in assistant relay? Cause you have to give the google account the name.


#160

Yes, I set up the account with the name "Hub-itat" and made sure it was also configured in Google Assistant and the relay the same.


#161

And you have that account linked to all your speakers?