[RELEASE] Fibaro Smart Implant FGBS-222

Well, thanks anyway. It was worth a shot.

Unless the 1-wire interface works out of the box with the implant then you are out of luck. I believe ControlByWeb offers a WIFI module that could work with it or maybe you could use a Z-Uno to interface with the 1-wire module.

Now that I think more of it, there must be something non-standard about the way the ControlByWeb adapter does DS18B20. Any old run of the mill DS18B20 can plug into the SI.

I'll have to check out z-uno, thanks.

Each DS18B20 has a unique serial number, part of it is a "family code". For instance, the DS18B20 is 0x28. Other device types using the same protocol have other family numbers.

The DHT22 uses another format altogether to communicate.

So those two protocols are supported by the implant. The X-TC1W-K could use the same/similar format to the DS18B20 but with a different family code or it could use an entirely different format, in either case, it will not work with the implant.

Yes, no info is getting to the Fibaro, per the logs.

In an unrelated development, there were some values for endpoints 3 and 4 which I believe are the two analog voltage inputs. In looking through the manual, it seemed to say it can read up to 30 volts, so I'll be hooking a 12v battery up to the SI and see what I come up with, :slight_smile:

Of course I read that wrong: 30 volts was for 3 wire.

I did a little (lame) testing.
Did not work on 26vdc power supply for a gate.
Worked on my running car at 14.04 volts. Mostly agreed with my voltmeter at 14.01.
That was with internal pullup resistor setting to on, whatever that means.

My application has 4 soil sensors each has a relay that closes when humidity drops below a set value. I want to monitor those with the FGBS. Obviously I have the two contact sensors. What can I do to monitor the remaining two? My first thought is introducing say 5V into each and use the analog sensors. Suggestions/Solutions?

There are only 2 inputs on the implant. Each can either be used as a contact sensor or an analog input, not both at the same time.

The only way I can think of is to configure the inputs as analog sensors and connect 2 sensor relays to each input. The two relays of each input are connected to ground on one side through different resistors. The other end of the relays are connected together to the analog input. Configuring the input as analog "with internal pull-up" you should get a different voltage depending on the state of the two inputs. For instance, assuming the implant pull-up is 17k ohms (from memory) and using a 20k for one relay and 10k for the other relay, you would get:

Relay1 Relay2 Reading
Off    Off    10V
Off    On     3.7V
On     Off    5.4V
On     On     2.8V

Use the other input for the two other relays. You could use rules and virtual devices to translate the voltages to actual contact devices on the Hub.

1 Like

Nuts, thought it was 2 contact, and 2 analog/digital!
Thanks so much, yeah, that all makes sense.

Hi, great driver, I have a smart implant already controlling my alarm. Interesting dilemma this - I want to use one to make my momentary doorbell button "smart" and trigger events. All is fine I can just wire it like a door opener in the manual with IN1 input. BUT... my kids ofen press the doorbell repeatedly for a laugh when arriving home. The implant may go to think it's initating a Z-Wave exclusion and go into yellow blink (which will fail as controller isn't excluding). I'd like to block this feature, so you have to use the physical implant button to remove. According to the manual this is possible if you activate the "sending scenes for triple click" via parameter 40 value 4 so a triple-click activates a scene instead (which I guess will be ignored).
So... Any idea how I can go set that parameter myself eith via the driver or otherwise? If not, do you have any other bright ideas e.g. changing the IN1 confguration to an alarm input?
Thanks for any help!!!

You could install the 'Basic Z Wave Tool' driver. That allows you to query any/all parameters and send any parameter (I do this for my Fibaro Dimmer 2's and Motion detectors to get at parameters that aren't available in the in built drivers.)

With the driver installed you would just temporarily switch the implant to that driver, open a logs page, send the commands you want using the preferences, then switch back the correct driver when you're done.

1 Like

Thanks John I may try that when I get it up and running first.

1 Like

I just switched the driver on mine and hit 'Get parameter report'. Parameter 40 is set to 0:

1 Like

So it's just parameter number 40, size 1, value 4 and hit the Set Parameter button. The logs show the change but if you want to be sure, you can just query the single parameter by clicking Get Parameter Report after entering '40' (if you leave the box blank it reads the full config). I just tried it and it took.

1 Like

Yes that makes sense 0 (no scene set) is the default value for parameter 40 according to page 10 of the implant manual here: FIBARO SMART IMPLANT FGBS-222
Any idea if using the scene setting will do anything consequential? I'm not familiar with Z-wave scene setting classes, a command disappearing into the bit bucket is ok! I just didn't want it to break the driver. Maybe christi knows. Also going to an ignored exclude status I hope wouldn't matter anyway, as long as it comes out of it quickly or with another button press. Guess I will just experiment!
So using that driver its Set Parameter with parameterNumber = 40, size = 1, value = 4 ? I've not used that basic z-wave tool interface before, just installed the code for it. [edit: yes as you posted at same time, thx!]

In the extended Fibaro manual it'll give you the size, in this case it's 1. When you do the 'Get Parameters' and it prints all settings to the log, the log shows what size each parameter is along with its current value (so you just match the size of the existing and alter the value to suit)

TBH I'm not familiar with scenes myself so I'm not sure of the effect. I also use one for my alarm. The one I was adjusting there is for my bed TV lift. Input 1 has a manual switch connected to it and I've never had any issues pressing it repeatedly.

Maybe set up a rule so that when the kids press it repeatedly your smart speakers announce that they've just lost a weeks pocket money!

1 Like

Don't you just need to set the parameter "Input 1 - sent scenes" to "Key pressed 3 times"? This is already available in the driver. Make sure to update the implant with "Save preferences" and then "Configure".

1 Like

I wasn't sure. It's often difficult to work out which parameter is which in the preference panes. I've wondered a few times why it's not standard practice to include the parameter number alongside the preference, so that it can be cross referenced with the manufacturers manual.

1 Like

I am a noob with Hubitat so there is a good chance that I am making a stupid mistake here. That said, here is my issue:

I am trying to control two garage doors with the implant. I have magnetic switches connected to the two inputs and have the outputs connected to the manual switch circuits on the openers.

Door 1 works fine - the input status reports and I can open and close the door with the switch (OUT-1).

However, IN-2 is connected to OUT-2, despite ‘connect IN-to-OUT’ being disabled. This means a state change in IN-2 triggers OUT-2, leading to an immediate re-opening of the garage door at closing.

I confirmed this behavior in benchtop testing with a second Smart implant and a couple of LEDs - IN-1/OUT-1 are independent, but IN-2/OUT-2 are linked.

I am running version 1.7.6, so as far as I am aware I should be up-to-date.

Any suggestions how to deal with this are very much appreciated!

So you set both " Input/Output 1 - Local Device Protection? *" and " Input/Output 2 - Local Device Protection? *" to 2?

Could you "Enable debug logging", "Save preferences", "Check Config" and after a minute or so copy the debug log that has been generated and post it here. Maybe also trigger both doors and also copy the generated log here.