[RELEASE] Fibaro Dimmer 2 (FGS-212) Driver

I would try to first use the driver Basic Zwave tool and set all your device parameters. THEN load the Dimmer 2 driver and try it.

Ok thanks I'll give that a go.

Right... simple once you know.
It turned out to be that unless in the device info (data) it says "zwaveSecurePairingComplete" its going to play up. I had to exclude and pair several times on each device, but once they were securely paired they work a dream.
It's worth mentioning the Fibaro dimmer 2's (212) were previously used with STs, I excluded them from ST and still had to pair several times. So it may be different when installing new dimmer 2's to Hubitat.
Also i didnt have to move the devices or the hub.

Good shout robin, about the securely paired issue.

Hope this helps the next person, and just want to say i think hubitat is awesome, basically ST but faster and more reliable. Got sonos, nest stat and protects, Alexa, TP link smart plugs all working easily and well.

Just waiting on Harmony integration and need to work out how to do scenes/routines. :blush:

Dave.

Hi,
First post, first automation element I am attempting to move over from SmartThings and I have hit a wall and fed up of trying the same thing over and over again (first sign of madness, repeating something and expecting a different outcome).

So I have a Fibaro Dimmer 212 using the Device Handler posted above by Robin (thank you Robin), but I am unable to get control of it. I also cannot seem to get the "zwaveSecurePairingComplete" message in the info block. Have tried reset(via b button menu), moving hub nearer but I am just stuck with the sync pending message and cannot seem to move past this.

Have also tried using the 'Generic z-wave dimmer' and the device handler above by Bobgodbold but no luck so far. Can anyone offer any further advice please? I suspect its all related to this connecting in secure mode and the fact that it used to be connected to the SmartThings hub (it was excluded).
Thanks Jim

1 Like

On my Fibaro 2 Dimmer (FGD 211) it says.....
Data * deviceType: 256

  • inClusters: 0x72,0x86,0x70,0x85,0x8E,0x26,0x7A,0x27,0x73
  • outClusters: 0x26,0x2B
  • deviceId: 4106
  • manufacturer: 271

What is this "securely paired" business? I have several of these and none say this. I did not move them from ST, but did move them from a Vera.

I'm just clutching at straws based on the comments above, my data block looks very similar to yours (not at home right now so cannot get to the screen). I assume yours is working fine and therefore this 'securepairing' message could be a red herring?

You should see a secure pairing message in the live logs during pairing.

If I get a chance over the weekend I'll try to re-write the handler to detect and allow for both secure and non-secure pairings.

I have not been watching the live logs while its 'pairing, will try that tonight when I get home and let you know. Thanks all for the help thus far.

So after the discovery I see this in data block:

  • deviceType: 258
  • inClusters: 0x5E,0x20,0x86,0x72,0x26,0x5A,0x59,0x85,0x73,0x98,0x7A,0x56,0x70,0x31,0x32,0x8E,0x60,0x75,0x71,0x27,0x22
  • outClusters: 0x2B
  • deviceId: 4096
  • manufacturer: 271

And this is what I have in the logs from removing the old device and adding new:

dev:2012018-09-21 17:32:54.033:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 3A 01 00 1D 2A D4 00
dev:2012018-09-21 17:32:54.012:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 21 01 00 AE B8 D4 00
dev:2012018-09-21 17:32:53.992:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 20 01 02 B9 CA D4 00
dev:2012018-09-21 17:32:53.973:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 1F 01 01 60 3D D4 00
dev:2012018-09-21 17:32:53.951:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 1E 01 02 67 6E D4 00
dev:2012018-09-21 17:32:53.935:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 0E 01 01 14 6E D4 00
dev:2012018-09-21 17:32:53.918:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 02 01 2B E4 27 D4 00
dev:2012018-09-21 17:32:53.896:debugDevice, parse description: zw device: 11, command: 5601, payload: 70 06 01 01 06 48 B8 D4 00
hub:12018-09-21 17:31:20.590:infoZ-Wave device "Device" excluded and removed.

So no mention of secure pairing at all!

Im not at home so cant show my data block... however i was having the exact same problem, honestly that was the solution, I had to include and exclude about 4 times. And the last time i did one by one and finally i got the securely paired status and they worked like a charm.

That being said last night after doing a firmware update on the hub they all just stopped working.

Will look at repairing one of them tonight to see if that helps.

I've probably tried unpairing (triple click) and pairing (triple click) upto 40 times now and it always the same. Had the hub right next to it too. I have pinged the question about this secure pairing back to support. I do not know enough about it to know whether its a function of the driver or the z-wave radio.

It would be great if Robin could make the driver work irrespective of the secure mode, but to be honest I feel there may be other problems later on if we do not get to the bottom of the fundamental problem.

Agreed.
Strange that i managed to get it to work, did you do the general z-wave exclude when unpairing? Btw i also left all my devices in place, i found no need to move them or the hub.

Seems odd how other fibaro devices have been added officially and the dimmer 2 hasn't been, especially as it must be the most common fibaro device.

@Jim_UK Have you managed to add Alexa integration successfully? I cant get it to work.

Yes the exclude from ST worked fine, it actually paired with HE also, its just I cannot actually do anything with it, I see entries in the logging, just no on/off control.

Yes Alexa app is working for me, I did have to do it many times. I only got it to work from the alexa app (not via voice control) and also had to ensure that an existing device of the same name did not exist (I seem to have settled on using the same names in HE as ST - not sure if this is a good idea with hindsight).

Sorry I ment general exclude in HE. Then re adding them.

ok no, thats new to me, 'general exclude in HE' I just removed the device. I assume that's on the z-wave setup screen. Great thanks will try that when I get home as makes sense.

Ah ok, I deleted everything from ST and Alexa and started again. May have to try again... and again :roll_eyes:

Yes is on z wave setup page, hope it work this time. :blush: (again may take a few go's)

This is my main gripe with HE so far (otherwise I am enjoying it - when it works its great), I have to repeat things like this multiple times. I assume that's partly because of the fact the devices came from ST and there are probably conflicts flying around that I am oblivious to.

I think something needs to be done about this though before it can become mass market.

I think at least some of this is the fact that there's no 'standard" for anything related to Include or Exclude.. 3 clicks, 4 clicks, side button push, 8 clicks in 2 seconds, power cycle 3 times in 2 seconds but end with On... sheesh!!

Hubitat has improved their Exclude, with logs etc. BUT everything can do the Exclude, you know that right? Your neighbor's Vera?? if you can get your device and their Vera close enough, it will do the exclude for you :smiley:

I've joked many times around here that if you invite me to your house, I'm going to bring my Aeon ZStick and (by double clicking it to put it into exclude mode) walk around your house flipping devices on and off to exclude them for you. :slight_smile:

If a device is paired with ST, you don't need to use ST to Exclude. The ZStick is superb for this. Hubitat will exclude anything too... just not as visibly. :frowning:

1 Like

Download the Hubitat app