[RELEASE] Echo Speaks


#465

What Echo devices are you using? I can't get the announcement to work even through the test page, but the logs show the messages are being delivered successfully. When I use the speech test, it works just fine (although out of sync).


#466

Mine are all Dot's, both gen2 and gen3. But I would think it should work on any echo device that is supported by Echo Speaks. Not sure what you mean by test page.


#467

Ok. That might be the issue. 3 of mine are gen1 and I also have a spot.

27%20AM


#468

Just tried that on mine and it didn't work either.

Go into your device itself and you will see playAnnouncment. Just type in a message and trigger it and see if it works there.


#469

nope. It doesn't work in the devices page either.


#470

Try turning off the queue for the device.


#471

Does Echo Speaks work at all for any of your devices? I'm wondering if something isn't configured right. Maybe the Heroku or something??? Also make sure you have the latest version of both App and Driver. I think it is 2.6 on both.


#472

Check the volume on each Echo under Devices. Make sure there not set to zero.


#473

Thank you all for your suggestions. The queue for each device was already disabled and the volumes were set to 40 or more. They do work when I use the test speech or play things like weather. It's just the Announce that doesn't work.


#474

The release you did yesterday? Or the release that is coming next?


#475

Yes. I am trying to install v2.6.0 on a new hub. I am able to install v2.5.0 on the new hub.


#476

You are trying the playAnnouncement button? You enter some text then push button. Not questioning what you are doing, just trying to help. You may have to see what Tony says.


#477

I just removed line 2069 in the Echo Speaks app and saved. Then I could install app.
I KNOW this not right but it worked. All the functions are working great too.


#478

No worries. I get it. The only thing I hear is the tone of the volume being reset. So, there is some actions and reaction. I just don't hear any words. Below is the device driver page from my Echo Spot.



12%20PM


#479

Check Volume on each echo device in Devices and make sure volume is a least set at 50. The same screen you are in from above.


#480

and we are getting somewhere. I hear the bonking but you are right on. The volume settings aren't changing in the device:


#481

On those units can you push a button to increase volume? Or just say Alexa set volume to 50%. See if that works. Might be a hint as to what is going on.


#482

I asked the Spot what it's volume was and it said 50. The device page shows as the one I posted. So, there does seem to be some disconnect. I don't know when the device page would get updated if the volume on the device changes.

I used the App to remove the device and add it again. It has the same behavior. I have three Echos and one Spot and all do the same thing. I would remove Echo Speaks and reinstall it, but I have one of the Echo's supporting 14 rules.


#483

I will investigate this further


#484

The next release will be v3.0 and will have Alexa guard control, ssml, and the new actions app