[RELEASE] Echo Speaks


#405

Status Update: I have the fix inplace and it's tested. I want to make a few more tweaks before I push out the changes.


#406

Update: New Server Build Released v2.2.2

Anybody who's Heroku server i'm a collaborator on should be updating right now.


#407

If you are not a collaborator, what do we do?


#408

All seems to be working normally! Thank you @tonesto7!!


#409

If you are using Echo Speaks, @tonesto7 is the collaborator. Go through the process of updating your Heroku app. Documentation for that here.


#410

Seconded. Thanks!!!


#411

I remembered about 5 minutes after posting. Thanks.


#412

@tonesto7
This works perfectly.
Thank you so much for the updates.
We all really appreciate your work on this.

Andy


#413

Back up, thank you very much. And thank you for the detailed instructions.


#414

Is anyone else having volume control issues?

When I select my preferred volume in Rule Maker, the message is played at the device's current volume setting, and not the level I have selected.


#415

@tonesto7, first all thanks for a great app and for jumping on the cookie changes. I don't know if you're updating your supported device list but I've used the app to connect and play music on my Ultimate Ears (Logitech) Blast (once I overrode the ignored devices). It shows device type A37CFAHI1O0CXT. The device shows ttsSupported : false. I also noticed the permissions shows flashBriefing=false. Is that something you set or that the API returns? I can ask for the Blast to play my Flash Briefing but it isn't processed from the device page.


#416

Yes. My Echo Dot devices are not always announcing and I'm finding that it's due to volumes changing. I'm not even specifying volumes in any of my rules. Didn't have this issue prior to the recent cookie issue.


#417

@didymus

How are you adding volume control to the standard speak command?


#418

@sdonaghe
When selecting music device, volume is a parameter.


#419

Ahh thank you. I have been using speech device not music device.


#420

@sdonaghe
But the volume control is not working for me.

Please let me know if it works for you.


#421

I removed my Echo Dots from devices and refreshed my cookie in the app. My Echo Dots were re-found. I then added the Echo Dots back to my rule and everything is working now.


#422

I have done the procedure of deleting the app in Heruko and redeploying it 4 times but none of my devices are showing still. How do I get this back working? Do I have to take everything out and start over?


#423

Did you remove the driver code from HE? Your devices should be created automatically. In fact, unless you actually removed them they should have remained in HE. You might want to try re-importing the HE app and driver code.


#424

The app, when removed, removes the child devices as it should.