[RELEASE] Echo Speaks


#303

Been doing a lot of testing lately as things were very flaky going to my echos. Here is some things I discovered.

If I use the standard notification app things are very inconsistent. Not all the selected echos will respond. And sometimes one of them will repeat the message several times. I tried selecting the echos in both the text and audio device selections. Same thing in both.

I created an app to test with. Found out that using playAnnouncement works pretty much all the time. Had some issues with playText and speak. Not sure what command the standard notification app uses.

If the notification to the echos is triggered automatically, using my test app, things seem to be fine. All the echos respond within a second or 2 of each other. If I trigger the message using an Echo, ie have echo turn on a switch when I tell it to which then triggers the message, the echo I used to tell it will not play the message. All the others do. For example. I tell echo 'good night' which sets a virtual switch in HE. HE then, along with other things, sets the mode to night. I have an app that sees the mode change and announces it on the echos. But the one that I said good night to doesn't.

Don't know if this makes sense or is of any help but just what I've been finding out.


#304

@tonesto7, Does this support Echo Auto? I finally got one. It shows up in the app, but I can't seem to get any speaking on it.


#305

Try creating a routine in the Alexa app that speaks using the echo auto. If it works provide me the device info shown for the device in the echo speaks app under the devices section.

I will update the config file stored on Github to add support


#306

When I create a routine in the Alexa app the echo auto is not available to be selected. So I guess it isn't able to make announcements that way. The auto does show up in the list of devices but it isn't selectable for an announcement.

Thanks for looking into it.


#307

Well that's kinda a bummer. Maybe it's a safety thing?!?!


#308

Can you share the info on your echo auto under echo speaks?
I would like to add the appropriate config for it to ES.
Specifically the Type and Family info.

It may be under the unsupported section or available devices


#309

Status: Onlilne
Style: Echo Unknown A303PJF6ISQ7IC
Family: Echo
Type: A303PJF6ISQ7IC
Volume Control: (True)
Text-to-Speech: (False)
Music Player: (True)
Music Providers: [Amazon Music, My Library, Tunein, iHeartRadio]


#310

The Info was under discovered devices. I see Speech not supported. Don't know if I can use music in any way to make it say something. I will try and do some experimenting. I'll let you know if I learn anything.

Probably a safety issue, but it would be nice to hear it say Alarm triggered or something rather than hear my phone beep and have to get it out. I would think hearing Alexa would be safer.


#311

Thanks for the info. It says no Text to Speech because I have a config that tells which devices are allowed to speak to eliminate issues.

I'm going to update the config right now and set it to allow TTS.
I will post a message when i push up the update


#312

I'm working on some fixes for this error right now.


#313

Just pushed up v2.5.0 with fixes for the exceptions and significantly reduced the calls to Amazon so this should help with the hub slowdowns


#314

Thanks! Much appreciated.


#315

Just updated to 2.5. Auto still shows text to speech as false.

Edit: It now says true. I'll do some testing tomorrow and let you know if it works.


#316

Hey all,

I just got ES installed and working last night, today I see these errors in the log.

I think some of the errors might be related to changing the device "label", which I did after it was created. The reason why I think that's part of the issue is, the log name is from the old label
image

The new device label is Echo - Shlikes Echo

Sooooo. what's the best way to fix these errors?


#317

Everything look good on 2.5.0. Only thing I just noticed is this error in my logs:

[app:137] 2019-06-01 08:00:15.761 am [error] groovy.lang.MissingMethodException: No signature of method: com.hubitat.hub.executor.AppExecutor.error() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl, groovyx.net.http.HttpResponseException) values: [makeSyncronousReq(Method: get, Src: getDoNotDisturb) exception, ...] Possible solutions: render(), getLog(), now(), iterator(), every(), grep() on line 1184 (getOtherData)


#318

Did some testing on the Echo Auto. Nothing worked. So apparently they aren't allowing any message speaking on that unit.

I got a request for a survey on the unit from Amazon. So one of the things I mentioned was that issue. Don't know if it will help or not, but worth trying.


#319

@tonesto7 I'm still puzzling over something. In ST I could issue a playAnnouncement to all of my echos and they all respond pretty much together. I do the same thing in HE and it's hit and miss as to which ones respond. Almost never get all of them. I made a test app to run in both platforms that just plays a message for testing.

Any thoughts?


#320

Ya, I wish I could stop the popcorn playback too and increase the number of echos I can spam at once. I can get three to play and no more at any given single moment and they're never in sync. I haven't experienced Echo Speaks on ST, so I just figured it's an Amazon limitation, which appears so.


#321

Lol. This is a hard one for me to test. My wife works from home and would kill me with the announcements. I’m not sure of the cause as it doesn’t seem to be happening to me.


#322

I had to go out of town for a few days, will do a little more testing when I get back.

I have 6 echos. I saw something on here about only being able to get 3 at a time. So maybe that's my problem. I'll experiment with that when I get back.