[RELEASE] Echo Speaks


#283

Pair the new Echo to your Amazon account.

The app actually does a full device refresh every 10 minutes and will automatically add any new Echo devices found on your account.
If you want to do it immediately then open the Echo Speaks app in Hubitat and press Done after It will show up as a device within 10-20 seconds.


#284

Perfect!! It worked. Thanks.


#285

Have tried using the stock Notifications app to send notifications to my Echos using Echo speaks.

I have 4 Echos selected for a notification. But usually only 1 or 2 respond. Not always the same one. I have tried using the text notification and the audio device notification.

What could be causing this? I never had this problem on that other platform.


#286

Amazon has a max request within a certain time frame. Maximum of 3 rapid pushes is all I can achieve before they throw an error back.


#287

I'm getting this error in my logs from a newly added Echo Dot:

java.lang.Exception: No response data exists for async request on line 2415 (asyncSpeechHandler)


#288

Yes, my newly added 3rd gen Echo Dot announces minimum 30 seconds after my other 2.


#289

I wish I could confirm this is the case. I only have 1 3rd gen :frowning:


#290

I don't know if this has any affect on why anything I send to echos is very erratic or not. But this keeps showing up in the logs for all my echos.

errorjava.lang.IllegalArgumentException: No json exists for response on line 1062 (getDoNotDisturbHandler)

What my issue is not all the echos I select respond and some respond more than once. This in regards to trying to send notifications to the echos.


#291

Has anyone experienced performance problems with the App? My hub was crawling and support had me remove all custom apps and stated that "some" of the apps I had installed were known to cause performance issues. Just thought I would ask before re-enabling the app.


#292

I've noticed this with mine since the last Echo Speaks update. I haven't had a chance to take a look into anything, but the prior version had seemed to be running well. Disabling ES and rebooting fixes the performance issues, so it appears to be directly related to this app/driver. :confused:


#293

Nothing was changed or added that would make the changes you are referring too.
I think that Amazon has been having issues lately and connections are timing out and that will cause the hub to start slowing down.


#294

Curious if you have both ST and HE using your Echo devices?


#295

My web access to HE has been very slow. I deleted Echo Speaks and it sped right up. So there is something going on there.


#296

I’ve been having lockups and slowdowns as well. I deleted and reinstalled the echo skill integration and now my hub locks up every 2 days instead of every day, but every time I open the Alexa app it takes forever to load, and always will list 8 or so devices as unresponsive. Echo speaks and NST manager are the only custom apps I haven’t tried disabling. I removed SmartCast yesterday and am waiting to see if my hub locks up tomorrow morning. It seems to get worse over night. With SmartThings I had to remove ES from WebCoRE due to WebCoRE crashing. I hoped it would be better on Hubitat, but will probably be deleting it tomorrow and just using virtual switches to activate echos if that’s even possible, or putting it back on SmartThings and using Hubconnect. I have 12 echo devices btw.


#297

@tonesto7, any idea what's causing these 2 errors with a brand new Echo Dot which was just recently added to my account?:

java.lang.IllegalArgumentException: No json exists for response on line 965 (getDoNotDisturbHandler)

java.lang.Exception: No response data exists for async request on line 2415 (asyncSpeechHandler)


#298

REbooting your hub will always resolve the issue, so I am not sure it is related to this app. I was running 2 custom apps, HomeCloudHub and this one. I had issues and disabled homecloudhub. As soon as I rebooted the performance was better, so unless both apps are using some code that is similar, I can't imagine the issue is Echo Speaks.


#299

Precisely right — I'm intently rebooting to get a clean slate.

What I'm trying to get at is that when ES is enabled (after a reboot), the Hub slows down.
When it's not enabled, the hub remains responsive.

I'm out traveling the next few weeks, so unfortunately I won't be able to do any debugging.


#300

I get these errors as well. No ill effects that I can tell.


#301

But why on one Echo Dot and not the others in my setup? There has to be some reason behind that.


#302

I'm running a few custom apps, including this one, and not once have I had my hub lock up on me.