[RELEASE] Echo Speaks V4

Same result. I get all the logs from ES to indicate that a notification has been sent, but nothing. The Echo works, if I ask the time so that is all working. for whatever reason it just does not work.

I just noticed your in the UK. Could be something about the server you are using in your ES setup?

1 Like

I've also tried setting the locale to en-US but it makes no difference. Can someone here confirm they are in the UK and operating without any issues?

Right, I have my head in my hands and I'm officially embarrassed. Whilst the locale was set right the server was not. Thanks for the pointer. All working. Apologies for wasting anyone's time and thanks to those helping me get there. special thanks to @terminal3 for pointing out I'm a fool :slight_smile:



Can you share what you had to do to fix this? I am having the same messages in my logs too.


You can view more details in this thread and a quick fix:


It looks like you cant login into alexa.amazon.com to grab the cookie. Any ideas how to auth to get the cookie? I am using the local server

Did you check the tips on this thread?

Also, due to the Amazon authentication library on the cookie server being outdated, you may need to turn off 2FA to get logged in, then you could turn it on again. That's my only other explanation but I am not sure why it works fine for some people and not others.

1 Like

I ended up rebuilding the server I was using an older version. Thank you for the help

1 Like

Anyone else getting "sorry I can't access your skill right now"

It seems to be in conjunction with a repeating notification that I have set up

Yes, I was just going to post the exact same question. Instead of saying door is open when I open the door it is saying, sorry I cannot access the skill right now with some additional words that I cannot catch.


I did a test speech on the devices that say it and it seems to "fix" it.

that did not work for me.

I have it happening on three devices. Two took one time to straighten out. The third took 3 or 4 tries.

I don't know if it will stay fixed though.

Happening to one of my devices... my back door. its inconsistent though.. happens on door open sometimes, happens on door close sometimes. never twice in a row though.

Similar situation here. We have a sleep mode announcement that happens and it went flawlessly but the animal feeding reminder that happens doing it consistently.

Unsure if related but I believe today was supposed to be the day that numerous Alexa features were disabled permanently. One that I use, Guard, is now a pay for service as of today. No more 'Alexa, I'm leaving' since without Guard, there is no point! When I go away (known due to the amazing HD+ Presence sensor) all my 'away' automation go on about their business regardless of Alexa.

Interesting. I didn't realize that

yea. a quick google - this was posted today: