[RELEASE] Echo Speaks v3 + Actions

I’ve been using Echo Speaks for months with decent results, but I’m definitely getting major issues with the new version. I just updated my Echo Speaks app, child app, device handler, and server, and now my entire HE is basically inoperable. I’m going to have to delete all the Echo Speaks components and won’t be installing them again soon.

If possible, you should send @tonesto7 your logs. I know he is trying to figure out issues with ES, and the more data he has, the more likely he can debug the underlying problems.

As aaiyar suggested, it would be a big help if you could pass on any symptoms/logs you have to @tonesto7. Even if you ultimately decide to delete the components, it may help identify issues that will benefit other users in the community. In my case, I haven't had problems with V3 of the app. There may be something that is different on my hub or there may be some other reason we're getting different results but your info could help everyone. Thanks!

Yes, understood. I will try to do so when I'm back on my local network. I just don't have a lot of time to play around with this, unfortunately. It's difficult to update to the latest version and not know whether that is going to brick my entire smart home.

I believe I've found the cause of the issues.
I spent awhile refactoring the web request code and I'm seeing more stable behavior now. I'm not sure how I missed some of the flaws until now... I will have a test version out tomorrow evening


I noticed this morning afew of my rules failed to run and my motion lighting was slower* - so I rebooted my hub and wholly heck its Really slowed down the web interface now. 4-8 seconds to load each page. Not pilling on, but the only thing i've added non-HE is ES in the last 2 weeks and had no issues but something has changed and its very noticeable.

*appreciate all your hard work @tonesto7

1 Like

This gives me a good idea... in the mean time I'm going to add a kill switch to the app to allow you guys to basically turn off all polling and activity in the apps and devices. That way you can stop it when it starts acting up.


I guess I'm trying to Jinx myself but I'm still waiting for the same problems others are describing. Still going strong no lockups or weirdness since beta. Are you guys sure your rules are solid if your using RM? I went through all my rules when RM4.0 was released and made sure they didn't cause errors. Had to properly rewrite a bunch of rules. Just a suggestion might help something has to be different.

my rule is pretty simple

lol okay

Bravenel looked at the rules I had that were causing errors and it was from something in RM4 that will hopefully be fixed in 2.1.5. I try to avoid things that could cause concurrency; no nested if/thens or anything too complex. I ended up redoing the rules anyway and am error-free. I think @tonesto7 is right in reworking the web requests, because my web ui was slowww, and now it loads pages immediately. I'm going to try out the reworked version when he releases it and will update, although I'm really liking how well it works on ST going through HubConnect.

1 Like


I was able to figure out why ES isn't showing any notification devices for Hubitat.

section (sTS("Notification Devices:")) {
            input "notif_devs", "device.notification", title: inTS("Send to Notification devices?", getAppImg("notification", true)), required: false, multiple: true, submitOnChange: true, image: getAppImg("notification")

On this line above, change the following so it'll work for Hubitat:




Not too sure about pushover though, for Hubitat it can use the same capability to work with Pushover but the current implementation doesn't work with Pushover in Hubitat at all. Not sure if pushover is only for Smartthings since I haven't used Smartthings in over a year.

After this change, the Notifications section is now populating all of my devices that supports Notifications:

You may wanna also note on the SMS section that SMS won't be supported on Hubitat anymore on next Hubitat release.


Great find thank you :+1:

I think the sad part is that any app/driver can do this to the hub. The app doesn’t progressively consume more resource or make more requests. There is something wrong in the platform that doesn’t like the way I’m executing requests.
But I’ve looked around at some other devs examples, and tried using some of there ideas where applicable.

I fixed a lot of device errors as well where Amazon just doesn’t return data for some devices.


Does this change how actions work also?

Thanks, @tonesto7 for looking into this. Incidentally, I uninstalled Echo Speaks and deleted the app/device code, but something must be wrong with the Hubitat platform because my entire HE is still largely inoperable. I am now down to only official Hubitat apps (Amazon Echo Skill, Dashboard, IFTTT Integration, and Rule Machine) and just three non-Hubitat drivers that I have been using forever, but something must have been permanently affected or have remained on my HE that the app “removal” didn't entirely clean up. I'm really at a loss for what's going on—I do think the issues were triggered by the updates to Echo Speaks, as the problems started right after that, but the problems seem to go deeper. I guess I will reach out to Hubitat support.


Did you try a shutdown and a cold reboot?

:frowning: this doesnt sound good..

@aaron, yes, I have tried multiple reboots; per your suggestion, I have also just tried a "shut down", unplug, plug back in. No improvement. All of my devices are Z-Wave (110 of them), and in the Z-Wave Details pane, all but about 10 of them are showing blanks for last sent/received, and none of them are responding to commands. Meanwhile, the web interface is snappy and responsive. I'm totally boggled. Anyhow, I probably should stop sidetracking this thread, as the problems I've got are now beyond Echo Speaks

Hans. Have you read the soft reset & restore documentation. You can restore a previous saved database to possibly get you back to normal. Make sure to reach out to Hubitat Support first. They can take a look and provide a solution that may not require a soft reset or restore.. Best of luck..