[RELEASE] Echo Speaks v3 + Actions

Depending on your alarm system is there no way to be able to passcode that? I.e I have the Ring alarm system so I can arm and arm through alexa and use that to trigger other actions but to disarm you still have to provide a verbal passcode to alexa.

But to your original point, Echo speaks has a SetWakeWord exposed command, so theoretically maybe you could set it so that if your GPS location is not detected at home then a custom action is run on all devices to set the wake word to "computer" but then once your GPS returns it does the same to change it back to "Alexa"?

Not sure if this would work in real world scenario though?

No unfortunately, I wanted to get the Ring system but was vetoed into getting Simplisafe, but that is a discussion for another time. I think Alexa has integration with SS but not at a routine level for some reason last I checked, only at a skill app level, like "Alexa, ask simplisafe to....".

I was thinking the same thing but even more sophisticated involving random numbers and modulo to select one of the, I think 6?, wake words every like 30 minutes or so. All given that presence isn't there.

But programmatically muting would be my preference as I have recently had cross-room voice detection issues, probably due to the open floor plan design, but tapping into the motion sensors of that room might help alleviate that.

Also a thing to note, if I'm not mistaken, this is only an issue if one, they are in the house, in which case the alarm should be going off, or two, they are outside and screaming through the window in which case, I don't even know if that would be recognizable by Alexa.

Looked into it out of interest and whilst you could mute the alexas that are in other rooms it doesn;t stop them listening just stops you hearing their response, the only option to stop them listening is the mute switch on the device but that's hardware based and can't e enabled remotely.

1 Like

I was mucking about and redeployed the app. Unfortunately, it won't authenticate me now -- I've verified my username/password is correct. It appears to be an added layer of security that Amazon is now enforcing a one-time passcode on new authentications.

I tried adding my cookie information manually, but despite saying that saved, it didn't acknowledge the authentication.

Any chance this might be easy to fix?

EDIT: it is now letting me past the login/OTP, but I'm now getting "Looking for Something?
We're sorry. The Web address you entered is not a functioning page on our site" -- but manually entering the cookie, then logging in seems to work.

Hello guys, i'm running into a problem with this. I started working on this last night and today and I can't seem to get past the login to Amazon Alexa. I've confirmed my user/pw is correct by logging out of amazon website and the Alexa app and logging back in. I even changed my PW, but I can't seem to get past this screen below. I even tried creating a new amazon account to see if it works and it failed as well.

Where is this issue coming from and is there a fix?

Possible to trigger alexa notification (not immediate speak) from RM?

I have both Echo Speaks and the Hubitat "Amazon Echo Skill" loaded. I have created several alexa routine triggers using the "Virtual contact with auto-off Switch" to have alexa speak when certain contacts open but as noted up in post 475 -~480, creating all those routines is pretty messy. I also have used RM to have Alexa speak when the contact/switch opens selecting Action Type: "Send, Speak or Log a Message, Send HTTP R…" and Action: "Send or Speak a Message".

What I want, however, is to trigger an alexa "notification" where the LED Ring spins until I request alexa to speak the message… need to be certain I get the message. I have not found a way, using RM, to have the action be a notification instead of an immediate spoken message. Is this possible or does this require using Echo Speaks instead of RM?

Ok now have tried to do in Echo Speaks... both "Announcement" and "Speak" selections speak immediately without the LED circle and waiting to be asked for notifications... is it possible to trigger a notification?

Gave up trying to use Echo Speaks... using "Notify Me" Alexa skill and Hubitat driver: https://community.hubitat.com/t/release-alexa-notifications-driver/12599

Anyone getting this error?

EchoApp (v3.6.2.0) | wakeupServerResp Exception: java.lang.Exception: No response data exists for async request

Something changed on Amazon side again. I think they are more actively trying to block this integration from working :frowning:

1 Like

I certainly hope this is not the case!

I was using all Google Home, and in good part because of this integration, am migrating to Amazon Echo... if the disable it, I might migrate back to Google...

There are many different platforms that use this method so i'm sure things will be figured out.
I've spent the last couple hours trying to track it down myself.

1 Like

Amazon need to relent and make this stuff supported.

3 Likes

That would certainly give them an edge over Apple and Google!

1 Like

I was getting notices that my Echo Speaks needed updating. I was able to get everything on the hubitat side updated, apps and drivers. Now it tells me that I need to update the server on Heroku. I cannot find instructions anywhere on how to update that. Can anyone help and explain how I update this?

A million thanks!

Ron

1 Like

Two ways to do this. Add Tonesto as a collaborator, or manually.

Here are the instructions. The first link gives the instructions for collaboration, the second (which is also linked from that page) gives the manual method.

https://tonesto7.github.io/echo-speaks-docs/updates/server_update/

https://tonesto7.github.io/echo-speaks-docs/support/server_removal/

1 Like

Thank you so so much. Really appreciate you guys helping without making me feel like an idiot. Keep up the great work. I made sure to donate as I really appreciate the work on this app.

Has anyone figured out the issue in regards to the occasional echo device logging a blank lastVoiceActivity: ?

I saw @VilifiedFerret 's post that seems to fix the issue by commenting that one line out, but that does not really explain the issue of why only one device is having that issue and also is that line actually supposed to be commented out? I see in line 895 of the Echo Speaks Device driver there is a similar debug logging, but for wasLastSpokenToDevice: which is commented out.

Does anyone have 2.5.0 working ok?

I keep getting "You still need to Login to Amazon to complete the setup",

even though when I login I get the "Amazon Alexa Cookie Retrieved Successfully" message.

My Cookie just expired and didn't autorefresh and now Amazon won't let me login, it just keeps resetting my password, For now EchoSpeaks is offline on my network :frowning: :frowning::frowning::frowning::frowning:

Looks like @tonesto7 posted a server fix on the ST forum.

I've updated to the latest version (as of 5 mins ago latest versions) and still cannot login to Amazon, the password is right as I can login normally through a browser but on the heroku proxy link that it provides it will not accept my login details.

Download the Hubitat app