[RELEASE] Echo Speaks v3 + Actions

I just updated and some commands doesn't work, for example playWeather.

Is possible to implement playtrack?

def playTrack(uri) {
if(isCommandTypeAllowed("TTS")) {
String tts = uriSpeechParser(uri)
if (tts) {
logDebug("playTrack($uri) | Attempting to parse out message from trackUri. This might not work in all scenarios...")
speak(tts as String)
} else {
logWarn("Uh-Oh... The playTrack($uri) Command is NOT Supported by this Device!!!")
}
}
}

nope... Amazon doesn't allow mp3 playback :frowning:

I am not an expert as you in Amazon Alexa, but I did a skill (copying and pasting from an exampel) in Amazon that reproduce an MP3 located in an HTTPS server. Could this help?

Is it possible to add more than one Amazon account to Echo Speaks to allow access to the Alexa devices on each account?

I looked at this before. Where do you clone that repo ? Inside the same repo you want to keep in sync ?

@tonesto7 how do you update Server: (v2.4.0) ?

I’m getting lots of errors which is overloading the hub... anyone have experience with this?

Echo (v3.6.0.0) | getPlaybackState | Status: (400) | Message: Bad Request | Data: [message:Invalid input, userFacingMessage:null]

Nope, not me

Good luck

Second time I have given this app a try (last time was mid last year), and both times this app is the cause of my hub getting really slow and completely locking up.
The last straw was last night when my hub locked up around 11pm and the only way to bring it back was to pull the power plug. No app is worth the possibility of corrupting your hub, specially with the amount of work I have put in to my routines.

Anyway, with this happening both times I have tried this app between the space of at least 8 months I am assuming it will not get fixed. The feature set is nice, but if it is this destructive then the whole thing can't be used. Or is this only me having this problem? Seems strange though as I just followed the instructions as presented.

Does anyone know of an echo app that at least has the ability to send custom announcements to the echos? It's unfortunate, but I can't use this one.

I recently reinstalled.

However I do schedule reboots daily at 4:30am.

It’s been around a week now.

Yeah it stays up for more than a few days......but it was noticeably slow to do everything. Getting half way down the stairs before the light turns on, for example, is unacceptable.

I don't want rebooting the hub every day to be a solution.


Fork is on the upper right. Once you have the fork in your repo, install Pull from above link. Install the Huroku server from your repo, The Pull app will keep your repo always up to date and Heroku will automatically update and rebuild the server.

3 Likes

Nice find... I tried at one point to find a solution.

1 Like

Ahh, maybe I can get it to work if I set it up on smartthings, didn't think of that. Time to plug my smartthings hub back in I think....at least for echo speaks:

So the PULL app is cloned into the echo speaks cloned repo ?

The Pull app will update your fork (every few hours I think) so your fork will match with any changes in the original repo. If your github has more than one fork, it will do them all so do whatever it takes to disable pull for anything you don't want to update.

2 Likes

ok

Would it be possible to only return a response to the Echo where a question was posed? e.g. I have a echo routine "What's the Status of my Garage Door". I would like the answer sent back only to Echo that the question came from.

Alan

Since last update the Echo Speaks lost the auth token every 1-2 days and I need to reauthenticate.

Someone more faced it?

I would also like the response to go back to the device it was asked from!

Download the Hubitat app