[RELEASE] Echo Speaks v3 + Actions

Should Actions be able to run Alexa routines? I can't seem to get it to fire. The test won't even run. Echo Speaks works otherwise as I use it in notifications.

Is it possible to direct the TTS to the last echo spoken to? I use this a lot to respond to status checking and don't really want to broadcast the response all over the house if possible.

Are there any directions anywhere on installing the node js portion locally instead of on heroku?

I don't believe there's anything specific. Node.js is not installed on your Hubittat hub. You need to install it on a Raspberry Pi or other device that supports it.

Yes, I know I need to install it on an rpi. I'm looking for instructions on installing and configuring the echo speaks server app in nodejs.

just run

git clone https://github.com/tonesto7/echo-speaks-server
cd echo-speaks-server
npm start

You will have to make sure to create a service to make it run on startup.
Make sure to select local in the app and it should walk you through setting it up local (It's been a bit since i've tested this process so i'm not 100%)

2 Likes

Tried that

    npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! echo-speaks-server@2.3.1 start: `npm index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the echo-speaks-server@2.3.1 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/pi/.npm/_logs/2019-12-10T03_05_40_695Z-debug.log

log says

pi@raspberrypi:~/echo-speaks-server $ cat /home/pi/.npm/_logs/2019-12-10T03_05_40_695Z-debug.log
0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli   '/home/pi/.nvm/versions/node/v13.3.0/bin/node',
1 verbose cli   '/home/pi/.nvm/versions/node/v13.3.0/bin/npm',
1 verbose cli   'start'
1 verbose cli ]
2 info using npm@6.13.3
3 info using node@v13.3.0
4 verbose run-script [ 'prestart', 'start', 'poststart' ]
5 info lifecycle echo-speaks-server@2.3.1~prestart: echo-speaks-server@2.3.1
6 info lifecycle echo-speaks-server@2.3.1~start: echo-speaks-server@2.3.1
7 verbose lifecycle echo-speaks-server@2.3.1~start: unsafe-perm in lifecycle true
8 verbose lifecycle echo-speaks-server@2.3.1~start: PATH: /home/pi/.nvm/versions/node/v13.3.0/lib/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin:/home/pi/echo-speaks-server/node_modules/.bin:/home/pi/.nvm/versions/node/v13.3.0/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/local/games:/usr/games
9 verbose lifecycle echo-speaks-server@2.3.1~start: CWD: /home/pi/echo-speaks-server
10 silly lifecycle echo-speaks-server@2.3.1~start: Args: [ '-c', 'npm index.js' ]
11 silly lifecycle echo-speaks-server@2.3.1~start: Returned: code: 1  signal: null
12 info lifecycle echo-speaks-server@2.3.1~start: Failed to exec start script
13 verbose stack Error: echo-speaks-server@2.3.1 start: `npm index.js`
13 verbose stack Exit status 1
13 verbose stack     at EventEmitter.<anonymous> (/home/pi/.nvm/versions/node/v13.3.0/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:332:16)
13 verbose stack     at EventEmitter.emit (events.js:219:5)
13 verbose stack     at ChildProcess.<anonymous> (/home/pi/.nvm/versions/node/v13.3.0/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack     at ChildProcess.emit (events.js:219:5)
13 verbose stack     at maybeClose (internal/child_process.js:1027:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:285:5)
14 verbose pkgid echo-speaks-server@2.3.1
15 verbose cwd /home/pi/echo-speaks-server
16 verbose Linux 4.19.75-v7+
17 verbose argv "/home/pi/.nvm/versions/node/v13.3.0/bin/node" "/home/pi/.nvm/versions/node/v13.3.0/bin/npm" "start"
18 verbose node v13.3.0
19 verbose npm  v6.13.3
20 error code ELIFECYCLE
21 error errno 1
22 error echo-speaks-server@2.3.1 start: `npm index.js`
22 error Exit status 1
23 error Failed at the echo-speaks-server@2.3.1 start script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]

Hi, @tonesto7. I updated to the latest version of each of the Echo Speaks components yesterday, and I noticed this unhandled exception in my logs this morning:

I have only a single Echo Speaks device (an "everywhere" group) set up at this time, and the error arose in the middle of the night, while there otherwise wasn't any activity in the house that I know of. Just wanted to bring this to your attention. Thanks!

Over the last couple of days I started getting error messages from Echo Speaks. Yesterday I updated the echo speaks apps/device to the latest version and I'm still getting error messages. Can somebody please tell me what may be the cause and what should be done to correct the errors. Below is a snapshot from early this morning:

Running Echo Speaks- 3.3.0.1 and Hubitat 2.1.6.118

Looks like Echo Speaks wasn't able to communicate with your device or with Amazon's servers at that time. I wouldn't worry about it if you only see it once, could be caused if your devices weren't connected to the internet at the time or Amazon's servers were having issues at the time.

Thanks for the reply. The error messages have been consistent over the last week and have been in the wee hours of every morning. I haven't seen any internet shut downs- I typically get a message from my security system if the internet went off line. I'll reboot my echo devices and keep an eye on things.

First of all Thanks for your hard work @tonesto7,

I am trying to install echo speaks but hitting the above error, I think because I am hitting amazon.com and my devices are at alexa.amazon.in . Is there any chance I myself add that or Do you have any plans to add the zone yourself.

Or am I missing any thing config related. I have deployed multiple times but here I am.

Thanks .

@tonesto7 any thoughts?

It is there, maybe not clearly stated:

Step 5 on this page:
https://tonesto7.github.io/echo-speaks-docs/installation/hubitat/device_install/

1 Like

I can get the amazon.in added today

3 Likes

[RELEASE] Echo Speaks v3.3.1.0

Main App (v3.3.1.0)

• FIXED: More zone condition and activation fixes.
• ADDED: New Zone history viewer in the Zones page.
• ADDED: Alexa Routines now allow you to add a name to them so the app now supports the name field(Meaning your actions routines will be easy to identify).
• ADDED: new amazon.in domain name.

Action App

• ADDED: Use Acceleration devices as triggers and conditions #175.
• ADDED: Alexa Routines now allow you to add a name to them so the app now supports the name field(Meaning your actions routines will be easy to identify).
• ADDED: Support for duration in minutes text variable #179.
• FIXED: Other bug fixes.

Zones App

• ADDED: Use Acceleration devices under conditions #175.
• ADDED: Zone Activation changes are now logged so you can view them.
• FIXED: Other bug fixes.


Other News:

Amazon added a couple new items to routines (Thanks @TonyFleisher) :

  • You can now give each routine a name
  • You can execute IFTTT actions
1 Like

Wow, Thats is wicked fast . Thanks a lot @tonesto7, IT is working fine. And started it right away.

Regards,
Pugazhendhi M

2 Likes

OK soo iv tried everything. I can seeem to log into the Amazon Login Page. It works, it says that its all been done correctly with this grey screen but when it takes me back to the home page it tells me to log in again! Its getting really annoying so if anyone help then that would be great. Thanks

So i was able to get a screen shot of a page that flashes RIGHT BEFORE changing back to the normal 'GOTO LOGIN PAGE' screen.


https://gyazo.com/525a79b90bbbec62043b82b68dbf0f31

Download the Hubitat app