[RELEASE] Echo Speaks v3 + Actions

Does this 404 error still happen on 2.2.5.122?

Shouldn't with ES 4.0.2.0. Tony pushed out a fix last night to address the issue.

1 Like

No it’s 3.6 I believe. Should I remove and re do everything? Or is there a way to update it?

I had to remove HPM and then reinstall it to pull the new version, but you may be able to have HPM do a repair and get it.

Sorry. What’s hpm?

It's the best way to install apps and drivers (and keep them updated).

What do you mean by this?

My server lists v.2.6.0

I did an update last night via hpm and I just did a repair but still not showing v.2.7.0 like your is.

Looks like you may need to redeploy the server.

1 Like

As in the heroku server?

I was trying to figure out what individual file the server was referring to.

Thanks.

Still my “work” day so I will attempt later this eve

If you aren't using HPM then you'll have to manually update the code:

For the Apps use these links for the import URL:

Echo Speaks: https://raw.githubusercontent.com/tonesto7/echo-speaks/beta/apps/echo-speaks.groovy
Echo Speaks Zones: https://raw.githubusercontent.com/tonesto7/echo-speaks/beta/apps/echo-speaks-zones.groovy
Echo Speaks Actions: https://raw.githubusercontent.com/tonesto7/echo-speaks/beta/apps/echo-speaks-actions.groovy

For the Drivers use these links for the import URL:

ES Device: https://raw.githubusercontent.com/tonesto7/echo-speaks/beta/drivers/echo-speaks-device.groovy
ES Websocket Device: https://raw.githubusercontent.com/tonesto7/echo-speaks/beta/drivers/echo-speaks-ws.groovy

2 Likes

Correct

You could just replace "master" with "beta" in the import URL.

I am using HPM. And I tried a repair as well. I will do a manual match up to see if files are synced properly.

Edit. I now see that was a reply to someone else. Whoops.

Did you need to do this step with the latest upgrade?

HPM says mine is up to date but not v4
image

You young whipper snappers with your fancy package managers, back in my day we just we just went to apps and drivers section and updated our code the old fashion way. We copied and pasted .

No really, I couldn’t get HPM to uninstall, complained that it was in used and refused. I just went to GitHub pulled the code form the Beta branch and pasted, redeployed my server via the manual instructions and I was good.

2 Likes

So there is the production version (note 1 in this thread)

and a beta version (more recent notes from Tony - look over the last 3-7 days for his posts)

On the beta version, it can be installed from HPM (or matched), but you may have to remove HPM and re-install / rematch as Tony moved file locations around in the beta version.

As other have mentioned you can also update the files individually (all of them however).

1 Like

LOL I've been with smartthings since v1 many years ago.... But I like the young reference. :slight_smile:

The 4.0.2 branch is officially Beta so you’d have to force it. The process described above says to go to HPM and do a new install of the beta version, then remove HPM and reinstall it, and then do a Match and select the Beta version. when it asks which version.

OR

Use the links I posted above to do a manual import to each of the apps and drivers.

Will that be on all devices and app codes?

Download the Hubitat app