[RELEASE] Echo Speaks v3 + Actions

Do any of these device names have unusual (non alphanumeric) characters or symbols?

No - all standard letters, and when it works, it works great - it just stops for some reason...

Hi, @nh.schottfam - I did try that, as well as a full power off, and also power cycling the echo devices and restarting the Heroku instance - they do not seem to do anything...

New setup...everything goes seemingly perfect during the install...and I see my various echo devices listed in the Hubitat Devices section, but ZERO devices "Installed" in the Manage Devices section of the ES app.
In the ES Status section, I see that three actions are listed as PENDING...one of them being "getEchoDevices". This seems to be why I'm not seeing any devices listed in the "Manage Devices" section of the ES app.
Not sure where to go from here.

Make sure you have all the apps and drivers code installed. I forget which one it was that I missed before and I had the same result as yours.

Use Hubitat Package Manager to install, it makes sure you don't miss anything. [BETA] Hubitat Package Manager

1 Like

Certainly worth a shot.
But being new to this and to make sure I don't royally screw up what little I already have, what are the steps to installing the beta package manager?

Is this the beta github?

Do I go into Apps Code and import or something else?

[EDIT] Think I've got it......it's matching installed apps and drivers now....

Okay...installed.
Removed all of the ES stuff previously setup.
Ran the HPM and did a search for ES. It has a listing but there's a checkbox that is already checked for ES. Clicking on the Next button just refreshes the search results.

[EDIT2]
Used the beta HPM's uninstall menu option to uninstall ES. Then searched for ES again and this time it didn't recognize it as already installed. Ran the install for it. Says it installed successfully.

[EDIT3]
And completed the rest of the setup. Now seeing the managed devices, unlike before! Thank you!

1 Like

Noob here... having an issue that I can't seem to figure out. Got Package Manager installed. Using this, I installed Echo Speaks and followed through the directions @tonesto7 published. I get to Step 6 of the Heroku server configuration and when I hit "view", no additional screen comes up to perform the amazon login.
I did have ES installed for my ST setup, but I deleted that server from Heroku since it wasn't in use any more. Any ideas?
image

Sorry of this was answered before - I looked all over first to see if I could find an answer.
Edit - I think I got it sorted out by clicking around in Heroku.

1 Like

Wow. it’s been some days since I last visited the community.

I was pretty ill with what ended up being COVID-19, but now I’m back to feeling more like myself so I just wanted to provide an update on the progress of the next release.

I've been working with a platform wizard @nh.schottfam and he is helping me optimize ES to significantly reduce resource (DB, CPU Cycles, Network) usage and I have to say it's running amazing.
I haven't even started on adding new features yet or defining the new lite mode. I honestly don't think a LITE mode is necessary on Hubitat after all of these optimizations.

It's probably going to be a couple weeks before I release a beta but I'm excited so wanted to share.

25 Likes

Hope you're on the way to a full recovery, thanks for everything you do :smiley:

1 Like

Thanks for the update. Sorry to hear you were sick, glad you are doing OK.
:mask: :nauseated_face:

Looking forward to updates!
:heart_eyes:

1 Like

Could I ask for a bit of direction.. I have been working on this for an hour and not having any luck.

I have a virtual switch created (tied to a Christmas tree etc..) that when I turn on, triggers Echo Speaks to play music on my Echo Dot. - works great.

Now, when the VR switch turns off, I want to have the Echo Dot stop playback.

Where am I missing how to send a 'Cancel' or 'Music off' command?

Thanks

Just tried this... On the device screen, I see there is a Pause and a Stop command. Both seem to work for me. There is also a "Stop All Devices" that works when the music is playing on multiple devices. Do those work for you?

Update: I just setup this rule and it works perfectly for me. Plays when I turn on the switch, stops when I turn it off.

Do you have "turns changed" as your trigger? If you just have "on", then the rule will only trigger when the switch is turned on... I've had that happen to me...

Oh... Looks like you are using Rule Machine?

I was trying to do it with the Echo Speaks action I created which has the music search string within it.

But maybe I should use Rule Machine to trigger the cancel.

Ah! I never used the Echo Speaks action...

You could set a Rule Machine rule until someone familiar with actions can pipe in with some tips... You would just need to trigger on the "off" command then, leaving the action to deal with the on command... Just a thought...

1 Like

Take your time. I work at a very large hospital and have seen first hand how hard this thing can hit. Your health is way more important.

Looking forward to the updates. Please reach out if you need any help with testing.

4 Likes

Glad to hear that you’re okay. I think I had it back in February before tests were being administered. My family had all the symptoms and was diagnosed with pneumonia. Next day I was renovating my basement and ended up in the ICU. Woke up 3 days later from a coma in restraints and they told me I had a rare form of Pneumococcal Meningitis. Thing is I’m relatively young and healthy but it’s really kicked my butt. I’d recommend loading up on the Vitamin D and just taking it easy.

1 Like

I just added a Echo Dot 4th gen to hubitat. I currently have a 3rd gen Echo dot that does text to speech e.g. %device% open. I can't get the new 4th gen to speak with my simple door open rule. I have double checked and the rule has both the old echo and new echo as speech on devices. I did notice in echo speaks app that the old 3rd gen has Announcements and Text-to-Speech set to (True) But the 4th gen it is set to (False) and I can't figure out how to enable it.

1 Like

For support reasons, not every device works without some form of verification... It may take a couple of weeks but I will enable support for the 4th gen

3 Likes

Confirming

Download the Hubitat app