[Release] [App] Circadian Daylight (v0.80) (Port)


Works for every CT/RGB/Dimmable device supported by Hubitat.

I’ve updated the descriptions in my development build to better represent that :slight_smile:


Hi. Yeah, it's me from the other thread.
I don't know the etiquette in this form at the moment so I come straight at you with this:

could you program an app with the function demonstraited in this video?
I would use it by trigering it from the Google assistant witch is tied in to the Google clock app... a perfect weak up light.


You’re a mind-reader.

I’m actually working on an implementation similar to this already. No set release or coding on it yet, though.

In the meantime, Rule Machine has a great Dim over N minutes function that’s been tying me over.


I use sleep as android at the moment. but just because it turns from a dark red slowly to a nice daylightish white. Did not even have to convince my wife for that :joy:
But I hate to have too alarm clock apps (or also other single purpose stuff on my phone/in my house). That's why I want so badly get rid of the hue bridge as well.

Good luck then


I grabbed the version from the 1st post but modes option doesn't seem to work. Has this been fixed?


In the latest version that I’m testing, yes. You mean:

Disable when in these modes



Hey Adam,

is it intended that the mode override to get warm colors (Sleep Modes) only works when the current time is past the sunset time. E.g. I have a light coming on very early in the morning (still in my "Night" mode) but it comes on as daylight. I can see in the code that you filter it based on the sunset time:

def getCTBright() {	

	if(location.mode in settings.smodes) {
		if(currentTime > sunsetTime.time) {
			if(settings.dcamp == true) {
				colorTemp = coldCT
			else {
				colorTemp = warmCT
		if(settings.ddim == false) {
			brightness = 0.01

The if(currentTime > sunsetTime.time) is what is throwing it off...
I took that filter out for in my local code but I figured I ask as it goes against the "Protip: You can pick 'Nap' modes as well!". At least for me, my nap times are not always past the sunset time :slightly_smiling_face:


Nope. I'm not sure why this was done in that manner. I still have to refactor those variables, so I'll fix that in the same swoop. What was version 0.73 has suddenly gained enough functionality and changes to be 0.80 :crazy_face: I've jumped ahead in my pipeline for development, but that's fine with me!

I'm out traveling the next couple days, but will do my best to get a release by Friday :slight_smile:


Same here. The moment sunset time passes, lights turn on at coldCT. Was waiting for someone else to notice :wink:


Thanks! I'll fix that for ya.


This is a app I need for the winter.... were I live the sun goes down at 4PM the earliest and doesn't come up until 9AM and it completely throws me off.

I need it to simulate daylight for summer time so my brain clock doesn't tear itself apart.

BTW many military members suffer worse from this issue if they also have PTSD like me.


Same here. I have some LED strips hidden behind curtains that I use to simulate sunlight/sunrise and help keep our house's heads together. :slight_smile:


The VA will give disabled military that suffer from PTSD and depression head gear that has LED lights on the brim to simulate daylight and help keep them stable. They are bulky and not very friendly at all.

Circadian lighting for the whole house is a much better idea !


That's a great idea...


:wink: Having that many separate light strips is one of the reasons I like the MagicHome controllers so much. Takes the cost down a ton.


Muuuuch lower priced than the fibaro or qubino controllers


I just set this up to work with my motion lighting apps, instead of specifying the levels / temps in there. Feels like this would be a good balance between the full blown Rooms Occupancy setup I used to have, and just plain Motion Lighting apps with limited, per-mode settings.

However, it seems like the dimming is much too aggressive. I currently have sunset override set for 10:00pm, and minimum brightness override set to 30, and my lights are still dimmed down to ~38% right now.

I'd prefer being able to not start dimming / transitioning CT until closer to bedtime. That's one thing I miss from the Rooms Occupancy suite, giving an explicit time range for dim and CT to transition.

Does it seem right that, 3 hours before "sunset override" time, with a minimum brightness of 30%, that the lights would be set so low so early?


Is your sleep mode enabled when that happens? I’d try removing that and see if it fixes it. Sunset offset should be working.


I was in 'Day' mode when I wrote the post, and am now in 'Evening' mode as I respond now. I set 'Night' for the sleep mode in CD, assuming that's right for what I want.
I hadn't set any specific modes at the bottom before, but just went ahead and changed it to 'Morning', 'Day', and 'Evening', not sure if that's required or not.


I should honestly probably just rework/reimplement that section... it’s kind of confusing. I never check it since we don’t use modes. Our house is too fluid, unfortunately.

Have you noticed any change with that? There’s a bug in the current release where those only enable past sunset, anyways.