Refresh Scenes?

Does anyone know how to force a scene to evaluate (on/off)?

When looking at my groups and scenes section from the main app page, one will show "On" when it is not. If I 'open' the scene to configure it, it refreshes and shows "Off".

I'm looking for a way to trigger this systematically out with a virtual button press, etc.

Nothing on the "Apps" page refreshes dynamically, but a refresh of the page on your browser should do it. You shouldn't need to actually open the Groups and Scenes app or any group or scene itself for this to happen (though doing so would also make your "Apps" page refresh when you went back--same outcome, just not the reason why).

There is no way to automate this, at least on the Hubitat side--it's more of a browser thing--but it's also just a display issue that would not affect regular use.

1 Like

Yeah - maybe I should clarify - it's not the actual apps page but the 'scene activator' switch that comes with each Scene. I assume this is what rolls up to the apps page?

What I'm trying to do is 're-push/activate' a scene using that activator button switch but it shows as 'on' when not in some cases. If I open the scene itself, both the apps page and scene activator button shows off (this is what I'm trying to mimic - this 'refreshing' piece). Once I do this step, then I can trigger the scene activator button switch again. It's as is if the "on" command does nothing since it already says it's on, when it's not.

Here's an example. These screenshots were taken in order without changing any devices or activating any scenes, etc.

image

Once I click on the 'scene' as to edit it, there is some refresh/reevaluation that is being triggered and this is what I'm after:


Now these show accurate:
image

and now I can easily just turn 'Day' On and it will activate the scene fully and complete it.

I'm not sure about the original issue, then, but regarding the behavior of "on" specifically, do you have activation optimization turned on in the app? If so, turning it off may help. That being said, the scene state should update in response to any relevant member device changes, so again I'm not sure about that.

Yeah I do have that turned on for almost all my scenes, but that's because I was getting better completion rates with it being enabled vs disabled. Chatting with @bravenel we enabled this to assist with what he thinks was the network being overwhelmed.

I was thinking if there was any way to trigger this refresh of the scene itself, I could then use some RM logic to trigger the scene to re-activate if it was turned on recently (<2 mins, etc) and then showing as inactive.

Yeah, if your devices report correctly, it should help. It almost seems like maybe the scene app either isn't subscribing to device changes or correctly processing the ones it does see, possibly only in certain cases (maybe a specifical attribute?), and opening the scene child app must force a re-evaluation. Bruce might have more ideas, and maybe it would be possible to reproduce this behavior with fewer devices to see if when it happens can be narrowed down.

Back to your original question, there isn't a "real" way to do that, and I'm not sure I'd recommend it, but if you really need a workaround, an HTTP GET on the scene page would probably do it (easy enough from RM if you don't have hub login enabled, but again I'd be curious what's actually going on instead...)

1 Like

There's got to be something with the scenes. I just edited my rule (mode/scene sync) to not trigger the scene per mode for evening and instead just listed all the same devices/settings as actions in this rule and everything set correctly. And all without delay, optimization, or discrete settings of course bc they don't exist in RM.

It will take a while to convert all the scenes into RM actions, but I'm going to try this over the next couple days and see how behavior is. Super curious why this might be more successful, seems the scenes are a much more delicate approach.

And one more thing to point out, is that if anything didn't set correctly, all I'd need to do is trigger this rule, which doesn't care about the state of the scene activator switch anyway.

Download the Hubitat app