[RE-RELEASE] EcoWitt and Wittboy Weather Stations And Sensors (Local)

Thanks Simon, works perfectly, even for 2 gateways.

1 Like

Which IOS app? I see three:
-WS view
-WS view Plus

My GW2000 and WS69 will be arriving next week.

Based on this instructional video I expect it is the EcoWitt App you want:

The WS View App is what I use on my older GW1100 gateway, so I expect the EcoWitt App is just the next evolution that likely came out with the release of the GW2000.

1 Like

All.of them work.

1 Like

Personally I use the Ecowitt app; seemed the cleanest when I tried them.


I have Ecowitt and WS View+ on my phone, but really Ecowitt is fine for the majority of what you’re going to be doing. If you are getting in using Wunderground or something like that you may want keep WS View+ around, but it really isn’t necessary. WSView is just a stripped down version of WS View+ and kind of useless.

On my little console, the Ecowitt app gives you an option for auto update of firmware. On my big console, you can pick that option on the console. Maybe look for it for your GW2000 (I don't have one).

First off, ecowit and this DH is awesome. Cant believe I waited this long to switch over.

  1. If I go to the "Weather Map" page I noticed I can click on other users stations and change there app page displays!!! Is it correct to assume that this only effects my view of there station and not there's?

  2. And this elevation setting for pressure, is 0 ft atmospheric pressure, meaning the pressure at my elevation. And if I enter an elevation > 0 it Calculates Absolute pressure like what it would be at 0 ft? Whats the industry standard here. I plan to get another station for my place at 3500ft.

No, I believe it defaults to 0 feet, so enter the actual altitude of your weather station in that box.

1 Like

I'm not quite sure what you are referring to here.... Is this inside the EcoWitt App on your phone / tablet?

@marktheknife is right, this is intended to record the elevation of the weather station, allowing for both relative and absolute pressure to be reported.

1 Like

I've got an issue I'm trying to get corrected. I've updated the Ecowitt device type for both the gateway and the sensor. The data is streaming correctly, but I'm constantly getting an error code every 5ish minutes in the data log. I would like to try to get this resolved.


When you say:

Do you mean you selected a different driver? Are you able to post a screenshot of what they are now?

Did the errors only start appearing once you made this change?

These errors have been there before the updated code. I'm using the device driver code from @sburke781 github.

Oh, so you updated the drivers through, say HPM, or by copying / pasting the code from my repo?

@sburke781 I updated them manually, as this Hubitat hub has no source of internet connection. Everything is on a local connection. I updated the drivers hoping it would have fixed the problem.

Ok, thanks, I was just wanting to confirm that you were referring to updating the code, not changing the driver selected on the Device Details page.

For those interested, I expect the part of the code that is producing the error is one that compares the driver version recorded on the Gateway device, to the version captured in the driver code. Basically, making sure the driver version recorded in the HE Gateway device matches the code I have released.

    // If the driver has been updated on the HE hub, check that this is reflected in the driver attribute
    // If not, run the version update to record the correct details
    if(!(device.currentValue("driver").startsWith(versionExtract(version()).desc))) {
      logDebug("Driver on HE Hub updated, running versionUpdate() to update the driver attribute");

There are one or two other possibilities, but my money is on this for now...

Can you post a screenshot or just a description of the EcoWitt Gateway device details page, in particular the Current States section, often on the right-hand side. Don't include the mac or passkey in the screenshot, or blank them out. I am particularly interested in whether the "driver" entry appears there or not (I'm thinking not....), but if it does, the value would also be useful. E.g.:

@sburke781 I'll provide this information later tonight, as I currently don't have access to the hub.

Thanks for the quick responses.

No worries. If you have time, just one last question.... Were you already running my version of these drivers successfully, or had you recently tried to move from Mirco's original version to mine and then started seeing these errors?

I believe I've been running your driver's this entire time, but I've never looked at the logs until now.

Ok, thanks for that... May not have made any difference, but was just wanting to make sure there wasn't something in the process of migrating to my version that could have been at play.