Random Zwave devices not working

Sometime today, random Zwave devices just stopped responding at all. There is nothing in the log file. I rebooted the hub and still there are several devices I can't access. Examples are a couple GE Zwave wall switches, an Aoetec Siren 6, and a ceiling fan. Another example is one Ikea Tradfri plug works great plugged into a lamp. Another lamp just like it with a plug just like it I can't access. I have rebooted the hub more than once. I haven't made any home automation changes in probably six months. This is the first time something hasn't worked. No way to debug this. Ideas?

So the issue with both zwave and zigbee devices?

You might wish to try a complete power down, wait for 30 seconds and then power up. Do the power down after a shutdown from the GUI. And disconnect power from the wall adapter side.

If that doesn’t help, try a soft reset and restore.

Only Z-wave devices and then only a half dozen or so Z-wave devices. The power down from the GUI and power back up did not restore the broken devices. How can a perfectly running system for the last year suddenly do this? Is Z-wave network corrupted?


What about your IKEA Tradfri devices?

1 Like

Just to be clear, did you remove power (for at least 30 seconds) after shutting the hub down?

1 Like

Yes, I did. No effect. I would say that maybe 8 Z-wave devices out of maybe 60 are not responding. All my Zigbee and Philips Hue devices through the Philips Hue hub have no issues at all. My Aoetec Siren 6 just displays a bright white light that can't be turned off and its siren and chime are inoperable.

The Ikea plugs are Zigbee, aren't they?

If your issue is really just with zwave devices it might make sense to take a look at your zwave details page. That can help isolate an issue.

After looking everywhere and doing the soft reset and restore, nothing fixed the issue. I have mostly Zwave switches that are out, a Zooz relay, and a siren. Each of these devices have links to at least 5 apps, so I was not really interested in deleting them and readding.

I haven't found an easy way around this issue. I wonder if this might be a good time to dump the hubitat and go to home assistant. There was no changes and no reason for the breakage and I have neither the energy or patience to constantly fix things that should not break to begin with. Does anyone have any parting ideas how to fix this before I move on?

Did you ever take a look at your zwave details page and check for ghosts?

1 Like

@brad5 My Z-wave details page lists nothing in the "route" column for the devices that are not working. The total count of Z-wave devices not communicating is 15. I have 16 Z-wave devices that are still functioning. It appears that toward one side of the house in particular are where the failure has occurred. I have made no changes in any home automation devices at all in over 9 months. All Zigbee devices and philips hue devices have no failures at all.

Possibly a Z-Wave repeater in the mesh (one key to connectivity of the side of your house having issues) needs to be rebooted (or has failed outright)?

The controllers in these things are supposed to have imbedded watchdog timers to detect hangs and auto reboot, but aren't infallible. Maybe try cycling the mains power to each of them in succession will find one that needs to be restarted.

@Tony Ok, I finally fixed the problem. This is EXTREMELY odd. So, I ended up powering off the house mains for three minutes and then back on. Problem still existed. I then did a Z-Wave repair and the repair reported things working that were not and things not working that were. Then, I did a repair on my devices one by one. Most failed. Some that reported successful were working prior and some were reported working but had been failed and still failed. On a whim, I executed the global Z-wave repair after the one by one failed repairs. This time, all but device 1D, 1F and 10 successfully repaired. Ironically, 1D, 1F and 10 had always been working and are still working. Bottom line, mysteriously everything is now working without exception. I can only assume that while I was at a family emergency in the hospital last week, there was a power glitch too brief to be logged. That apparently hosed things up until I cycled the mains. Then the Z-wave repair did not work until I did a one by one Z-wave repair that appeared to have failed. Finally , I executed the overall Z-wave repair and everything came back. I have no idea why a bad report on 1D which is an Aeotec Siren 6, because it is a multifunction Z-wave device and its Z-wave ID for the chime showed up and repaired but the Z-wave device for the siren did not. Yet, the siren was always working. The 1F device is a Jasco wall switch in my office only 10 feet from my C7 hub and it was and is working with no issues. Finally, the 10 device is a siren in the garage and it never had any issues and still works. So, hopefully this post helps someone. My conclusion is that when you experience a Z-wave problem like mine, try standing on one foot, hopping, and holding your nose while singing yankee doodle. Wow, just wow.

Glad you had success. I suspect that cycling power did indeed restart a device that was a key part of the mesh, and once it got going again repair was able to do its job.

One thing about Z-Wave repair that adds to the frustration factor is that sometimes it takes more than one repair to get everything working. If devices at the far edge of the mesh are inaccessible because the controller's neighbor table needs updating (and the furthest away has only a single neighbor which is itself also stranded), it makes sense that the first repair would get devices with multiple neighbors going while a second repair will be necessary to affect a device that is only within range of one that came online from the first repair. And depending on what you read, exactly how long it may take for the effects of a repair to ripple through the mesh seems to be unknown.

@Tony your description of the iterative process is actually extremely helpful. I can see how branches of a mesh could be "orphaned". When using any mesh technology we are creating a neural network that, in theory, should provide multiple redundant pathways. Apparently Z-wave has persistent pathways in its mesh. Those pathways, if broken, do not appear to be self-healing. Also, as you have pointed out, multiple repairs may be needed to make everything whole. I may wait for a day or two and do another overall Zwave repair to see if 1D, 1F and 10 repair successfully even though they are working now. Very odd indeed sir.

Actually I still don't understand why a single pass Z-Wave repair should not work, at least in theory. It would seem that any stranded node, even at the periphery, should be capable of receiving (and responding) to broadcasts during the neighbor update process. The advice that more than one Z-Wave repair may be necessary is pretty old and may have been obseleted by newer iterations of the protocol. I know full Z-Wave repairs are not recommended as a front-up recovery method, but when you've tried what 'the book' recommends, you have nothing to lose.

As has been mentioned in other recent threads in the forum, Silicon Labs has some bug squashing yet to do with the 700 series; hopefully they can get things ironed out before sunsetting development of mesh support in the SDK in favor of Z-Wave LR.