Qubino DIN Dimmer compatibility

Hi Hubitat staff! I have been wrestling with my Hubitat setup for more than a few years now. Whatever I do (and believe me, I have tried just about anything, including some of the stuff that is documented in my threads), I can't get scenes and groups to work properly. Last try was that I bought a C7 (my third Hubitat so far...) just to be able to manage the ZWave radio better than the C5 - I am in Sweden/Europe.

Anyway, since most of my devices are Qubino DIN dimmers, and after I have tried just about everything except replacing them, I suspect they are at issue, but before I spend thousands of dollars to replace them, I need to check something with you.

I communicated with Qubino in september 2020, and they told me that they had sent you the devices, for you to write device drivers. Before that there were no official drivers for the DIN dimmer, so I tried other drivers - but soon after this, official drivers did show up. But I still have the same issues with the official drivers.

So, the question is: did you have any issues with the Qubino DIN Dimmer when you wrote the drivers since they are not on the Compatible device list? Specifically my issue is that they don't always turn on or off when there is a lot of traffic, such as when turning a group on or off, or setting a scene. For a single device it works flawless, when there is less than a handful of devices the group/scene works fine 95% of the time, but for a group with 30-ish devices there are always some devices that are not triggered, anywhere from 5 to 20 does not react.

And if you did not find any issues, and they not being on the compatibility list is simply a mistake, could you please consider to revisit them and see if there is anything that can be done in the driver?

Tagging @mike.maxwell and @bcopeland

In the meanwhile, @phjalmarsson - have you tested whether metering (say using a relay of 100ms) improves the situation when controlling a group of 30+ z-wave devices?

If you would like to test this, you can open/edit any previously created Groups, then "Enable metering", and add a delay of 100 ms. If everything works with 100 ms, reiteratively try lower values, until you find the smallest value that works.

1 Like

Yeah, tried that many times, with as much as a 1000ms delay, and it still does not help. At least not much; since the issue is intermittent, it is hard to tell exactly.
Just for fun I tried 1000 ms again (might have been the first time since migrating to C7) once and it turned on all except one dimmers. I use 100ms as standard otherwise - just tried again and 4 out of 30-ish did not react.

When I was fiddling about last night, for some reason it worked consistently much better (=less bad) at turning on, with around 10% not turning on, while for off, about 70%(!) did not turn off. More or less consistently over a handful tries. Different dimmers that did not react between different tries, although I do have one that always seem to work.

I assume you’ve also tried all the standard zwave troubleshooting? Like removing ghosts, and stranded devices, checking for frequent route changes, low SNR etc etc?

I have to admit that I don't know what "frequent route changes" and "low SNR" (although I can guess) are, and even less how I can troubleshoot it; no one has mentioned that in any of the other threads where the issue has been discussed over the years. Any help with that/pointers in the right direction would be greatly appreciated.

Look at the your Settings -> Z-Wave Settings page.

What is the LWR RSSI value for each device? Positive values are acceptable. But values greater than 10-15 would be better.

What are the number of route changes per device? My hub has been running for about 2 weeks now. One of my devices has 7 route changes. Most of the others are at zero. A lower value is better here. Values above 20 are not good.

Thanks, amazing how much more you can see with a C7 than a C5!

LWR RSSI are above 30 for all devices except for a battery-operated button that has 19. That's for all devices that reports it - there's more than a few that doesn't have a number at all. What does that mean?

Route changes are HIGH for some. A couple has 60, but they are outlet switches that are moved in and out from the terrace every now and then.

  • A couple of the dimmers are above 15 and some are above 20, and that seems to be the ones that are unresponsive most often.
  • The DIN Dimmers that are mounted on the same rail as others have the highest values. A few that are mounted by themselves have lower values.
  • None of the other devices (non Qubino DIN) have a higher value than 10 (except for the outlet switches)

The mesh should be a very uncomplicated one. The hubitat is in the middle of the apartment, and all devices are within 7 meters. After installing the new C7 hub, I did take care to add things starting with the devices closest to the hub, but that's with a meter accuracy, not centimeter.

I can't see why there should be so many changes? No devices are moved about, except the outlets as described, and the battery-operated buttons when they are charged, but nothing should be meshed through them, right? Could it be external interference? I live in a large-ish city (Stockholm), on the top floor, and there are a couple of cell "mini towers" on most sides, and a ton of neighbouring WiFi access points. But that's not the same frequencies at all. Neighbouring Z-Wave? How can I identify those?

Would Repairing the whole Mesh, or troublesome devices by themselves, help?

Perhaps by looking at the Zwave Mesh program, you will be able better to see what's going on with your zwave mesh:

1 Like

Maybe you should post your Z-wave details in a screenshot (all columns and rows). We might be able to spot an issue.

Thanks everyone for the replies. I just cross-referenced the device list with the Z-Wave details page (WHY can't the hub do that, or at least let us export the lists to csv or something?!? :angry:), and it seems like a couple of the devices I thought was battery-operated remotes were actually ghosts.

So it seems like it's time to pull out the old Aeotec stick and delete them first before disturbing you guys anymore, because deleting ghosts does not work even on the C7 (how come Hubitat can't fix that?!?). I'll be back once that's done, but the work week starts now and I need to get some sleep, so it might be a few days.

1 Like

Actually, depending on the ghost, it can. If the ghost is unpowered, delete works pretty well.

1 Like

Not for me I¨m afraid. I had 10 ghosts, and neither one could be deleted from the hub interface. The PC Controller method worked well though.

Hi @phjalmarsson,

The problem with these is that by default are included with S0 security. This is buggy with the qubino's and causes them to drop off the zwave network. This does not only happen with Hubitat btw.

The solution is the clumsy way to pair them using a USB stick zwave secondary controller. This topic shows details of how to add such a USB stick (Z-Wave Ghost Removal using a UZB-Stick - How To - #3 by danabw)

PS: if you use Alexa de default drivers will make it show as a Temp sensor with no option to change. You can control the dimmer functions by voice, but not in the alexa app. Here are some drivers to avoid that: Alexa shows wrong device type for Qubino DIN Dimmer

Cheers Rene

Ok, so now I've excluded the gosts. I need to apologise for my wording in the initial post - it seems I had a total of 10(!) ghosts, and I most certainly should have checked that before posting using those words. However, the problem persists, see last paragraph.

But after removing the ghosts there's another problem: almost all Qubino Dimmers stopped working in a very "interesting" way. I'm guessing that those are the ones that had related ghosts?

  • They check out in PC Controller (i.e. the "Is Failed" function show them as not failing)
  • They are listed in Devices
  • They are listed in ZWave details
  • I tried Repairing them individually in ZWave details without errors
  • After getting the same errors after that, I tried a Repair of the whole Z-Wave network without errors.

Now comes the "fun" part. Let's say I send a On command to a lamp that is off. Nothing seems to happen. But looking in the event log there is first a "switch on Type=digital" which I assume is my command, then followed three seconds (in the example I'm looking at) later by a "switch off Type=physical" command, which I have no idea about where that comes from.

Even more "fun" if I look in the log for the device there's three events:

  1. "was turned on" at the same time as the on command in the event log
  2. followed immediately by "was set to 255%"(!)
  3. And three seconds later by a "was turned off"

This was solved by manually setting the Devices to a dimming level of 100%, and after this they work individually again. I'm just putting the above here as documentation in case anyone else has similar problem.

However, after removing the ghosts and getting individual devices to work again, the original problem of some of the Qubino devices not responding during group on/off is still there. :frowning:

So I'm back to my initial question: is there something inherently wrong with the Qubino DIN Dimmers or their drivers? If the latter, can something be done about it?

Thank you very much for your very insightful reply!*) I don't know HOW many hours I have spent googling, searching and posting in the forums over the years, and this info never came out.

I already followed the PDF you referenced to get rid of the ghosts, but I missed the information about including devices via the Z-stick - I did not even know that was possible! I might not exclude/include all of them with that method in one go right now**), but I will at least keep the stick handy at my desk and use that method as the devices drops off in the future***). That thread should really, REALLY, REALLY be linked in Hubitats official docs.

Again, TONS of thanks for this - it might actually put an end to five or so years of misery with the lighting. Never again am I gonna take a chance on non-compatible devices!

As for the Alexa issue; no, I use Google, and there are no such issues there. But thanks for the pointer to the driver code, that could be useful in the future. It certainly would have been earlier. :wink:

Finally a hint to other Qubino DIN Dimmer owners that I just learned by trial and error: when you include them, you don't need to close the circuit according to the instructions, you can just as well hammer the S button. For those of us that only use remotes and no circuit breakers that saves SO much time!

Now I'm just waiting for a final radio-wide Z-Wave repair, and then I can see if maybe the unresponsiveness in groups issue that I started with is still there...

Thnx / Peter

*) And to think I almost missed it since you posted your repIy while I kept editing and changing my previous post for several hours, which apparently makes the forum software believe that I had seen it.
**) Since honestly I am just SO sick of messing with the devices right now.
***) Which they have been doing regularly before. For some reason mostly the ones that are mounted far away from the others in hard to reach places. :wink: S0 is weird by the way; I did notice that I got to choose from S0 and S2 when including (although that choice seems to be gone on C7?), but I thought that S0 meant Zero Security. I even think that there was a help text saying so...
****) Weird that I didn't find it myself, but now I see that it was posted less than 2 years ago, and I did my googling well before that. Well, that's another lesson then.

Hi Peter,

I had trouble with an other brand 700 series hub and it was actually Qubino support that told me about the to them known S0 issue. On that other hub you cannot use a secondary controller. So I tried Hubitat and since they are included with None as security they have been rock solid. I must admit I only have a hand full at the moment, but they are very responsive and never have dropped of once since.

As yes the button work in some cases, but not all. Exclude does not seem to work. Include and factory reset do. Go figure.

Basically I include every 500 series device via the stick method when the first pair shows S0, and so far no more trouble. 700 series devices do not seem to have the problem. Hopefully more of those will become available for the EU region.

Hope you can solve your problem now.

Cheers Rene

1 Like

Thanks Rene. The button works well for exclusion; just long-press for 5 secs or so, per the instructions. Just as hammering for inclusion, it doesn't work every time but after two or three.

But same issues as before sadly. Damn. :frowning: