Qbino flush 1D temp report no longer updating

I believe I've upgraded to the lasts qubino driver from Eric Maycock:

And I have the parameter:
Digital temperature sensor reporting Range: 0 to 127 Default: 0 (Disabled) set to 1 in the driver.

This used to give me temp updates for every 1F, but now the temp no longer updates unless I push a change to the device preferences.

The ercom driver was updated 13 days ago, and the commit has a message of:

Hubitat not properly parsing sensorbinaryreport. Using Notificationreport for sensing i2 open / close

Not sure what that's all about, but again my temp sensor that used to report at 1F intervals is no longer reporting. This is a pretty serious problem for me since this sensor control my hotwater return loop. It's worked for the last year without issue.

have you tried the stock Hubitat Qubino Thermostat Module driver?
I am using the Qubino Z-Wave Plus On Off Thermostat Module ZMNHID3 with that driver and my hot water re-circulation system. Still working fine.

The qbino thermostat is a different device from the fulsh-1D. I know this because I bought one by mistake and it works differently, though they both support an external temperature sensor.

Is there a native driver for the Fulsh-1D as well, or just the ercom one?

yes there is a Hubitat 1D relay driver as well

Alright I found the other DH but I still don't see any temp updates.

I wonder if the sensor went bad or this is a software issue? This is the sensor I'm using:


Yes there is a built-in driver for the the Qubino 1D Relay Module.

The temperature sensor must be attached before the device is joined...

Yeah, it was. As I said, it's been working for a year. Maybe it just needs a reboot, but that's a bit of a problem since I have to flip the breaker to do that... unless I put another switch in? I might have, can't remember...

I am using the same one with my ZMNHID3

have to tried a zwave repair?

Maybe its a zwave problem. I had a bunch of stuff fall off the network that I can't get repaired since the last hubitat upgrade. a yale lock, and a leviton dzpd3.

The whole damn zwave network seems to have gone to sh*t. z-wave repair just hangs for 24hrs. All used to work....

could be a faulty zwave device jamming the zwave network.
I had a GE zwave switch that would mess up my schlage zwave locks whenever it was physically turned on. Removed the switch and everything worked fine again.
I had to power one device at a time off to find the problem device.

I assume you have rebooted the hub.

if you have saved a backup file from before you lost the first device you could try and install that
If that doesn't work maybe try going back to an old firmware version.
I try to always save a backup before doing a firmware update.
I had a firmware update corrupt my hub once and had to get support to create a restore file.

What does "corrupted" look like? I dunno... I reverted to the oldest backup I have. I tried zwave repair again and It prints the first line in the logs then nothing else, just like where I started.

I appear to be TOTALLY FCKED. If I have to rebuild the whole house, the hubitat is going in the trash and I'm doing it with home assistant. This black box thing is bullsht.

In my case rule machine was corrupted and they rebuilt it with all my rules or I would have had to remove rule machine and recreate all my rules again one at a time.

You could try and kill power to one half of your devices and reboot the hub and see if zwave logging is still slow then power off the other half of the devices and power back on the first half and reboot the hub again and test the logging again.
That would tell you if it is a device causing the problem.
I would keep each half grouped as the same types of devices (multiple types in each half)
just in case it is a custom device driver causing the issue.

after that you could try to roll back your hub firmware

I have tried to rollback. I'm trying a platform rollback now... whatever that means.

OK well... I rolled back to and things seem snappier. Then I shut off the zwave poller RE app and the z-wave rebuild is cranking along now too. Fingers crossed...

So it was likely the zwave poller RE app
you should be able to update your hub to the latest firmware again.

maybe I can, but let me see if I can get my original problem reporting again, and my missing light and lock back online, then I'll consider it.

woo hoo getting temp reports again! z-wave repair at 66 of 70 devices...

1 Like

Alright well, after last night the qbino flush1D still wasn't reporting properly. Sometimes it seemed to want to report at 1m intervals, other times it wasn't reporting all together.

I went down to the basement this am and flicked the breaker. Rebooting it seems to have brought it back to reporting .5C intervals like I want, so this seems to be an issue with the qbino firmware. I hate having to do this because it reboots everything else on that circuit too, obviously.

One of the things on that circuit is one of those little iRobot floor mop robots and its charger. Here's a little thing to never do if you're an alleged "software engineer". When the power is lost to the iRobot mop while on the charger, it sends you a little error beep code. Every minute or so. Forever. Even after the power comes back on, it continues to beep until you go tend to it.

If my power goes out for 1 second in the middle of the night, the whole house is woken up by the beep code every minute until I get up and smash all the buttons on the robot, or yank the battery to make it stop.

Does the machine serve me or do I serve it? This has become my #1 deciding factor in allowing new technology into my home, and the vast majority of tech fails this test.