Problem with Zwave outlet and dashboard

I have enbrighten zwave outlet that's been functioning fine since installation over a year ago. It's controlled by a zwave switch near the front door via simple rule that says if the light switch is on, turn on the outlet which are the living room lights. There's also a sunset automation if I'm not home.
Recently, the lights have been working fine but if I tried to control them with my dashboard, non responsive.
I've tried everything under the sun to get this working again and it's just not happening. I've removed the outlet and re-added it to my hubitat, numerous times. I can't get the dashboard to display the outlet, just says unknown. I can control the outlet on the device page for it, no problems. It responds to the simple rule on and off.
Not sure what the issue is but I'm open to any suggestions.

I would do two things. First, make sure that this Dashboard tile still points to this device. If you've removed and re-add d the device, you will definitely have to do this, and make sure that you've also authorized the new device for use in this Dashboard (via the Dashboard app in the admin UI). Second, I'd make sure you're using an appropriate template. For this device, something like "Outlet" or "Switch" is probably what you want. You can check both of these things from the "three dots" menu on the tile.

If that doesn't help, make sure the device accurately reports the value for the "switch" attribute under "Current States" on the device page. If not, no app--including Dashboard--will know its current state either, and with Dashboard in particular, that will cause problems when tapping the tile to toggle its state.

Thanks for the quick reply.
I am very familiar with dashboard app, have the device listed in my "lighting" dashboard.
I now believe my issue is with Hubitat or the device as it is not showing now showing anything for Current States. The device also does not show any activity at all in the Devices page listing, despite me toggling the switch on and off multiple times in the devices info page.
I was able to solve the problem for the near term by using Mirror, which I'm not sure how that APP popped up on my list but it was there last night. I'm guessing there's some sort of issue with the device, which is strange because it's been working all this time.
Thanks,
Dave
PS How do the device ID's in the dashboards correlate to the device ID's in the device page?
Device ID for the screwy outlet in it's device page is "deviceId: 13616"

Sounds like you've narrowed it down to a problem with the device or driver. If you don't see anything under "Current States" (at least not anything that the Dashboard template you're using expects to be there--which for the Switch or Outlet templates would be the "switch" attribute), you'll have problems on Dashboard.

So, looking at how to fix that, the first thing I can think of is your driver. If you can find your exact model on this list (they aren't always that specific), try the driver that is listed for it, which is what Hubitat considers to be the best match: List of Compatible Devices - Hubitat Documentation. If that doesn't work, a driver like Generic Z-Wave Outlet or Generic Z-Wave Plus Outlet would be a good place to start. It's usually a good idea to run the "Configure" command on the device page after changing drivers, so I would also recommend that.

If that doesn't help, there probably isn't much you can do, but maybe there's a driver issue staff can look into (though there may also be community drivers you can try if you want). Turning on debug logging and seeing if anything comes into the logs when you turn on/off the device would probably be the most helpful; you'll likely see a "SwitchBinaryReport" or a "BasicReport" or both, one of which the driver should eventually parse into an event and the other which it will likely skip (most stock drivers log "skip: ..." with the name of the report it's skipping when this happens, but if you're not versed on Z-Wave, just post the logs and someone can see what's up)--and this is assuming anything comes in at all, which if it's not, there is likely a different problem.

The "deviceId" you're referencing is probably in the Device Details section. That is just a numeric value assigned to that particular brand/model of device (and perhaps others that use the same OEM, likely Jasco or whoever makes it for them). What matters for Dashboard is the Hubitat-assigned device ID, which is mostly just visible to you in the URL (e.g., device/edit/xyz, where xyz is the numeric value), but unless you're manually editing the JSON I'm not sure you'll see those anywhere. Further, this is distinct from the Device Network ID or DNI, which for Z-Wave is the node ID (assigned by the Z-Wave controller/hub, normally sequentially as devices are paired).

I think there's something going on with the device itself. It's a standard Jasco outlet and that's what I also have in the rest of the house and they all work fine so I'm thinking it's not a driver and I've removed and re-added it a number of times, even rebooting the hub in between and it's acting the same. I'm thinking something went south in the outlet. It's working fine with the Mirror.

As to the device ID, I'm trying to correlate the "Device" in the JSON with the actual outlet or switch device number.

  "rowSpan": 1,
  "template": "switches",
  "col": 1,
  "colSpan": 1,
  "id": 3,
  "row": 2,
  "device": "738", <-------------this number
  "templateExtra": null

Thanks,
Dave

Yes, that is the one in the URL that I mentioned above (you can ignore the others :slight_smile: ). Still not sure why your device wouldn't be working, but another thing I just thought of: it's paired with security maybe see if it works differently without?

It's not surprising that it would work with Mirror if it's the "receiving"'device, since it seems to respond correctly to commands, and that's all the app would be using.

Download the Hubitat app