Problem With Aeotec Multi Sensor 6

I added the Aeotec multi sensor 6 to hubitat a few days ago. The motion works fine, but the temp is stuck at 72 and the humidity at 64%. Just for the heck of it, I clicked configure and nothing changed.

Any ideas short of unpair/repair?

I had this once. It was fixed with a firmware update. But you'll need a z-wave USB stick to connect it to a computer to update it.

1 Like

Thanks for the reply. What if I pair it with a Smartthings or Vera hub? Would the firmware update?

I fixed mine by stomping on it and throwing it in the trash. That thing was nothing but an aggravating mess of issues, it never worked right, it didn't report motion reliably, it didn't report temp or humidity reliably, luminosity never worked, it would completely disconnect from the z-wave mesh for no reason, pairing was a PITA. My money would have been better spent on a drill bit to the brain to make me forget that this thing even exists at all.

It's a -10 out of 5 stars, and it will make your smart home stupid. Makes a great gift for your worst enemy.

So I take it you didn't like the multi sensor?


If I had to choose between getting another one of those, or having someone sprinkle glitter all over my house, I'd choose the glitter.


At the other extreme... I have 12 of them, 11 on batteries that need to be replaced sometime after the 60 day mark. I also have 2 of the Dome and 4 of the Iris v2 and v3. The Iris are, as is touted widely, faster and longer battery life, at the expense of 4 fewer senses. The Dome and the Aeon are the very similar response wise, has 4 fewer senses and a longer battery life. Neither the Dome nor the Iris have needed a battery change, so far, so I don't know which will be the winner of that race, but I suspect the Iris because of the lower traffic areas in which they sit.

I'm either in for a treat or you just had a "lucky" one. I have 8 of them. Working pretty good now for about a month. All wired to mains. No batteries in my house if I can help it. :grin:

To clarify, mine was the dome. The dome was concave after I was done with it.

Is this still the case? I see firmware update apps. Can it now be done through that?