Problem with a scene not activating all the devices

I setup a goodnight scene that I can activate using Google Home. Turning the scene on seems to work fine. However, when testing (done very little so far), not all the lights are changing as they should. This scene should turn off any lights that are on, and turn my hall light on at a dim setting and my bathroom light on. I'll manually turn the bathroom light off after I brush my teeth and I'll use my phone to turn the hall light off once I'm in bed.

So right now I'm testing it, sitting in the office. Here is what the scene looks like


All these switches are Zooz switches. My mesh is very reliable. I've tried using the metering function to add a small delay between the zwave commands and nothing changes.

Since all the other lights in the house are already off, all it should be doing is turning off the office light and turning on the hall light at 11%. It seems to reliably turn off the office light, but more often than not, the hall light stays off. Here is a log.

Highlighted in yellow is the scene. You can see an instance where it worked fine. Then I turned the office light back on and the hall light back off and activated the scene again, but you can see highlighted in green where only the office light turned off. The hall light did not turn on.


May need to put a ~50 milliseconds pause between commands. (There’s a thread on it somewhere in here if I can find it...)

Do you have 'Enable activation optimization' turned on for the Scene? If so, turn it off.

1 Like

I think I do. I'll have to check later. What does that setting do?

It won't send a command for a device setting that already is set. So that would explain your logs.

Try 75 msecs.

Okay, makes sense. This is actually something I was thinking about while creating the scene. Occasionally Google mishears me say to turn the hall light on (which is what prompted me to create this scene actually) as "turn all the lights on" and will try to turn on about 15 lights. When this happens, my zwave network freaks out and Hubitat becomes unresponsive for about 15 - 30 seconds.

So with the optimization off, does it send an off command even to the devices that are already off? I've wondered this before when creating a rule in RM too. Is this why the metering ability was recently added in?

Also, with limited testing, turning the activation optimization off seems to have fixed not everything firing.