Problem Mixing Zooz and Inovelli Actions in Rule Machine

In my Master Bedroom, there are two separate circuits used for overhead lighting (one for entryway and accent lighting on the front wall, and one for main overhead lighting; both circuits are solely comprised of recessed dimmable LEDs). The front circuit is controlled with a Zooz ZEN27. The main overhead circuit has an Inovelli Red (LZW31-SN).

My desired action for each switch is:
-Single tap: Toggle individual circuit to which the switch is connected
-Double tap: Toggle both circuits

Simple enough. I've created a rule in Rule Machine to set the actions. However, I'm getting very erratic behavior.

After resetting the switches and initializing the rule, the first time I use the double tap action, both circuits toggle accordingly. However, after the first use, everything starts falling apart. Next time I try to use it (either on or off with double tap) the Inovelli circuit does not respond. Usually, at this point both switches will still function manually as a single tap (but it is probably worth noting that after the Inovelli has stopped responding to the rule [digitally activated toggle], the first time I manually toggle that switch, my Hubitat logs indicate a digital activation [when it should be physical]... so it seems that perhaps the command is getting stuck in queue and not actually responding properly or reporting properly to the initial command?!). Either way, the more times I try to use the double tap, the worse it gets. After 3-5 tries, then the physical switch will stop responding as well, and cannot even be used to activate the single circuit it is connected to, until I reset the switch (this even happens with the Zooz switch, even though it seems to be the switch that is otherwise responding correctly).

What I've tried:

  • Double checked my rule. Everything looks fine. I have a similar rule in another room controlling 4 lighting circuits, and that one works perfectly (the only difference is that the one with 4 circuits that is working well only has Zooz switches. No Inovelli there).
  • Drivers. I've tried the custom Inovelli driver, the built-in "Inovelli Z-Wave Smart Scene Dimmer S2," "Inovelli Z-Wave Smart Dimmer," and "Inovelli Smart Scene Switch S2." I'm using the built-in "Zooz Central Scene Dimmer" for the ZEN27 (because I added the Zooz switches with S2 authentication, and the custom driver does not work with S2 yet) and that driver works well in the other room that I have the similar configuration.
  • Isolating the rule to one switch. I initially setup the rule to operate from either the Zooz or the Inovelli switch, but after such erratic behavior, removed the triggers from the Inovelli (at least for now for troubleshooting purposes), so the rule can only be triggered from the Zooz switch, but the issue persists.

Does anyone have any idea what is going on here? It really seems to me like it's the Innovelli switch is not responding properly or reporting properly to the Hub, causing the compounding problem. Has anyone been able to successfully incorporate a setup like this with mixed hardware manufacturers within their Hubitat (it seems like it shouldn't matter if mixed manufacturers are being used, since the Hub is processing/issuing/receiving the wireless commands).

I would really like to get this fixed, but would like to retain the Innovelli if possible, as we want to utilize the notification LED function on this switch as an indicator for the status of our doors, windows, locks, garage, etc... when going to bed at night.


Innovelli's button mapping uses presses for up and holds for down in their version of the driver. Use the built-in Innovelli Smart Scene Dimmer driver it uses more common sense buttons but doesn't support as many taps, and the advanced button controller app to map out the functions to the buttons.

If you need to make an adjustment to a function that the built-in driver doesn't support, then you can switch back to the Innovelli provided driver to make the change. Hit configure then move back to the built-in one.

In this use case I am using the button presses to control some smart bulbs but you can put whatever you want in there.

If you just want to control the load then make sure it's configured for that in the custom Innovelli driver then switch back to the built-in driver. You can forgo the ABC controller for local load control.

Hi Lewis. Thanks for the reply. I've tried both the custom driver, and the built-in driver (and I did notice that they both handle the mappings differently). Right now, I've reverted back to the built-in driver for the switch (for both the Zooz and the Inovelli). Unfortunately, it doesn't seem like this issue is related to the button mappings though. In fact, I've removed all custom mappings, and removed all triggers from RM for this Inovelli switch. It's essentially back to stock state at this point. But I'm having issues even getting actions from this Innovelli switch, even when triggering it from the Zooz switch. My logs do show the double tap for the Zooz switch when trying to trigger the action, so I know it is mapped and received by the hub... it's just that the Inovelli switch is not responding reliably to the trigger.

Does that make sense?

Yup, just not sure which way to go with this yet. Could be an unrelated device impacting the mesh. I'd try to rule that out first. Have any zooz 4 in 1 devices or contact sensors? Using the generic zwave contact driver? Any devices with nothing in the clusters column? Running build Is memory an issue?


Does the innovelli switch respond to commands from the device page?

It really shouldn't be an unrelated device. When we began a remodel on the house last month, I started from scratch. I've got door sensors, window sensors, garage door sensors, relays, outlets, 4-in-1s, buttons, etc... that I've never connected to this hub, because I'm trying to get all my switches installed and stable prior to expanding. So right now... Zooz dimmer switches, Inovelli dimmer switch, Jasco/GE Smart fan control, and my phone (mobile app) are the only devices. All of them using built-in drivers at the moment.

Yes. I am running

As far as clusters go, that's an interesting point. I am seeing 2 nodes that have blank clusters, that are not present in my devices. Perhaps these never got fully removed from the Z-Wave network after removing some previous devices?! I guess I can try to repair the Z-Wave network to see if it helps... however, I would be surprised if that was the issue, because both of these dimmer switches do respond to on/off commands from the device page.

Here's free memory from the last few hours this morning:
2020-12-15 08:02:58,555704,240716,179633
2020-12-15 08:08:01,555664,240716,178409
2020-12-15 08:13:05,555508,240716,179774
2020-12-15 08:18:08,555544,240716,179905
2020-12-15 08:23:12,555672,240716,180123
2020-12-15 08:28:15,555804,240716,179849
2020-12-15 08:33:18,555696,240716,179676
2020-12-15 08:38:22,555892,240716,179763
2020-12-15 08:43:25,555672,240716,175256
2020-12-15 08:48:29,555516,240716,179093
2020-12-15 08:53:32,555536,240716,180003
2020-12-15 08:58:36,555400,240716,179831
2020-12-15 09:03:39,555244,240716,179684
2020-12-15 09:08:42,555296,240716,180135
2020-12-15 09:13:46,555220,240716,180025
2020-12-15 09:18:49,554936,240716,180091
2020-12-15 09:23:53,554972,240716,180350
2020-12-15 09:28:56,555104,240716,180118
2020-12-15 09:34:00,555096,240716,179415
2020-12-15 09:39:03,555164,240716,179989
2020-12-15 09:44:06,555008,240716,165750
2020-12-15 09:49:10,555060,240716,179059
2020-12-15 09:54:13,555132,240716,179823
2020-12-15 09:59:17,555280,240716,179741
2020-12-15 10:04:20,555172,240716,179396
2020-12-15 10:09:24,554268,240716,135072
2020-12-15 10:14:27,554288,240716,178146
2020-12-15 10:19:31,554108,240716,176141
2020-12-15 10:24:34,554320,240716,173111
2020-12-15 10:29:38,554240,240716,148249
2020-12-15 10:34:41,554112,240716,173167
2020-12-15 10:39:45,554268,240716,175411
2020-12-15 10:44:53,554156,240716,144042
2020-12-15 10:49:57,554308,240716,177940
2020-12-15 10:55:00,554408,240716,178350
2020-12-15 11:00:04,554108,240716,174177
2020-12-15 11:05:07,553952,240716,177907
2020-12-15 11:10:11,553640,240716,178497
2020-12-15 11:15:14,553600,240716,178340
2020-12-15 11:20:18,553972,240716,178481
2020-12-15 11:25:21,554120,240716,178884
2020-12-15 11:30:25,554040,240716,174090
2020-12-15 11:35:28,553764,240716,178109
2020-12-15 11:40:32,553864,240716,178836
2020-12-15 11:45:35,553676,240716,168926
2020-12-15 11:50:39,553660,240716,178250
2020-12-15 11:55:42,553244,240716,175526
2020-12-15 12:00:46,552720,240716,174925
2020-12-15 12:05:49,552700,240716,178525
2020-12-15 12:10:53,552496,240716,179363
2020-12-15 12:15:56,552656,240716,179255
2020-12-15 12:21:00,552572,240716,179199
2020-12-15 12:26:03,552648,240716,179174
2020-12-15 12:31:06,552660,240716,174643
2020-12-15 12:36:10,552632,240716,178531
2020-12-15 12:41:13,552624,240716,179250
2020-12-15 12:46:17,552452,240716,178453
2020-12-15 12:51:20,552468,240716,178825
2020-12-15 12:56:24,552408,240716,179135
2020-12-15 13:01:27,552272,240716,175315
2020-12-15 13:06:31,552436,240716,177803
2020-12-15 13:11:34,552312,240716,179159
2020-12-15 13:16:38,552584,240716,178473
2020-12-15 13:21:41,552544,240716,179330
2020-12-15 13:26:45,552540,240716,178945
2020-12-15 13:31:48,552412,240716,178987
2020-12-15 13:36:52,552304,240716,178185
2020-12-15 13:41:55,551412,240716,139370
2020-12-15 13:46:58,551244,240716,173406
2020-12-15 13:52:02,551968,240716,144534
2020-12-15 13:57:06,551956,240716,178347
2020-12-15 14:02:09,551280,240716,171837
2020-12-15 14:07:13,550956,240716,147812
2020-12-15 14:12:16,550668,240716,164684
2020-12-15 14:17:20,550848,240716,138472
2020-12-15 14:22:23,550792,240716,142968


No clusters usually means a failed pair and they will absolutely wreck your mesh if that is what they are. And the more traffic that is on the mesh the worse it gets. The Zooz 4 in 1's have an issue when there is more than one on the mesh for whatever reason. Their engineering group is looking into it. Battery devices using the generic zwave contact sensor driver and a few other generic drivers have a bug where they spam the device trying to get battery reporting out of it and is causing the mesh to lag out. Replacing contact sensor drivers with the Ring Alarm Contact Sensor driver is a workaround until it's resolved.

1 Like

It looks to me like the two devices with no clusters are old ghost devices that are no longer part of the mesh. They are not listed under "devices." They have no routes. No other Z-wave devices include them in their route. Just to be safe, I ran a Z-wave repair. But, these ghost devices are still listed. In the past, I think there was a "remove" button on that screen in Hubitat... but I don't have one now. Is there a way to remove these to ensure they are not causing issues?

They are failed pairs, possibly defanged ghosts but the device that was re-paired is still on the network and the hub is able to ping them so you don't get the failed option. Usually, it's the next device in the list but not always if you skipped around and came back to them or whatever. You can kill power to all the circuits except for the hub and see if you can get it to go to failed by clicking refresh. If you get the failed message then the remove button should work.

Ok. Thanks for the tip. I'll see if I can get those Z-Wave devices out, then retry and report back.

A bit late and off-topic, too, but I need to thank you for this tip, the average RTT of my Sensative Strips decreased from about 16s (!) to about 10ms after changing the drivers.
Not sure if this is related to the Generic Driver issue too, but I found my mesh reorganizing after switching to the Ring driver, using way more direct routes to the hub than before.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.