Problem Controlling Inovelli Ceiling Fan Light with an Inovelli Red Dimmer via Rule Machine

I'm having trouble with only one switch trying to control another light. The switch I am using is an Inovelli Red series dimmer, LZW31-SN. It is connected only to line and neutral wires. I am using a Hubitat C7 hub. I want it to turn the light of an Inovelli Fan+Light LZW36 on or off.

In Hubitat I used Rule Machine to create a rule for a button 1 push to turn the fan's child light to 100% and a second rule for a button 1 held to turn off the light. It was working for a while and then stopped working. I could push the paddle to turn it on, but nothing would happen. Likewise, I would go into the room, turn it on from the fan/light switch and then go back out and the red dimmer wouldn't turn it off. However, if I turned it on and off from inside a few times the red dimmer would start to work again for a while.

I've tried removing and then re-including the switch but it seems even flakier - i.e. it stops working even sooner that it used to. Any ideas on how to fix this?
@Eric_Inovelli
@ericm
@bcopeland

I wonder if a Z-Wave association fair any better than a RM rule. Never played with an LZW36 though, not sure how the dual device would present/be targeted.

I tried that first, but could not get it to work. Someone said I needed them to be at either matching security levels. They said the light was at security zero. Even thought the security for the Fan/Light was at S2 I removed then re-added the red dimmer with no security. I tried to do an association on group 2 with the child for the fan light, but that didn't work. I am thinking that the problem may be that the light is using a generic driver. I think they both need to be Inovelli drivers, but I don't know what driver to use for the fan's child light. I posted this question but have not gotten a response. Do you know which Inovelli driver I should use for the child light? Also do you know if the security for the child light would be different than the fan/light itself and does it have to be zero or just matching?

Thanks,

Just speaking personally, I always use the corresponding Inovelli driver for any Inovelli device (ie, from their github or via HPM).

I think the differing Security levels of their inclusions probably would be an issue ... are you aware that "security zero" is an actual security level ("S0"), as opposed to disabling security? Your devices might still be using different settings in this regard.

I would try the whole setup with all security disabled, or at least with them definitely included using the same Security level, just to reduce the number of factors in play. You should be able to see what each device is using if you visit your Hub's Settings screen, then Z-Wave Details. There should be a table with a column over on the right for "Security" where you can compare them.

I'd be happy to try the Inovelli driver, but I don't know which one to use for the Red Series Fan + Light, LZW36 and the parent says it is an Inovelli driver, the fan says it is a Hampton Beach driver and the light comes in as just a generic driver.

Unfortunately I've never used an LZW36, might be actually be worth seeking guidance about the ideal config in the Inovelli forums.

[Edit: Just noticed you did, nevermind]

Download the Hubitat app