Possible bug: "And stays" not being honored for presence sensor

I have a couple Aqara FP2 sensors that I've added in HomeKit. To see them in HE, I created virtual devices of type "Virtual Presence with Switch" and set them via HomeKit. So far, so good.

I tried using the device as a trigger in RM, but found that the "and stays" option is not honored for the device. Of course, this is no big deal, since I can instead use the "switch" of the virtual device as the trigger, which does honor the "and stays."

Just a heads-up for anyone else heading down this path, and perhaps to the good folks at HE.

I'm not seeing this behavior. Can you provide a screenshot of your rules and Logs that provide evidence? (As well as a decription of what is actually happening if this isn't it and it's not apparent from the logs.)

Also, if you are not on the latest release ( as of my writing), be sure to update, as there have been some RM fixes.

My rule and logs:

1 Like

I’m having a similar issue with contact sensors. I have a rule to notify me if a door opens and stays open for more than 5 minutes after dark. I swear this used to work correctly, but now, anytime you open a door after dark, you get a notification 5 minutes later. I opened the rule and watched the variable go to open a then back to closed. 5 minutes later, i got a notification that a door was open.

It's hard to say anything without knowing more information. For a good overview of what it takes, including:

...I suggest consulting: How to Troubleshoot Apps or Devices | Hubitat Documentation, notably the section on apps. Both the rule itself (in its entirety) plus logs that demonstrate the problem would be helpful. If you are not on, released today, I would also update before trying again.

I'm not able to reproduce the problem, as I demonstrated above with a rule and logs.

1 Like

This rule has been in place for quite some time. I only recently noticed that it had begun misfiring.

I removed all the doors except the one I was testing with. With just one door trigger in the rule, it works as expected. Something must have changed.

I've tried re-implementation of my rule to sense the presence and stay, and now it works. Not sure exactly why, but it clearly wasn't working earlier. Perhaps one of the OS updates did it...