[PORT] Gentle Wake Up


#41

Well of course this did not work again. Error on line 673. I can't use this app for some reason.

This is all I have setup on the Child App

RULE
Rule


#42

The Gentle Wake Child app only gradually raises light intensity (or gradually decreases it). It does not turn off the dimmer or bulb at the end of that time period.

If you want the dimmer/bulb to turn off after it has gradually increased in intensity, then you have to separately turn off the dimmer/bulb (not the Gentle Wake Up Child switch).

So if the Child App runs for 10 minutes, then your Rule has to turn off the dimmer/bulb after the Child App is done running.

I think you're getting the error because you are trying to start a gradual dimming while the dimmer/bulb is already at its maximum.

I'm going to see if I can reproduce the same error.


#43

I don't get the error.

But if I turn on the GWU Child controller switch while the dimmer is at its max intensity (i.e. it is on), the Gentle Wake Up Child timer doesn't run. It just sits there. And the light remains at whatever intensity it was supposed to be at the end of the first time the Gentle Wake Up Child Switch was turned on.

Even if I turn off the dimmer, the GWU Child timer doesn't start running.

The solution is clearly to ensure the target bulb/dimmer is off before starting the GWU Child.

@bptworld - hope this helps.


#44

My tests are:

There is nobody home at this time.

Created a Child App for a 5 min run time. Start at 10% end at 99%. Thats all I've done in the GWU app.

Created a new RM 4.0 Rule
When 3:00pm
Turn on Child
Wait 5 Mins
Turn off Child

This will work 1 time. Once it is done, I go in a change the time to test again.
When 3:30PM
Turn on Child
Wait 5 mins
Turn off Child

Second time around is when I get the ERROR LINE 673


#45

NOPE. All I did was change the Time in the RM rule. Light did not turn on and getting this error.


#46

@aaiyar @bptworld This just makes no sense to me at all. Why is it working with a fresh new child but when I change the time to run another test it bombs out.


#47

Since this has been driving me nuts for the last day and a half I decided to remove the app and create a RM 4.0 rule

This one here seems to be working for me


#48

This setup works for me. Hope this helps to track down an issue (if present).


#49

This worked for me the first night i used it using the default time of 30 minutes, on the second and third night I changed the time to 35 minutes and I started getting the errors in line 673. I'm changing it back to 30 minutes to see if to works again tomorrow.


#50

I just looked at the code a little, could the issue be that your are dividing by 60? At least in the few examples I see listed of the times that are messing up it would appear that dividing that number by 60 always returns an infinite repeating decimal. Maybe you need to put something in your code to trim it to two or three decimal spots??


#51

Report this morning

Used Rule Machine 4.0. Worked perfectly.


#52

while making a RM 4 rule like you did above is simple and working. having it as an application means I can easily make changes to the days/time, have it turn on other devices, and do other things without having to edit code.


#53

@Kappen. With the RM rule you can edit all you want and get as complex with it as you want.

Send messages, turn in TV, start coffee....the list goes on.


#54

well if that works for you thats awesome. Since I'm not using this on color bulbs or a bulb you can change the temp on and the error is coming from the code that ramps up the light temperature I just modified his code a little until he can get it fixed.

Line 673 is

state.dimStep = endTemp / seconds

I changed it to

state.dimStep = 83

that clears the null condition and it seems to work fine for those of us with just a normal smart bulb


#55

I do t have color Changing bulbs either. I have a dimmer plug that my lamp is plugged into.


#56

then that code change will work for you too.


#57

Yes I'm sure it would. Today, I would rather not add another app to the hub. Why? I don't know. Lol.


#58

I've been monkeying around with this for a bit but so far can't get color or color temp changes to work using hue bulbs integrated through a hue bridge. Is that feature known to be functioning?

The dimming works fine but the color and color temp settings seem to not actually impact anything. Although the color setting did make my light start as blue and stay blue the entire time. Color temp acts the same way as if I don't have temp on. It simply uses whatever color temp the light was at last and stays there.


#59

Dimming? ... Does 'dimming' mean 'brightening'? That's the only thing that makes sense.

Are "dimmers" equal to "bulbs"? ... or did I install the wrong app?

I bought a Sengled Color Plus bulb. All I can get GWU to do is turn the bulb off. Was I supposed to buy dimmers instead of bulbs?

Maybe I'll uninstall and start over..... do you have a video or screenshots to follow?


#60

Dimming refered to genericly as changing the level of a dime setting so yes in this case brightening.

Like I said everything seems to work fine I just can't get color or color temp to change.

The instructions in the app also mention a slider in the device settings which I've never seen I can't get the function that sets percent complete in the device to do anything either.

This is a great app just need some help sorting out these issues then it will be perfect for me.