[PORT] AXIS Gear Driver

Just updated my Github with V5, seems to work pretty good.

  • adjusted driver to work with Hubitat
  • added logging toggle
  • added importURL

Be sure your device is also up to date.

4 Likes

This is great bptworld! I'm actually using a slightly modified version of the 5.1 driver (I basically commented out a capability line and one of the metadata lines - no idea if this is messing anything up but everything seems to work... I'm no programmer)

I had a couple questions:

  1. Overall these drivers work well but I've found that they aren't compatible with the "Shades" dashboard template (slider doesn't work) - do you know if this is an issue with the driver or the template itself? If you use a "dimmer" template it works as expected.

  2. There is a pretty significant firmware update for AXIS that supports ZigBee 3.0 and firmware updates in smarthome mode - do you know if this will need updated drivers to support? I apologize if this is obvious, I am still very new to Hubitat and home automation in general.

Again thanks for what you've done already - the Hubitat community is great!

BTW First post after a year of lurking so let me know if any - love Hubitat!

After updating I couldn't get the shade to work again. Tried to do the zigbee re-pairing with the logs open (didn't delete device) and it found it again but still couldn't move the shade.

Woke up this morning and the shade was in the 'morning' position! Sent a command to it and it now works again. Don't know why but I'll take it!

Good to know - I'll try the update on the 8 gears I have and report back.

bptworld - How exactly do you do a re-pair without removing and re-adding the gears (which I REALLY don't want to do due to all the automations associated with the shades)? Is it the same thing as a ZigBee heal (turn off hub for 15 minutes and turn back on)?

I updated yesterday and am having the same issues you did. Tried everything (turn devices off and on, hub off and on (not 15 minutes), etc.) short of re-pair/Zigbee Heal/remove and re-add.

Thanks in advance,

Felipe

The instructions are the forum somewhere but this is a summary... This works for any Zigbee device

  • Open the Zigbee log in one browser tab ('Settings', 'Zigbee Details', 'Zigbee Logging')
  • Go to 'Devices, 'Discover Devices', in another browser tab
  • Be sure to be next to your Zigbee device at this point
  • Click on 'Zigbee', starting the timer
  • Press the 'pair' button on the device (every brand device is a little different on this part)
  • Watch the screen, you will see device found and if you jump over to the zigbee log tab, you will see the zigbee device sending data again.

Hope this helps.

1 Like

Gotcha - simple enough (and will try and search the forums more thoroughly in the future before asking). Will give it a shot.

Thanks for the quick response!

No problem, hopefully you get it going again. I did the process above but it didn't start working until sometime over the night. Zigbee is funny like that, sometimes it takes a while.

Hey, just wanted to say that it worked (and immediately for me)!

Thanks again for saving me from having to remove and re-add (and showing me a new trick)

EDIT: Also, shameless plug - I posted in the feature request section (Driver Support for AXIS Gear) for official driver support for the AXIS Gear - anyone who stumbles upon this thread should go over and vote for support!

1 Like