Please point me to the proper setup Assistant Relay

Unfortunately, Assistant-Relay doesn’t really support all of the functionality true voice commands seem to support. This is an issue with the NodeJS server/Google SDK, not an issue with the Hubitat side of things.

It’s been a while, but as I recall commands in the following form sometimes work...

[CC]set volume to 50 on Family Room Mini

But I am pretty sure the volume command above does not work. It does if you use Google Assistant on your phone, though (without the [CC] of course).

I don’t recall ever having to use the wake phrase “OK Google” when using Assistant-Relay.

Huh, I've never tried it without. Thought I read it was needed, but guess I just assumed (wrongly) that it was. :grimacing:

Duh, it works without Hey Google. Completely makes sense. I made fun of my friend for pressing the button on his Android phone, but then still saying "Hey Google..." But this IS talking to google assistant, so of course you don't need to say Hey Google :roll_eyes:
The jokes on me this time!

Thanks for that info :slight_smile: What do I use in RM to take advantage of the Chromecast actions. I know I can use the speak/notification function with google relay in RM but cant seem to find the the commands that are available in chromecast devices in RM.

yes the set volume does work but you need to add % to the number in my experience.

1 Like

Go to: Apps > Rule Machine > Create Custom Commands

  1. Give it a name, i.e. "Stop Google"

  2. Select capability for test device > Actuator

  3. Select actuator to test for commands > [your chromecast capable devices name]
    Mine happens to be "Kitchen Display"

  4. Click "New custom command... > Select the custom command from the drop-down list.

  5. Save your custom command.

  6. Hit Done, and then Done again

  7. In your rules, the action for True or False is to run a custom command.

  8. Select the custom command to run, and on which device it should run.


    These are your choices

    Save the command

    Select Custom Command for Rule Machine Actions

    Which of your chomecast enabled devices should the custom command run on?

Custom Commands is definitely one way, albeit a bit complicated.

Another way is to use “Custom Action” in your True or False Action of a Rule. When you select “Custom Action” for a device, you can pick any of its commands and can pass parameters to those commands.

1 Like

Thanks Dan. I realized as I was putting those instructions together that I hadn’t used custom actions in anything yet, and didn’t really know how they worked (and was too tired to read up on it at the time). :grimacing:

1 Like

I have successfully installed Assistant Relay V2 and the V2 HE driver. Everything works as intended.

However, where do I change the username that is broadcast prior to the message? I have changed the username in the driver but it does not work. It always broadcasts "Scott", which is my name, but I want it to say something else.

Is there another setting somewhere or buried deep in RPi?

Thanks,
Scott

IIRC, there is a config.json file (or similar) on the RPi which has your google username in it. You'd have to change that entry, maybe? This is really a Google Assistant-Relay NodeJS server question, as the Hubitat v2 driver simply implements the HTTP calls specified by that project's ReadMe on GitHub.

Here's the pertinent section...

Once you have downloaded your client secret file, rename the file to your chosen user name. For example: greg.json . Once renamed, copy your OAuth file to the folder server\configurations\secrets

When Assistant Relay is ran, it will automatically configure itself to according to the files in the secrets folder. These are also the usernames you can now pass with your queries. For example, the username for greg.json is greg

Yeah I've looked in the config.json file and the file downloaded from Google. Don't see it unless it is encrypted......I'll keep checking.

see my edit above

Yeah I saw that but based on the above it is spalexander.json so it should be spalexander. But it's saying Scott instead. Maybe since it can't say spalexander, it is reverting to my Google username.

Oh well.

Right here...Tested it. Changed it to pig dog and it said "Broadcast from smart home, assistant relay is now setup and running for pig dog"

You talking the config.json file in /home/pi/assistant-relay/server/configurations? If so, I changed mine from spalexander to Test and it still said Scott. Although, I did not reboot.....I'll keep testing.

No need to reboot. Just stop Assistant Relay and start it again. Path is very likely different for me vs you. I'm running version 1 and I'm running it on a Mac laptop.

You should see the same stuff I have in the file though, all in one line. Does it look like that? Should be only one config.json file regardless of the version.

Yep. Changed it. Still does not make a difference. I'll keep messing with it. Having another issue with rPi and I may reinstall it. When I do, I will try Version 1 instead of 2 for Assistant Relay.

I wouldn’t go back to v1 if I were you. The major difference is the form of the http requests, IIRC.

Not sure is this was already answered somewhere else...

Can I activate a routine on a specific Google Home device (I have 5, but want the routine to run on only one) with the help of Assistant relay (or something else maybe)

Something like [CC]Good Morning on Google Kitchen

No, Routines are not Google Assistant Routines are not supported by the Google Assistant SDK. So, you cannot trigger Routines through Assistant Relay.