Patched webCoRE for Hubitat (2018/09/09)

community_app

#587

Correct.... the minions are looking into improving the mobile apps.... will likely get new features such as push notifications and user responses / HE compatibility... but don't hold your breath in the short term I'm afraid.


#588

@putnamjwp - web request PUT method does not follow 307 redirects. I am referring to this post over at the webcore community:-

I am trying the exact same thing and am not getting success. Using Postman and getting the redirect URL and then using in webCore works fine.

Any chance of getting this fixed over here?

Thanks in advance :slight_smile:


#589

I have not yet make the move to Hubitat from ST, but I'm definitely thinking about it. For WebCore, in order to make it work on Hubitat, do you need to have a local Rasberry PI hosting the WebCore website? But besides RPI, has anyone tried to use a different host? Maybe a router running WRT? I am running Merlin WRT on an Asus router. Or maybe one of the NASs, like QNAP? Both of those devices have excess processing power that might be usable. The router is an ARM like the RPI, so that might go well. The NAS has a Celeron, so WebCore might need to be recompiled for that. Comments?


#590

No, you do not need to host the webCoRE Dashboard locally. That is just an option in case you don't want to depend on the public server. It does not affect the way your pistons run, which are local regardless; the Dashboard is only for viewing and editing. (That being said, I've done it both ways and local hosting makes the the dashboard load a lot faster, and I had no problems with large numbers of devices authorized, which I might have once had a problem with on the public server.)

If you do decide to host it locally, you do not need a Raspberry Pi. That is simply one easy option available to you. The instructions for the Pi will work on most apt/Debian-based systems, though you may need to see what the actual package names you need to install are. There are also instructions for Docker that are again geared towards Linux but should work anywhere you can get a Docker container running (some NASes can indeed do that).

But again, no need. :wink:


#591

Speaking of hosting this entire thing locally. Has anyone created a docker container?


#592

You have to create the containers yourselves, but as I mentioned above, running the webCoRE Dashboard locally in Docker is an option: Patched webCoRE for Hubitat (2018/09/09), post 195 or so above.


#593

Hey guys! Not sure what is going on but I have a local version of PI WebCoRE and I can't get any pistons to run properly. Keep getting an error. It's like any device I added in HE and via the SmartApp is not being properly initialized.. I can add devices and they show up in WebCoRE so am not even sure how to troubleshoot this.

Here is a very simple example:

10/2/2018, 8:03:59 PM +125ms
+0ms ╔Received event [Home in Somewhere].test = 1538525039118 with a delay of 10ms
+39ms ║RunTime Analysis CS > 15ms > PS > 19ms > PE > 5ms > CE
+65ms ║Runtime (35773 bytes) successfully initialized in 19ms (v0.3.105.20180628) (64ms)
+66ms ║╔Execution stage started
+69ms ║║Cancelling statement #1's schedules...
+72ms ║║An error occurred while executing the event: java.lang.NullPointerException: Cannot invoke method hasCommand() on null object
+73ms ║╚Execution stage complete. (7ms)
+88ms ╚Event processed successfully (88ms)

Am I missing something? WebCoRE seems to run fine and so does HE. I add RuleMachine rules with the same devices and they work fine. Really like the flexibility of WebCoRE though.


#594

Just tried reinstalling WebCoRE on HE, no go. Same issue.


#595

I wonder if there are permission issues on the WebCoRE Server.. mmm. Also when I click on show piston in browser it never comes up. I can access it directly though.


#596

Check to make sure you're on the latest version. Your logs are showing v0.3.105.20180628 and the latest is v0.3.108.20180906. Earlier versions can't query devices in the latest Hubitat firmware.


#597

Argghh!!!!!! I thought I had installed the latest and greatest. Not sure how that happened must have grabbed an older link. Apologies for taking your time but thank you!!!!!!!! Works perfectly now..


#598

Is it still best practise to have two instances of WebCore with HE, as it is with ST?

One for the dashboard, one for the rules?


#599

The only time I've ever had two instances is for webCoRE itself, and one for webCoRE Presence sensor.


#600

Well imo its always nice to have 2 instances for debugging and any problems you might encounter in the future. If something goes wrong with your dashboard or the rules, you won't lose everything


#601

I don't see why its needed, but each to their own. The pistons are backed up with your hub backups. The code is on Github, its real easy to restore in any event.


#602

Sorry if this has already been answered...but I was just wondering that since backup/restore to file is now fully supported in WebCore, can that be used to port Pistons from ST to HE? I've been waiting for that and Google home integration to finally rip the band-aid off and make the switch. Had another internet outage today thanks to Speculum...I mean Spectrum. :wink: So, it's looking more and more like I should get on it and make the switch. Thanks!


#603

Yes, I imported a whole number of Pistons via that method. Very easy.


#604

Thanks so much!!


#605

So I posted this in another forum "WebCoRE vs Rule Machine" but thought I'd mention it here as well. A word of caution.....

I just encountered a major issue where my HE web interface was completely non-responsive after several clicks. Not sure what was going on I tried rebooting various times and nothing seemed to work. I even got a "Zigbee network offline" message at one point. Contacted support but while waiting decided to try and simplify my setup by removing WebCoRE. Manually powering off the HE, removing the usb stick and then booting up allowed me to regain normal access to the UI. I was then able to remove WebCoRE. I shutdown "gracefully" via the interface, added the stick back in and booted up. Everything started working and the interface was snappy again. Support got back in touch but had noticed that things seemed to be working from their end. Gave them the heads up on what I did.

My WebCoRE (v0.2-377-gb5cefd4) was running locally on a Raspberry PI3 - I had about 5 or so pistons with some basic logic, timers & triggers but nothing too weird as far as I know. It's possible I could have inadvertently created conflicting or "fatal embrace" pistons but not sure - I do have experience writing them under ST.

Have recreated most of them in RM now and things are working better. RM is quicker to respond but for me not as flexible - I really love the WebCoRE interface.

For now have disabled WebCoRE. :slightly_frowning_face:


Hubitat completely frozen (webCoRE)
#606

Just an FYI - The only part of webCoRE that doesn’t run locally on your Hubitat hub, is the web configuration tool. All pistons run locally on your hub, You could turn off your RPi and your pistons would still run fine.