Pair zigbee device (temp sensor SNZB-02) with Zigbee bridge and Hubitat at the same time possible?

Hi guys
Can I use at the same time a zigbee device (temp sensor SNZB-02) paired with a Zigbee bridge and the Hubitat hub?

I first paired them with Hubitat but the update of data is rather slow - I few times per day (despite tryin the kkossev drivers) and then I also paired them with a Zigbee bridge and now in the eWelink app I have temp readings every 30 seconds but the updates in the Hubitat seem to have freeze.

I would expect that the temp sensor will just reply with the data to both Hubitat and zigbee bridge.

Any thoughts on this topic or similar experiences?

Thanks and regards.

It is not possible to pair one and the same Zigbee device to more than one Zigbee coordinator (hub).

Have you tried this driver: https://raw.githubusercontent.com/kkossev/hubitat-ZigbeeReportingConfiguration/main/Zigbee%20Reporting%20Configuration.groovy ?
Switch temporary to this driver, select the option "Re-pair with aggressive reporting settings" and pair the sensor again to HE. Once it starts reporting every 10 seconds, it will be easier to fine-tune the desired reporting period. Finally, switch to the HE driver that you usually use.

1 Like

Hi kkossev.
I've tried the drivers written by you (thank you), but haven't re-paired the sensors with aggressive reporting settings. Will try it and provide some updates.
Thanks again.

@user2764 I have added SNZB-02 to the Tuya Temperature and Humidity ... driver.
Please update the driver to the development branchver. 1.0.10 2022-10-11 from the link in the driver thread second post : [RELEASE] Tuya Temperature Humidity Illuminance LCD Display with a Clock - #2 by kkossev

Configure your minimal and maximal reporting periods and the measurement minimal change (delta) and click on 'Save' while rapidly changing the humidity at the same time... the battery-powered zigbee device must be awake at the time when the new reporting configuration is sent.

Click on the Initialize button after you update the driver.

If the reporting configuration is successful, you will see in the device logs (info logs, no need to turn on debug logging) confirmation like this :

[dev:3284](http://192.168.0.151/logs?tab=past&deviceId=3284#)2022-10-11 22:21:23.407[info](http://192.168.0.151/logs?tab=past&deviceId=3284#)SNZB-03 Reporting Configuration Response for humidity (status: Success) is: min=10 max=120 delta=100
[dev:3284](http://192.168.0.151/logs?tab=past&deviceId=3284#)2022-10-11 22:21:22.883[info](http://192.168.0.151/logs?tab=past&deviceId=3284#)SNZB-03 Reporting Configuration Response for temperature (status: Success) is: min=10 max=120 delta=10

If you can't wake up the device by changing the temperature or the humidity at the time when the new configuration is sent, the most sure way to configure is to pair it again to HE. Don't delete it, just pair it second time with the same driver.

1 Like

Download the Hubitat app