Optimising Evening Lighting

Hi Folks,

I have a couple of lighting rules that run in an evening triggered by motion - they basically set lights in an open plan area to a warmer white as a first step and then later in the evening turns some lights off and lamps on etc.

I’m using motion sensors to only trigger when the room is occupied.

Although they work, I don’t think I’ve written these in an optimal way and hoping for a few tips on how I might optimise.. Thanks in advance!!

Stage 1:

Stage 2:

You might want to consider using Scenes, one scene for each. Then, you could simply play around with how you want the lights for each, then capture that scene, change the action to scene transition from one to the other. Makes it easier to tweak how you want it.

2 Likes

Also consider that any time the motion goes active this rule will trigger again. In the living room this could start spamming a lot.

image

1 Like

To me, that's one of the best reasons to use the Motion Lighting app - it handles all of these details. In fact, I believe that Motion Lighting could handle this, especially with scenes. That's how I do all my room motion - vacant and occupied scenes.

3 Likes

I agree completely. Especially if you aren't going to use motion zone/trigger aggregation.

1 Like

Switched to scenes - that’s much easier to manage! Thanks for the tip - I hadn’t explored scenes... a few quirks with the capture but all working now..

I was coming back to ask about the motion triggering the evaluation unnecessarily i.e. if it already has a scene active - no need to re-evaluate .. is the motion app mentioned a community app?

I see its a native app.. so I’ve set up as below:

What does the 1 minute delay do that gets added as a default?

... I figured it out as all my lights turned off ! :slight_smile:

So this is where I landed; it’s not quite right for my use case though; ideally unless the override switch is on, I’d want it to activate the scene on repeat movement. What seems to happen is, it activates on first movement, if some devices are switched off manually, the scene changes to not active, but i’d expect movement to trigger the scene again... it doesn’t...

The reason I like it this way is if the lighting is messed with inadvertently it will revert back to the scene unless it is explicitly overridden..

Is there a way to have it handle repeat events differently?

Create a motion aggregation group for your Konnected Hallway and Living Room motion sensors so motion in either counts as one activation instead of two. In the motion aggregation group extend the activation time to say 5 minutes. You can tweak the timeout on the aggregation group to your liking.

It's Zone Motion Controllers in built-in apps.

This new device will become the trigger for the rule. Even at 1 minute it would be way less spam.

It will also prevent the rule from retriggering in the middle of an execution if they trigger both motion sensors close together.

Makes sense, I;ll give that a go! Thanks for that

It’s a shame the motion app doesn’t re-run actions on each motion if for example a scene moves to a not set state from a manual change to a device - but I guess this is really for turning lights on on motion and auto off again..

@bptworld Has a Scene controller app. I haven't explored it much but he does all kinds of crazy things with it.

1 Like

In the aggregation set up - does the mode setting, mean that the virtual motion sensor will only activate in specific modes? If so that’s another way I can reduce the need to run the rule and evaluation step on motion..

Set for specific mode(s) only, default is all

Yes

As you start building up all your rules sometimes you'll have overlapping executions of things going on. You don't want to get to the point where you are saturating the mesh and missing events or executions. It's better to build in the rate limiting early so you don't have problems later.

1 Like

Thanks for the advice on this!

Download the Hubitat app