[OLD] MQTT app beta1 and pre beta2 - please use beta3 thread

excited to test this out. Thank you!

Firmware v2.2.0 has been released now for the hub.

IF you upgrade and IF you have a very busy MQTT setup with messages exchanged with your broker every few seconds and IF you experience any new slowdown after you have upgraded, then contact me re. early access to beta3.

Beta3, which is currently being tested with some users, changes from using events to a parent child setup which means that the backups that HE has to perform can complete quicker if there are lots of events. As 2.2.0 changes the way backups are prioritised, beta3 is recommended with this new firmware. Beta3 should be out for everyone this weekend anyway.

I'd love to try Beta 3 - some inconsistencies sinces moving to 2.2.x

@shane1. Dot you have a lot of updates from MQTT to HE - say more than one every 2 seconds ? Are your inconsistencies to do with speed?

If not I'd very much like details / bug reports as moving to 2.2.x should only really effect backup speeds under very heavy MQTT traffic.

An update on beta3...
Two of the pre testers identified a serious bug.

Beta 3 fixes enabling devices publishing to MQTT using ‘everything’ (all capabilities) which was broken in beta2. Consequentially devices enabled under a capability drop down like ‘dimmers’ now rigidly enforce only publishing that capability for the device, meaning in this example ‘onoff’ would not be published, you would need to enable the same device in ‘switch’ to enable that too.

Very useful but has been very awkward to implement and a couple of issues have been found. Spent a few 7am nights this week and still working on this, but I’ll get beta 3 out ASAP. This is the last remaining issue I think. It would have been very unpredictable for people upgrading.


OK I am posting beta 3 tonight at last !
It will shortly be in the MQTT beta 3 thread here.

I will leave this thread for a few days and then ask for it to be closed. If you continue to use a version prior to beta 3 or have a general question post here for the time being.

Beta 3 has a lot of changes and a whole new architecture as parent/child. It represents the last step in feature additions and is near release so I don't expect there to be a beta4.

Please read the first few posts in the new topic when upgrading or it will not work. If you are running latest 2.2.0 firmware on HE I do recommend you upgrade.

There's bound to be a few initial issues and so I will promptly post hot fixes if needed and I will be looking to add this version into Hubitat Package Manager shortly. It's only one app and one driver and one optional driver so not hard to install anyway.

1 Like

@kevin did you get to creating Virtual Pressure Sensor or Omni sensor with the pressure sensor in it?

I have multiple smoke detectors, environmental sensors, and weather station, unfortunately, I can't use it easily without habitat support. Maybe @mike.maxwell will create Virtual Pressure Sensor later in some next firmware updates, pressure also missing in RM4. Until then I could use user-created driver.

The only driver I am offering is the virtual MQTT text device. I'm not intending any others and I only support creation of virtual devices using HE's virtual drivers of which there isn't a pressure one unfortunately.

@mike.maxwell any chance for creating Hubitat Virtual Pressure Sensor or is it completely out of the scope?

I am very new to MQTT. I have a broker setup and can connect to it using MQTT Explorer, but I get the following repeating message. I tried completely removing the driver and app, restarted the Hubitata, and reinstalled, but the same message pops:

2020-06-01 04:21:37.394 pm infoMQTT> MQTT connect failed attempt:[null], try again in 10 secs

dev:652020-06-01 04:21:36.362 pm infoMQTT> Connecting as Hubitat_temporary to MQTT broker null

dev:652020-06-01 04:21:36.357 pm infoMQTT> MQTT> client null temporary

Maybe a view of my broker config will help. If not, post yours so we can see what you're doing.

I could post it, but it looks nearly identical...except for the Hub Name. I have the tcp and the port the same.

OK, which broker are you running and on which operating system? What network components lie between your HE and the broker system? Using any firewall?

Have you rebooted HE after installing the MQTT app?

Mosquitto runnning on a Synology NAS. The HE is on a different subnet than the broker, but it's on the same subnet as the MQTT Alarm Panel that can connect. The gateway has full, bidirectional allow rules between the two internal subnet, and the traffic logs do not show any indications that the traffic is dropped.

Can you run wireshark on any system in the path between the HE and NAS? I'm not familiar with the NAS so I don't know if wireshark runs on it but that would be a great place for it.

Hi both, The MQTT app is not communicating with it's child MQTT driver, here you see the null/temporary details.

Can you delete any and all MQTT Client type devices that may have been created and then just restart the app which will re-create the child again. You don't need to delete the actual driver code.

I think maybe the device wasn't created as a child the first time. You can see this within the device itself...


Deleting the child device and restarting the app worked.

Sorry Frank, this is my fault - apparently an app isn't 'installed' until you first hit done. Strange but true. I thought it was installed at the time you 'added' it.

I create the child device before you hit done and so it isn't actually a child of my app at that stage . I will fix that.

This is a beta3 issue and does not impact beta 1 or 2 users. I just noticed it's in an old thread.


In the meantime anyone with this issue delete the MQTT Client device and re-run the app.

How do you get access to the beta3 thread?

Have edited the original post link which wasn’t working :thinking:

The instructions are for beta 2 .. just updating them now. Read the first few posts in that new thread to get going for the time being...