Old Issue Rearing It's Ugly Head Again I

After authorizing all the devices with the Google Home App in Hubitat, I try to connect to Hubitat with Google and get the following error:

The parameter "state" must be set in the query string.

I know this was an issue with one of the earlier firmware versions, but I'm seeing it again tonight. I sign in using my Google credentials, and I'm pretty sure if they were the wrong creds, I wouldn't advance to the page which asks which location I'd like to connect to, as seen in the first screenshot.

I've just updated the firmware, and wasn't having this issue last time I tried this. I've provided a screenshot of my hub info as well. Looking forward to getting this worked out!

Thanks guys!

There is a later firmware you could try.

How do I get it? I get this when I check t for updates through the hub... I suck at technology...

All three of my hubs say that...

Why do you think there's an Update available that you are 'missing'? What version are you on? The latest is:

Cause of what that guy said... I've attached a screen shot of my current firmware version, pretty much because I'm too lazy to transcribe it. It looks like I'm a dollar late and a day short on the ole' firmware... I have limpware, and thus have firmware envy.... Dang.

I feel like I'm being Amish shunned for inappropriate silliness.... When will people recognize what they refer to as "Im-matoority", not as a moral failing, but as the debilitating cognitive defect some of us are forced to live and struggle with every day of our lives!!?!! WHEN??!!

Just kidding, I have red hair, sooooooo, yeah.

If the update no longer exists, which seems to be what you're saying, it would be because Hubitat got a report of a problem then 'un-released' it :frowning:

So don't be envious of my code that has such a fatal flaw that the code has been retracted :sob:

The update existed as of last evening, when I updated one of my Hubitat Elevation hubs.

@pete3500 - have you tried rebooting your hub via the SETTINGS web page? Sometimes that allows the hub to reestablish its connection with Hubitat's cloud server, where the firmware is downloaded from.

Do you have a DHCP Reservation for your HE hub in your router's DHCP server? It is best if your hub's IP address does not change.

BINGO! WORKED, and all issues resolved! Thanks everyone!!!