Offline Hub cannot keep accurate date time

I am a docker user but based on @dan.t link it seems like a trivial process to install and configure the ntp server. I have found that adding really simple packages to a container actually increase the complexity of configuring and maintaing them. Just my personal experience, but thanks for the suggestion.

I have a Netgear Nighthawk router (probably with a very similar interface to Orbi) so I don't have the advanced config options to do internal>external port redirection.

I have the no-hosts flag in my dnsmasq config but I should be able to set this up in my dnsmasq conf file.

Thanks for the suggestions guys. I will look into setting this up sometime soon.

1 Like

It definitely is. If you already have a linux server you can dump it on, that is easy too!

I have an Ubuntu box and a few rpi's. I would prefer to have all the Lan services (DNS, DHCP and Ntp) all on the same box pi to rule them all. hopefully I can set it up and avoid any of the DNS redirection problems Dan eluded too earlier. Only one way to find out I guess.

1 Like

I had the same problem, but I moved my GPS Pi to my basement, and ran the GPS extension cable to the middle of the house - away from metal obstructions (but nowhere near a window), and it works doesn't really need much signal at all with the external antenna...

1 Like

I always advise using specific NTP time server names in /etc/ntp.conf instead of pool names. If you're running a GPS Stratum 0/1 server, it is allowed to use specific named time servers in Stratum 0 or 1 who have identified themselves as "public" time servers (as you are googling for NTP time servers, you'll find the registry for public time servers that you can use).

This will address the issue of redirecting back to yourself.

I run a rPi 3B+ as my dnsmasq (DNS & DHCP) server AND my Secure NTP server (with the GPS Hat), along with unbound as my (private) DNS resolver (instead of BIND). All this runs without breaking a sweat.

I have a second rPi running backup dnsmasq (DNS only), plus (standard) NTP server and backup unbound. I also have this 2-Pi setup at my vacation home, and the two sites use each other as secondary time servers, along with several public Stratum 0/1 servers that are "nearby" to each locations' internet provider (FiOS at one, Spectrum at the other). The secondary servers at each site also perform local backups of all the sites' rPis (to a USB hard drive), and the secondary server at home also collects munin stats from my 9 rPis...

These little rPi3B+'s can do an awful lot of network I/O without much effort...I am now looking to consolidate these services and even more onto a single rPi4B (4GB version)...

Thanks, @ronv42!

FWIW, I don't alias all four pools (0-1-2-3) for any domain, because I've found that DDWRT-based NTP servers (eg. MeteoBridge/WeatherBridge) will actually reject duplicate NTP hostnames anyway. Including my local (Stratum 0/1) server in just one of the pools is enough to get my server to be preferred over the remote ones- since the response time will be so much better.

I remember why I had omitted - I have instead just pointed all of my window hosts directly to my local server :slight_smile:

my blinds supposed to open everyday if there is motion in a sensor between 6:00 am and 11:59 am. Today there was motion within this range and the blinds did not open. I checked the time in hubitat and it was actually 2:00 am so that explains why my blinds did not open but the question is why hubitat hub did not have the correct time?? I had an internet failure and a hub restart 2 days ago so that could have caused the time to go wrong but should not the hub automatically after that get the correct time from internet ?? is not it automatically ??

They say it checks every hour. Possibly if its too far off, it doesnt auto-correct? It has been seen where if NTP isn't available right at hub boot time, if say the router and modem haven't completed booting and connecting yet, hub time does not get set.

Since 2.1.5, you can now install a NTP client to keep the time synced.

Great once I migrate to 2.1.5 I will install it. Thanks

Have you tried the "update time from browser"? Should work, go to settings and select "Hub details". It's at the bottom.