NST and heating while I’m away mode

I’m using NST Manager with my Nest thermostat and have the below rule setup to take the thermostat out of eco mode when leaving work. The rule is firing because I get the notification but the thermostat isn’t actually starting to heat. Im sure it’s something simple but it’s alluding me.

All I do is set the nest to home of away depending on if the mode is in a home mode or a away mode and that then does the heating. I think that is easier.

I then have a homeward bound mode that if the mode is in away and we enter the much larger geo fence it sets it to that mode so the house starts warming up. It lets me know by a notification that it's doing that.

Now if we then enter the small geo fence or are connected to the WiFi, it then sets it to the normal home mode, to which the nest mode is already home. If we leave the larger circle again it will send the nest mode back to away and notify that we left again and it's being set back to the away mode for HE and nest.

BTW in this homeward mode everything is exactly the same as the away mode only difference is the nest. So all alarms/ lights are still in the correct state.

So what I'm also saying is that it's probably not working because your nest is in away mode.

The behavior you’re describing is definitely what is happening. I hadn’t thought of creating a separate mode for this use case.

I created a headed home mode that should set nest to home but for whatever reason that’s not working. I’m a little hesitant to mess with nst manager as I don’t want to break the entire thing.

Could I use a custom action in rule machine to set nest to home mode?

Yes that's what I do, works perfectly.

Sorry for the long wait, should this work?

Yes that's it :grinning:. No parameters needed.

I have this setup and nst Manager reflects an home status but the nest app never updates to reflect Home.

I’m a little worried that nst Manager is broken even though it shows the api status as good.

Have a look in the app as see what you have to decide how to determine if your home. It may be setting it away again, mine are all off. Also have you created a virtual presence device in the NST manager app? That's what I use to control the home /away.