Notify on door lock code

So, We are selling our other home and wanted to be notified when the realtor opened the front door using their code. Seemed simple. Notifications->Door lock code->realtor

The issue is, even though the logs and %text% say its the realtor, it actually sends a message for ALL codes even though only the realtor code is selected.

I have confirmed this on our other HE system as well.

Bug?

You did not mention which lock you are using, every lock manufacturer is different with what message it sends

It's a quickset z-wave. Don't actually see how that is relevant.

If they are giving you options to select a lock and a code, there should be in place the coding to distinguish the selection. I'm not coding the routine looking for responses. I'm just using the built in functions. So what the lock returns should be irrelevant to me.

Can you show how you setup the notification? This should have nothing to do with what type of lock you are using. A trigger in RM should be sufficient to notify you. See below as an example, but change Any Lock Code to realtor for your needs.

image

Change %text% to %value%. %value% is the variable for the user.

Here's what mine looks like:

Notify Pushover: '%value% unlocked %device% at %time%'

This sends the following (as an example):

Realtor unlocked Front Door Lock at 11:11am

Message isn't the issue. It sends a message on ALL door openings. Not just the 'realtor code'

Try a trigger in RM and see if the same occurs. If it doesn't, then there might be a bug in the Notifications App.

First off, I can reproduce what @Mensan reported with a Schlage BE469. Second, the trigger works perfectly in RM as suggested by @jkudave.

So there might be a bug in the Notifications app.

Also - as @waynespringer79 mentions, there are lock-specific quirks. Heaven knows we've seen a bunch of them! But this issue appears to be shared by two different z-wave locks .....

Edit: @Mensan - just use RM to send you a notification ..... that's a quick workaround.

3 Likes

I have a BE469 and have reported the same issue happening to me a few times, as well. I just gave up on the Notifications app and used a Rule Machine trigger instead, which works as expected. But glad to know I'm not the only one with this problem. I suspect it's a bug, so hopefully it can be fixed.

1 Like

How did you setup your notification. I have it set to "%value% unlocked %device% at %time%" HE%20Notification%20Rule

When the notification is sent I get " unlocked at TIME" where the time is correct.

That's about what I have, just with my text in a different order--not sure why it wouldn't work for you. (Surely at least %time% should give you something... :scream:)

thanks for your help. It appears that my issue was more with the lock not reporting properly to HE. I am going to try a repair on my network and try again.

Just want to report that I have a Schlage BE369 and I am experiencing the same bug with the notifications app as @Mensan noted. Not sure if admins are monitoring this, but definitely appears to be a bug. I will switch to RM for this notification as well.

Same issue observed with Yale lock. Following are the screenshot

App code:

Action log when I unlocked the door with my code

It looks like the problem is in the triggering in Rule Machine and not with the locks or the app

I was getting really frustrated with not being able to get Door Unlock notifications but I think I found out what was happening.

On my Lock Device I had "Enable Lock Encryption" enabled. As soon as I disabled it everything started working just fine.

Hope this helps someone.

I would post a screenshot, but I don't seem to have permission. :frowning:

Edit: well, it's the next day and it has stopped working again. I don't think "Enable Lock Encryption" is the problem any more.

Also, Maybe Related: Kwikset Smartcode 910 Zigbee Not Recognizing User Code Entered

Edit: Something below didn't work as expected. I was able to get 4 Schlage locks working perfectly using the steps from the post after this one. Leaving this one for reference, but if you follow the steps from the next post you should be golden. Good luck!

(Old broken process, see next post!)

I think I fixed it, or at least it works for now!

Alright, I was able to get my lock to notify again. I'm not sure if it will break again after 24 hours, but I'm going to dump my notes here as it will hopefully help someone to get their Schlage Z Wave lock working.

Introduction
I just recently moved from SmartThings to Hubitat. During the move I excluded my locks and then included them into Hubitat. This went VERY well and I thought everything would work just fine. I did not factory reset the hardware however, I did however delete all the old codes in Lock Code Manager via Hubitat after the inclusion so that I could re-add them properly. (They read as ???? instead of the actual codes.) This was a migration (lock was already setup using smart things), not a new (unboxing) install.

I enabled "Code Encryption" on the device and then went to setup notifications. Then I noticed notifications did not work. Then I disabled "Code Encryption" and it worked again for a few hours. Then notifications completely stopped working... again.

I came across a post regarding another lock (Kwikset Smartcode 910 Zigbee Not Recognizing User Code Entered) which suggested removing, resetting and re-adding the lock.

This worked, notifications are working again and hopefully they will continue to work and not break again after 24ish hours. I will of course update this post if it breaks again.

I apologize for the excessive details above, but I wanted to make a note of everything to help troubleshoot if it happens again and hopefully it will help someone else.

The Fix
(PLEASE READ THE MANUAL BEFORE ATTEMPTING THIS, WARNINGS AHEAD!)

  1. Factory reset the lock. Unplug the battery, hold down the Schlage logo on the outside of the lock and then reconnect the battery. The light should blink twice and the device should now be factory reset. All previous codes are now reset, the lock is "almost" factory reset. There are additional steps to finish the reset, please see page 12 of the manual. You have to use one of the 'default' unlock codes to calibrate the lock and continue.
  2. Factory resetting the lock does not seem to exclude the lock from the z wave network by default. To exclude the lock, start Z Wave exclusion on the Hubitat Hub and then on the keypad hit the "Schlage" key -> Type the locks programming code (found on a sticker under the inside of the lock) -> Followed by the 0 key. (See page 13 of the manual). If you get a green confirmation on the lock you're golden, if not, you many need to move the hub closer to the lock like I had to.
  3. Once your lock is excluded, simply include new devices and repeat the process (Schlage key -> Programming Code -> 0) and Hubitat will find your device.
  4. I also had to manually delete all of the user codes at this point. (Schlage Key -> Programming Code -> 6 -> Programming Code)
  5. Re-add your codes, setup notifications (I used rule machine, though I think Notifications would work again now) and everything should work perfectly.
  6. If you had to physically move your hub closer to the lock restart your hub now via the settings tab. If you don't, you may need to repeat all the steps above. For some reason my hub forgot everything I did after I plugged it back in inside my networking cabinet.

Another thing I need to check is if adding a 'disabled' lock code caused the problem. I had some weird stuff happen last time I tried that but I haven't pinned that as an issue and my be an unrelated bug.

I should probably re-read this and fix all the typos, but it's 3am and I'm sick of troubleshooting this lock. It works for now and I'll check it again tomorrow. Will update if it breaks, otherwise the fix is above. If I can help anyone troubleshoot this further please let me know.

Edit
Well, it did stop working again. I think it may have to do with power cycling the Hubitat hub. Will continue troubleshooting later and will report back. :\

2 Likes

Well, 2 days later and lots of blood sweat and tears but I finally got 4 locks reliably installed, configured and sending notifications. Sorry for the back to back posts, but I'm hoping my headaches and notes can help someone else.

Going to leave my last post for reference in case it helps someone, but here is the final process I used on my Schalge locks to get them setup.

There is a very good chance that you're going to need to physically bring your hub to your lock or your lock to your hub. Like within 3 feet.

  1. Exclude the lock from the network.
    Set your hub (any) into exclusion mode and then on the keypad hit the "Schlage button -> Programming Code -> 0 (zero)". You should see a green check mark on your keypad indicating your lock has been excluded.
  2. Factory Reset the lock. Unplug the battery pack from your lock, hold the Schlage button on the keypad and then reconnect the battery. You should see the light flash twice.
  3. Use one of the 2 default user codes at least once (from the same sticker as the programming code). This will calibrate the lock or something like that.
  4. Delete all of the codes from the lock. "Open your door so you don't get locked out, lock the lock (bolt out), press the Schlage Button -> Enter the programming code -> Hit 6 -> Enter the programming code again." Now all of your codes are removed.
  5. Put your hub into pairing mode.
  6. Hit the "Schlage button -> Programming Code -> 0 (zero)." Your hub should find your device. Name it and save it.
  7. Wait. Like seriously... just wait like 2-4 minutes. I think a huge portion of my problems from yesterday was due to my lack of patience.
  8. Setup your Users and Codes in Lock Manager. Only add "Active" users, do not add any "Disabled" codes. I haven't double checked this but I think disabled codes cause a bug where codes are added to the wrong user.
  9. Setup Notifications. I would recommend using Rule Machine, but you should be able to get the notifications app working at this point too.

If you get stuck somewhere with any of the Schalge line of Z-Wave locks I'm happy to help troubleshoot. Hopefully the notes above will help with other vendors too.

I need to re-read and edit these posts... but that's for another day. :slight_smile:

Good luck!

So I just noticed that this is still happening to me. @bravenel, did you write the Notifications app? To summarize, the problem that we're seeing is that a Notifications app like this:

notifies you instead when any code is used, not just the ones you've selected. Most of us have Schlage Connects, but I'm not sure if that's really the problem. A Rule set up to only trigger on the same codes works fine, so I don't think it's a problem with the device.

Let me know if you need any more information to troubleshoot!

Yes, I can confirm that there is a bug in Notifier. Will look into it.

Bug found and fixed. Will be in next release.

6 Likes

Download the Hubitat app