Notifications....again

Again, all mobile app devices have stopped getting notifications. Several times recently this has happened and each time I have determined it was not on our end. Has this been a recurring issue for others as well? Is there something that's been going on with the service?

2 Likes

Others have talked about needing to accept the "What's New" dialog that appears after an update to the mobile app, more so in terms of Geofencing not working, but maybe it has a similar impact on notifications?

1 Like

I had problems early on with the built in notifier. I switched to pushover and it's never been an issue since. Just my 2 cents.

5 Likes

It's starting to look more and more like I need to go that route. I already have it set up for very important notifications to take advantage of it's emergency override of silent mode. I may have to start playing with further customizations on that.

Still not working after running through everything that has worked before. @bobbyD

I cannot replicate. I have several push notifications coming throughout the day that never stopped once, in months. I have Galaxy S21 and my wife has S10 running Android 12 and 11 respectively. Without further details is hard to determine why yours stop working.

Well I JUST discovered 1.6.8. I was on 1.6.7.

On 1.6.7 I would click notifications and the page would never load. Now on 1.6.8 it loads instantly. I'll run some tests and report back.

I'm also on 12 on an s21

1 Like

I feel dumb. It seems to be working now. Sorry for the fuss.

1 Like

It can happen, no reason to feel dumb.

2 Likes

No worries. And don't feel bad, I would be super annoyed if mine would stop working. Be sure to check the battery optimizations, to make sure that your phone is not killing the background process. That will stop the notifications again. Samsung wants to have good reputation of long lasting battery, so they have several custom optimization features on top of what Android already has.

2 Likes

If it's okay, I'd like to hijack this thread a bit since it seemed to resolve.

I am running 1.6.7 for the push notifications and don't even see an option to upgrade my Pixel 4a on the Play Store.

Not sure if it's my imagination, but it seems like I've been missing more and more notifications from some zigbee sensors lately.

Does the app always have to stay running in background? I don't remember having to log in every time either.

This could all be something to do with having recently added a bunch of new zigbee sensors, but i sure miss a lot of notifications if I'm not connected to the hub via the app.

Also... Would the presence of another devs dashboard app installed on my phone disrupt any of this?

Always too many variables to consider with this fun platform. Not to hard for a tinkerer to get out maneuvered by gremlins.

Have you looked into the battery optimisation options on the phone. I posted on another threads on one of the settings I needed to change, I'll try and find it...

This was my post (plus a few after it) where I was talking about my experience. I think I just needed to restart my phone, but maybe there will be something else in the thread that may help you.

1 Like

I've just got a new s22 Ultra and cannot for the life of me get push notifications working. I'm on 1.2.7 build 126. All permissions on all the time, 'revoke permissions when app not used' off, battery optimisation off etc. I've also uninstalled/re-installed to no avail.

I also have the location issue where inside/outside of geofence won't update until I touch the radius slider, and when it does, I don't get the push notifications for arrive/depart etc. Clicking on the app notification menu just results in an endless spinning circle that never updates.

Would app version 1.2.8 fix these issues?

*EDIT - went nuclear and removed my phone entirely from Hubitat and registered my phone anew in the app as recommended above - seems to have worked... Only this darn geo-fence issue to overcome now...

So I enrolled on the BETA, nothing has changed, cleared cache/data, uninstalled/re-installed after restarting my phone still no push messages :disappointed:

I'm on 1.2.8 build 128 with a Galaxy S22 Ultra using Android 12.

The app is completely unrestricted, location on all the time, no optimisation, no revoking of permissions if the app isn't used for a while etc.

I'm kind of out of ideas now, @bobbyD can you help?

Have you considered Pushover?

Not yet - but I will if this fix (see my edited post above) doesn't last...

Geofence has always been a issue. I would look into an alternative like life 360 which seems to be more reliable

1 Like

1.6.8 beta build 128 fixes geofencing for most users. If you're still having issues, try uninstalling it and reinstalling it, move the radius/pin around, remove device and set it up again, etc.

2 Likes

I have been dealing with notification to my phone (Samsung Galaxy S20) not working for a long time. It worked for a while then quit. I was able to delete my phone and re-add it and then it worked for a while and then quit again. I installed a flood sensor by my water heater and wanted to be sure I get notifications but was not able to get it to work again. I installed Pushover and it has been working for me. Not sure why the Hubitat app doesn't do notifications, but Pushover did the trick. My guess is Hubitat is missing some security setting on Android that makes it not work.

Download the Hubitat app