[No Longer Maintained] Energy Cost Calculator

I can look into it, but that app is already pushing my limits of code. And those 'On' times are stored as strings.

I'm familiar. If I can some time, I'll send you a PR.

For the IotaWatt users:

I'll be figuring out what needs to change to get energy reporting into HE. I don't imagine it'll be much.

1 Like

Im messing around with it now. Will PM you if I get stuck.

Good luck!

Power monitoring added. Time is a string format so not sure how you gonna use it.

1 Like

I've released a new driver for the IoTaWatt integration: [RELEASE] IoTaWatt+ [BETA]


What is the best way to deal with billing at 1 rate up to 1000 kWh and a different rate above the 1000 usage?

1 Like

Ooo....that's a new one. Could you pull the rate scheduler for your power company, or just tell me who they are so I can? I'll need to code that and release an update.

I might be able to kill two birds with one stone. I was looking to add the ability to change the rate based on a virtual switch turning on. A simple rule of >1kwh, turn on switch would fit the bill.

1 Like

I sent a PM with a link to the document.


1 Like

I installed this app a few months ago, with 6 devices selected.

A few weeks ago one of them just quit reporting any energy, and since I haven’t been able to get any data from it.

It is a Tasmota flashed device, (Sonoff POW device) and if I select it from Devices, everything looks normal, with all information being reported correctly.

All other 5 devices are also Tasmota flashed plugs.

Where should I look to make it work again?

From the device page, go to Events and be sure that the entries are recent. If the plug stopped reporting, the attribute data will still be there but will be stale.

If everything is good there, turn on debug logging for the app and wait for the plug to refresh (or force a refresh). You should see log entries for it when the 'energy' value changes.

Last resort would be to unstick the plug for the device selection, click done, go back into the app, and re-select the plug.

I already did all three options and still no luck.

Please take a look at this log info and tell me if you see anything weird or wrong.


Edit: BTW, I’m using @garyjmilne Tasmota drive

Log looks good to me. I would say that the reporting interval is as low as 10 seconds and personally I would find that generates too much activity on the hub, but I doubt it is having any effect on your particular problem.

P.S. Just make sure that the device attributes are accurately getting updated by those incoming values.

There's no energy report.

I've been out of the loop for a few weeks. Everything has been humming along. I went to check my energy report today and noticed that I have no updates on majority of my KP125's since last month. 2 of them are reporting, not sure why only those 2. Did something change recently with this report or the kasa integration?



Washer (Reports correctly):


Heater Plug (Doesn't report):


Nothing has changed for the app. There was a Kasa update and I ran into issues with most of my devices not reporting as well. I did end up resolving it. Start with the below post and read your way day:

My Modify Lan settings was unchecked. Do I need to set the MANUAL IP on all my plugs? Strange that it's not all of them. Some work.

It looks like recently an update was made to the energy reporting plugs in the kasa integration. I guess I'll need to get some help in that thread.

My fault.

I had the wrong settings on the driver’s settings.

Now it’s reporting again after correcting it.


1 Like

I had the same problem again this morning. I went into the Kasa integration app and selected "Scan LAN for Kasa devices and add", waited for it to finish, hit "Done" (because I had nothing to add), and the plugs started working again.

1 Like