No Devices Found

Good day folks,

I have add my Hubitat C7 installed for two years. Starting off with just managing 6 lights. I hade a Schlage Lock installed but never tried to manage it within Hubitat. I added it a few weeks ago, but realized I need to add a few range extenders.

When I was looking around the Hubitat forums, I came across a thread on the Hubitat Z-Wave Mesh app. I installed the app and it appears to be working correctly. One of the things I noticed is that I have four (4) deivices listed as "No Device Found". Three (3) of them are listed as "Secure Keypad Door Lock" and one (1) as "Power Switch Binary".

I have read the term "Ghost Device" used throughout a number of threads. Is this what they are?

Are these devices detrmintal to the overall perfomance of the Z-Wave mesh?

How would I go about getting rid of these devices?


Start with this Ghost Thread.

Add some pics/screenshots of your devices so there's a better picture of what you're dealing with. :wink:

1 Like

Thanks for the reply....

I should have included screen shot in the first place.

I am not seeing the "ghosts" in the Devices section of the main Hubitat screen:

I am seeing them when I run the Z-Wave Mesh Details app:

Where do i find the built-in Ghost removel tool.


Go to Settings >> Z-Wave Details and refer to the Ghost Thread that @Ranchitat lists above.

It looks like you have you have 3 failed attempts to join the front door lock and 1 failed attempt to join the garage lights. You should remove power (battery) to the front door lock before you attempt to remove the 3 ghosts or you will not be able to remove them. Same with the garage should kill power to the garage light switch before you try and remove the failed node 06.

Thanks...that cleared some things up for me.

One question...from the screen shots i sent, how were you able to determine that the 0x06 No Device Found was a failed attempt on the Garage Lights?

Thanks again

A ghost can be left over from a failed attempt to join a device. Usually, it is the next successful device in the Z-Wave Details list that caused the ghost. With regards to node 06 that appears to be the garage lights, but you need to confirm that from the Z-Wave Details page.

You need to kill power to the device that caused the ghost, or HE will assume the device still exists and refuse to remove it.

1 Like

I am on the east coast of Canada...1.5 hrs ahead of EST, so I am only seeing this now.

Here is a screen shot of the devices:

Asking so I can understand better.....from that screen shot, can you definitely tell it was a failure on the Garage Lights switch?


The one at the top with discover on the line needs to be removed, that's a ghost. Click refresh then remove... If it doesn't remove,, disconnect power to the Garage lights. Shut down the hub from the settings menu and unplug power for 5 mins and power back up and attempt to remove again. Ghosts will wreak havoc on your mesh.

1 Like

Worked perfectly....thanks


Looks good! Are you doing cloud backup for your hub (with Hub Protect) ? If not you should. Standard local backups don't backup the radios