No cloud connection and remote app after hub's IP changed

I have Tablet with Dashboard (via Kiosk Fully Browser) in local network, it started showing 404 errors couple days ago, i noticed that hub's IP address changed (DHCP) and i updated IP address in Dashboard's URL on tablet, dashboard worked for one day and then showed same error with old IP in URL... i cleared browser's cache, but it still tried to find hub with old IP after restart, so switched to OLD STATIC IP in hub's settings, local tablet works without any issues now, BUT my remote app on the phone lost connection, in local mode it tries to connect to last IP that DHCP set, and there is no way to update it in the app?! Also app and hub itself lost connection to cloud (to my Hubitat account)...
I've tried to restart hub, to register it again to account, log out and login, nothing helps. Also noticed that some devices stopped working with rules... Don't understand what's going on...

Please HELP!

I'd suggest that instead of using a static IP on the hub that you set up a rule in your router to always give the hub the same IP.

The difference is that with the current setup, if your hub goes offline there is a small chance that a new device on the network can be given the hub ip and when the hub comes back there will be an IP clash.

For the hubitat app, have you tried logging out and logging back in afterwards? I had a similar issue before where the IP changed and I couldn't get back in for a while from my phone.

Not sure about the rules. Are the devices local or network devices? Anything on zigbee or zwave should only be local and not affected by the network. You can actually just unplug the ethernet cable and the rules working with local devices will continue to work

Yes, i've tried logout and login again in app, it takes time to retrieve data and then it says Hub is not responsive, please amke sure it's online (even reinstalled the app and login).
I see on hub settings, that "Cloud connection unavailable" in system messages, so i believe cloud wont see this hub any more also...
Internet is working.
So i don't understand how the app got and remember new IP DHCP assigned, but can't get new static one...

Hmm, looks like Static IP setting doesn't work correctly. Hub becomes unregistered. I've tried everything, could not register it again... Only when i switch it back into DHCP mode it's registered again and remote app found it.
That's crazy that even hubitat support did not tell that this feature is not working.
Waste a lot of time.