No cloud and wrong IP address displayed

I Hubitatians,
I have 4 Hubs, 3 over one property.

My most recent addition "Rooms Dorm Side" displays the wrong IP address in "Registered Hubs" The address it displays is the original address that was served to it prior to fixing the IP address in the router.
Screen Shot 2021-09-15 at 4.52.08 pm

It also has no cloud access and I cannot access it remotely using the app. The other 2 Hubitats which live on the same network operate perfectly.
Any thought?
Thanks
Tom

Are you connected to the router using a wired connection, and have you used that same connection method (wired or wireless) the whole time?

I'd also check whether the hub is blocked for any reason in the settings on your router, or whether your router may block it by default unless you grant it access.

Was the hub ever operating under the assigned IP?

Hi SBurke,
Yes the Hubitat was connected via cable.

I now suspect the Hubitat may have been registered by someone else and returned to the vendor as the vendor has since told me it was his demo.....

I have tried numerous IP addresses each protected from the router's DHCP.

Does anyone know if a Hubitat was already registered to someone (and they reset it) if that would effect its behaviour connecting to the cloud and being identified correctly in Find My Hubitat?

Thanks

Tom

I'm expecting the answer may be yes, but can't claim any experience myself. Might be one for support... @bobbyD ?

Since the hub is listed as being Registered to your account, I don’t believe it being used is the issue…but I am not 100% sure.

Have you rebooted the hub? Usually that will cause it to reconnect to the Hubitat cloud.

1 Like

Yes I have rebooted the hub several times, changed its IP address too. What bugs me is my 2 other hubs operating on the same network behave perfectly and I can connect to them from the app.
The million dollar question is how can a hub be displayed with an incorrect IP address in "Registered Hubs". This then means I cannot remotely access it but I can access it locally by using the correct IP address.
Is it faulty? If it is its very odd.....

The reason I suspect registration issues this Hub (192.168.2.12) will not register yet other on the same network have no issues.


A Full Reset will also reset the Hub Registrarion. I’d give that a try, but be forewarned that both the Zigbee and Z-wave radios will also be reset (which is probably a good thing since this hub was used.)

Just last week I bought another second user hub and although the hub had been reset by the seller I had a similar issue. The hub was assigning itself a 168.x.x.x address at boot up - my network is 192.x.x.x. I tried the hardware reset button to no avail and eventually had to switch my PC to 168.x.x.x to access the UI. It was showing as using DHCP. I performed a few hard resets and eventually it acquired a 192.x.x.x DHCP address and all became well and I could register it.

What I noticed was the the UI indication of DHCP vs static didn't seem to display correctly or hold the newly assigned IP choice. It repeatedly went through 'new hub' setup but it was also maintaining the previous owners email address ie the previous registration detail. Not sure why but it got there eventually

1 Like

Problem Solved. Thank you Kevin. The full reset (see other posts) worked. Cloud established, hub registered.

Download the Hubitat app