Newly Added Aqara Button Not Available To HubConnect

I am using HubConnect to send device events from my SmartThings Hub to my Hubitat hub. All has been working fine.
I went to add 2 new Aqara buttons to SmartThings today and the buttons aren't showing as available device in the SmartThings remote client app when I choose to 'select devices to synchronize'.
I have added the button device handler for both Hubitat and Smartthings. Also tried rebooting the hubs. I can see the 2 buttons in Smartthings and they show as Online but I just can't get them to show in HubConnect. Any tips would be greatly appreciated. thanks

Have you updated to the latest version of the app in ST also?

Hi. Yes I believe so from here HubConnect/SmartThings at master · HubitatCommunity/HubConnect · GitHub.
It's just that the aqara button isnt showing as a devices to select. If I go I to a different app like webcore it is there to select. Feels like it doesnt recognize the device type or isnt picking up new ones.

Ok so further to that, I just tried to add a new xiaomi door and window sensor and that does show up in hub connect so again it does seem to be device specific. Has anyone else had success in getting Aqara buttons to work?

Not sure why that was marked as solved. I am still unable to get Hub Connect to detect my Aqara button. If its useful the button model number is WXKG11LM. I am using the bspranger : Xiaomi Aqara Button device handler for the button in SmartThings.

Any tips for how to debug this would be handy. Any logs to look at etc?

Download the Hubitat app