Newbie probs: bulb control and hub update

Just got the unit today. First problem, clicked the link to update the hub. It downloads, unpacks, and then it applies, and applies, and applies the update. It never finishes. So, I moved on.

Second problem, I connected a Sylvania Smart+ ZigBee BR30 bulb. It shows up, but I can't control it. Tried different drivers, no response. Bulb model is 75584.

The actual model # on the bulb base is: 73739

LOL, I tried the update again, and this time it took. So, no problem there. Still can't control the bulb.


The previous version of the hub update UI had occasional oddities, but the new one should more or less finish on its own after you get it started. Maybe yours was really old, but glad it's sorted out now!

For the bulb, that bulb looks like it should work with the "Generic Zigbee RGBW Bulb" driver. Did you try that one? (You didn't say what you actually tried.) After you change the driver, hit the "Configure" button. Maybe do it twice for good measure. :slight_smile: Does any of that help?

Also, if you have other Zigbee devices on your network that aren't bulbs, keep in mind that many smart bulbs (especially--at least--old versions of the one you have) have been known to cause problems. See the "Tips for designing your Zigbee" mesh section in Hubitat's Zigbee documentation for more details there. This is unlikely to cause a problem with the bulb, so I don't think it's what's happening here, but it's definitely possible for this to cause problems with other devices down the road.

I tried several drivers. I'm currently on Generic Zigbee RGBW Bulb, but I got nothing. It's there, but it's not telling Hubitat anything other than it's there. Configure x10, Refresh x10. No control. No status. Nothing.

I ordered 75584, but what they sent is 73739 which appears to be an OSRAM bulb.

Not what I wanted. I think I may have to return them.

Osram/Sylvania/Lightify have so many different names that I forget which ones they used more in the past and which ones they use more now. (I think the "Smart+" ones are the more current.) Either should work, though--I have one of the older ones that does. Not sure what could be going on with this one...

I thought Osram Lightify were re-branded as Sylvania Smart+? With maybe a change in firmware, but the hardware was the same.

I just checked my BR30 bulbs. That is the exact model number that I have. And I'm using the Generic Zigbee RGBW Light driver.

How far away from the hub is the bulb?

1 Like

Also did you join the device in place?, or did you join it near the hub then move it...

The latter method frequently results in disappointment...

1 Like

The Hub is downstairs and the bulb is upstairs. The Hub has to be downstairs, no network wire upstairs, so it's shooting through one floor. The physical distance is, though the floor, about 20'-25' I joined the bulb in that location, no movement. There are no other devices.


I removed it and rediscovered it. Probably should have done that sooner.

Thanks for the help!

The newer ones have a different SOC and behave much better, especially with the latest firmware update released a month or two ago. These are the ones branded Smart+ directly on the bulb.
I actually had issues with the generic rgbw drivers not reporting state correctly and switched to the Sengled color plus driver. It works much better with the newer bulbs and now I have prelevel staging as well.

1 Like