Newbie Issues MyQ/Smart Things Invisible

I have a MyQ garage door opener with open/close sensors and Smart Things plugs.

I can't get my Hubitat to see anything. Buyer's Remorse is circling. I can't figure out what I'm doing wrong.

That's not good! Hopefully we can fix things.

Let's start with the SmartThings plugs. Which specific model? SmartThings has WiFi plugs and zigbee plugs. Hubitat can only pair (and control) the zigbee plugs.

For your MyQ garage door opener, I suggest installing Hubitat Package Manager (HPM). Install the MyQ app through HPM.

Detailed instructions on installing/using the MyQ App can be found in this thread:

It would be ideal if you had a Hubitat-compatible door sensor (not the MyQ sensor) to monitor door status (open/closed). Most people using a zigbee or z-wave tilt sensor for this purpose.

1 Like

Or Aeotec Door/Window Sensor 7 contact sensor.

1 Like

Here is the box from the plugs

Yeah - unfortunately, those are WiFi; they're not directly compatible with anything other than SmartThings. Even Alexa compatibility arises from SmartThings' integration with Alexa.

It might be possible to keep the plugs on ST and use HubConnect to expose them to Hubitat, but it’s unclear whether that’s possible any longer with the change in ST architecture. I was on ST briefly for two weeks after Wink blew up and also lost its LiftMaster integration contract, but then migrated to Hubitat when I realized what was happening at ST.

You might ask in the HubConnect thread on this forum.

Do they make non-wifi versions, still?

I bought a bunch of lightswitches that I ended up returning over compatibility issues. I'm getting frustrated.

Yes. Here's a link:

https://www.amazon.com/Samsung-SmartThings-Outlet-GP-U999SJVLDAA-Smart/dp/B07F96JB63/

There are also less expensive zigbee plugs sold by other vendors that work with Hubitat. I can also recommend you check Hubitat's List of Compatible Devices to guide your purchasing decisions:

https://docs.hubitat.com/index.php?title=List_of_Compatible_Devices

Or you can post here asking for opinions on a particular device or recommendations for a suitable compatible-replacement.

1 Like

I use Hue plugs only because you can set the power fail return state.

1 Like

Can someone recommend cheap "paddle" switches?

I've found Zooz switches & dimmers to be relatively inexpensive, but of good quality, with multiple useful features. Their post-sales support and service is also excellent.

In addition, Zooz support (@agnes.zooz) is very responsive to being tagged on the Hubitat community forum.

While I have no experience with them, I know that others speak highly of iNovelli switches for the same reasons.

2 Likes

Please tell me this works. I compared the model number, but so far it's not seeing it.

Yes, they work fine with Hubitat. There should be built in drivers, or you can use the Inovelli drivers for advanced functionality. The Inovelli drivers are available in HPM.

The good news is the switch is wired in and manually working. The pretty LEDs even light up, too. However, Z-Wave indicator is showing red. The switch is literally, 15 feet away and on the opposite side of a wood-framed wall. If it had steel framing, I might be able to understand. It is also located next to my WiFi transmitter.

What range is expected without a repeater?

Much, much more than 15 feet. Do you see the device when you scan on the hubitat side, ignoring the switch for a moment?

You mean the "Exclude"

I mean under "Devices" -> "Discover Devices" -> "Z-Wave" ?

No. It doesn't see it, even when the switch is set to accept connection.

Thinking of doing a factory reset on hub. I don't have anything attached to it, so nothing lost.

I got it all working, with the exception of my WiFi plugs!

I have an "issue." The black-series switch is on/off. There is an instance of it in my Hubitat that lists it as a dimmer. My hub uses the on/off one. The switch initially worked flawlessly turning it on manually. Something has happened and the switch illuminates when scheduled (small blue indicator lights) but does not light the porch light. Now, I find that when I use the switch manually, I have to hold the button in the on position to light the porch light.

Any ideas?

Download the Hubitat app