Newb seeks help with Levition DZS15 switch

I'm trying to switch over from Wink to Hubitat, and having a heck of a time with this switch. I had added it to Hubitat at one point, but it wasn't working quite right, so I removed it and went through the Exclusion process, then put the whole project aside in frustration. Now I'm ready to try again. I've got the Hubitat up and running again, and I'm trying to get the switch included again and failing. I've tried multiple times, and it either doesn't find it at all, or says it finds the switch, and sits on the Device Discovery screen and says Initializing, but never seems to actually add the switch to Hubitat.
Any advice?

BTW, this same switch worked with the Wink hub for several years without a problem. And I did exclude it from Wink before I attempted to switch to HE.

Supposedly this is an officially supported device.

Did you try either this reset procedure:

or this one from Leviton?

It would appear that there might be different versions of this same basic switch, so I am not sure which will work.

Edit: from the Smartthings forum, this user had to do a power cycle to make theirs include.

I know this is an old discussion, but it became relevant for me today! Same switch, same issue. None of the various instructions I found seemed to be applicable to this specific switch.

Here’s how I finally got mine to work (reset and power cycle may not be needed, but it’s what I did):

  • Excluded switch from SmartThings.
  • Reset switch in standard way by pushing up until paddle pops out, then holding down until LED turns amber and then red.
  • Turned off breaker, then turned back on.
  • (This is the step that differed from previous instructions) Push the top of paddle until it pops out again, then hold the bottom down until the LED turns amber, but release before it turns red. That put it into pairing mode instead of resetting it, and SmartThings immediately found it.
1 Like

I did have the instruction sheet from Leviton, but that only has instructions for resetting it, not putting it into pairing mode. The info you posted from SmartThings got me going in the right direction. After turning off/on the breaker, and getting the light to turn amber, I did get the switch be Included into the system. I even created a one-button dashboard to turn it off and on.
Thank you so much!

1 Like