New Setup - Base IP won't work but port 8081 will?

I am a Wink user moving to Hubitat. Purchased a unit on Amazon (and a Lutron Pro bridge from eBay that hasn't come yet). I went to setup my device. Had already read some stuff on here so I figured it should go easily.

I followed the directions on hooking up and created a portal account. I have my computer and the hub on the same network. I do the “find hub” and the automated default way does not work. I can do the advanced way and put my network in as “192.168.XXX.0” (leaving out part of IP) and it will find a hub at 192.168.XXX.144. But when I click on that, it opens a browser to 192.168.XXX.144 (leaving off first part because you can't post links) but it gives a browser error about connection refused. I can ping the IP from my computer. After looking on the community I saw connecting to :8081 (left off http part) and that does pull up a "Hubitat Diagnostic Tool" with platform version (hub- and other information. There is no "previous version" listed.

I have disconnected the power, waited 30 seconds, and rebooted and tried again. Seeing some posts on here I even hard-coded the speed and duplex on the switch port. Nothing works when trying to connect to the base ip using http (aka port 80). Only way I can connect to the device is via port 8081.

I sent an email to support but have not heard anything yet. Do I have a bad device? Any suggestions?

Welcome to the community!

This is a temporary thing to do, do make sure to remove the hard-coded setting once things are working, it can cause CRC errors.

The first thing to try is to just go to the :8081 page and run a soft reset, then see if you can access the main page. It will also be a good idea to upgrade to the latest firmware once you get in to the main GUI on port 80.

1 Like

Just tried the soft reset. It took the mac and I entered the "soft reset" and then when I hit the button, it gave an error "Unknown Error Occurred."

Try a different browser or clear the current session cookies to make sure there was nothing wrong with the logged in session, this could happen.
If the MAC was wrong or entered incorrectly it would say that. This error, if it can't be solved by trying a different browser, indicate you will probably need to await an answer from support. Amend your ticket with this information.

1 Like

That's a "you need to logout, then log back in, timeout" error... Not easily translated, I know :smiley:

The problem I've had with this is: the logout button ALSO fails. :frowning:

The solution for me has been to try a different browser. There are probably better solutions, but nothing faster :smiley:

1 Like

Yeah, it isn't a login or timeout issue I don't think. First, I was using a Chrome Guest window so I could close that and re-open. Second, pulled the power, waited 30 seconds, and rebooted it. Last, from my little experience so far, when it asks for the MAC when choosing one of those commands, it is basically asking you to login.

So it took the MAC, I enter the soft reset text, and it gave the error. Now I could try the MAC again. I entered it as shown on back of device without the colons (:). I could try this again with an intentional wrong MAC and see what happens.

Any idea how long it takes for tech support to reply? To be honest, this is not a very good start to using this product. Very frustrating so far.

I verified, it you enter the MAC incorrectly (with no colons), it will give an error saying incorrect login. If you enter the MAC with or without colons, it will let you continue. In both cases, got "Unknown Error Occurred" after entering the "soft reset" text and pressing the button.

I think this unit is broke. Any idea how long it takes support to reply? I am thinking of just returning this to Amazon and getting a new one but was hoping to hear from support first. If I wait too much longer it wont come tomorrow.

Don't do this on devices with built in databases. For now you don't have any data in there, but best to get in the right habits from the start :wink:

It is, if you enter the wrong MAC you'd get an "Incorrect password, try again" error message.

Anything from minutes to days. Depends on how busy they are and how well they manage to prioritize the serious ones first. If you add the information you have here to the ticket it could be faster.

Also, it is probably time for @bobbyD to have a look at this, this is beyond community support.

There is something called "Safe Mode", not really sure what it does, but maybe worth a try if you can activate that? Do you have the "Restore Previous Version" button? You can also try to change firmware version using that.


What color is the LED on the Front??

None = no power
Red = Shutdown/halted (with power)
Blue = loading Platform OS
Green = Platform OS is running

Note: Those are my shorthand translations of the LED color. There may be nuances I'm not aware of.


Sorry for the troubles. It sounds like your hub may not be formatted correctly. When you get a chance, could you please tell us what color the hub's LED is showing (if it's blue, then we could try to run a factory reset)? Please check your email for more details on how to perform this reset.


Light is solid blue. It turns red if I do a shutdown from the menu.

1 Like

You will need to perform the Factory Reset process @bobbyd emailed you about

Be patient.. I tried this process out and it downloads a brand new copy of the Platform OS. That's exactly the same as a normal Upgrade BUT the upgrade gives you a progress message or two. The Factory reset one does not.. so it REALLY feels like it has failed. The OS has to be downloaded, then verified, then it gets installed THEN it reboots to the new OS. All without assuring messages. So be patient and wait.. then wait again :smiley:


RUNNING! Yeah, didn't see your reply because I was working on it. OMG... thought it was bricked because it immediately said the recovery completed immediately. Then following the directions, only went to blue on reboot and even after trying to connect, the 8081 and recovery screen both showed NO PLATFORM SOFTWARE! But I clicked on the new link on the 8081 screen to "Download Latest Software" (or something like that). After a minute or two when I redid the hub find process and clicked on the hub, IT WORKED!

Was thinking it was toast but it worked! THANKS!

FYI - I don't know if a document exists on some basic troubleshooting (my searches did not find anything but my search terms might have missed it) but having a pinned topic or a link on the wiki main setup page, showing at least:

  • Opening a browser to the 8081 port 8081 if main IP doesn't work
  • Pinging the IP
  • What light colors mean
  • Etc.
    I know you probably would not put the recovery process there, but at least having the knowledge that the blue light meant it was not fully booting and that a recovery process existed and tech support could provide it would have made things less confusing IMO.

Phew. Glad you got it working OK.
Now the fun starts. :wink:

@bobbyD my new hub will not change from blue to green either. I probably need to perform the factory reset also. Can you please email me the instructions? Thank you. I emailed support but would like to get this taken care of before Monday morning.

1 Like

Please check your email. I followed up on your ticket.

1 Like


I am having the exact problem explained in this topic.

I can only connect using port 8081 and have a solid blue light and on /factory/recovery it shows no Platform Version.

I’ve tried:
-Checking all firewall settings.
-/factory/recovery & Download Latest Version
-Soft Reset
-Full Reset
-Different browsers and PC.

Could you please help me fix this.

I’ve tried full reset from the menu on 8081 and it says it’s reset but then I just get a red light on the hubitat.

Please open a case with Hubitat by emailing them at The solid blue light usually requires their intervention.

Okay I emailed support. Thank you. I’ve been reading the forum for hours, trying everything suggested with no luck. Im pretty disappointed.

Ordered a return & replace from Amazon.