New router with different IP - how to change address on hub

I replaced my router and formerly my network was 192.168.0.x with the new router it is now 192.168.1.x How can I change the IP Address on my Hubitat?

There is no way to set an IP address on the HE Hub. You will need to set up an IP DHCP reservation on your new router.

You should be able to see your Hub at

Your hub will only get a new IP address if it sees the network connection "go down" and come back on. If you cannot find your hub listed at the portal @zarthan linked to, pull the ethernet cord (NOT the power cord) out for 3 seconds and then put it back in. That should make the NIC request an updated IP from the new router. Once it is on the network again set the new DHCP reservation.

If that does not work, and you know your hubs old IP, you could manually set your computer to the same subnet, access the hub, and tell it to reboot.

You can also log into your router and change the DHCP scope it gives out to be the old one, but this can create IP conflicts as the reservations/allocations are not set.

You should try all these things before pulling the power cord, and risking database corruption.

Oh and welcome to the community!

1 Like

Thank you @zarthan and @TechMedX for your quick responses. After I read @TechMedX explanation it was clear to me what I had to do. I removed the network connection and the Hubitat didn't seem to want to poll the network. I tried it for 3 seconds as directed, and even longer. I knew that if I forced an initialization my problem would be solved. I removed the power connector for a short time and watched the Hubitat go through its POST. When the LED turned GREEN I was then able to 'discover' it, and saw the new IP address. I've assigned a DHCP reservation and all is good. I did not lose any of my devices or applications.


:cold_sweat: well at least the hub is ok, but you should not just pull the power. I'd grab a backup to be safe and make sure to shutdown before making future network changes. Yanking the hubs power can be bad mojo.

1 Like

Pulling the power cord is likely to corrupt the database. It doesn't always but to be safe you might want to do a soft reset. Download a current database backup or better still use your off-device backup from yesterday (a hint that you should set up off device backups) then follow this. Soft Reset - Hubitat Documentation

1 Like

For what it's worth, my network is set up so that almost all of my devices have a static IP address. This just makes organization a lot easier. I also lock down the network pretty heavily for security reasons. Depending on your router, it can be pretty easy to know what's connected and prevent unknown devices from connecting. One of my good friends is a cyber security expert and I've taken some direction from him about further enhancing security measures. Virtually the only devices that can connect to my network are ones I have specifically assigned a static address for, based on their MAC address (wired or wireless). Guests are welcome to connect to separate, password protected guest network which cannot see my primary network or devices. It's perhaps a little more work to maintain, but you'll know exactly where you stand with what or who is connected.

I suggest familiarizing yourself with your new router’s web admin interface. What router did you buy?

This should allow you to see a list of currently connected devices, as well as set dhcp reservations, without having to resort to pulling the power plug on your hubitat hub in the future (which can cause database corruption, as others have already explained).

That is pretty much where I am as well. I brought the new hub up on the main LAN. Getting ready to segment all HA devices on a separate vLAN. Would prefer to be able to set the IP on HE but it is easy enough to get around. Running Unifi, so I can see it pretty easy.

Security is becoming a bigger and bigger issue these days. I have been locking my network down too.

This is quite a bug, isn't it? Since I register my hub for the first time, it has to have the same ip for the whole lifetime? What if you move you hub to some router where it's original ip is already taken by another device? Can you please add possibility to update registered hub's ip address, so I can see it in

I've changed both names and addresses several times and had no problem locating the hubs in portal. This happens automagically.

To put some details here: I've got a new router, which assigns ip addresses from different range. Instead of 192.186.1.x, it's 192.168.0.x. I set DHCP to always give to hubitat, which is different from what ip address it got from previous router. Now I can't see the hub on, it reads there are no registered hubs for this account - while when I go to the hub by local ip, I can see in settings it's registered to my user.

Ha, it's there now. Waiting couple of hours didn't do anything, but when I opened it in mobile app couple of times, it suddenly appears in my registered hubs on

The hub checks in periodically to see if there are firmware updates, so it can put up a notification bubble.

I just came across this, and wanted to pass along what worked for me.

Go to the settings, then shutdown your hub safely. Wait until the light on the hub turns red. Then change to whatever router you want to use, then unplug the power from the hub, wait a few seconds, and plug it back in.

It took a couple minutes for the hub to show up. Also, my router, like most has a 2G and 5G connection. On my old router, I had to connect on the 2G side, but on the new one, I have to connect using 5G.

1 Like

I'm in sort of a similar boat. I got a new TP-Link mesh network and I'm having trouble getting my C7 hub connected. I mistakenly thought that by giving my network the same name it would all just reconnect. I went to and it was able to find my hub using its MAC address. However, when I click Connect to Hub it fails. I don't know how to set an address for it with the TP-Link or if the address has changed.

Screen Shot 2021-04-15 at 11.26.01 PM

I had left the power to the hub on the whole time so the power was on before the hub was connected to the new router.

Is there a way to gracefully power down the hub if I can't get to the menu? I don't want to just pull the power cord.

I would suggest you try unplugging the network from the HE hub, waiting a few seconds, and then plugging it back in. This should cause it to get a new address from the new network.

For most of the TP-Link routers I have used, there is a "DHCP Server" page in Advanced -> Network area where you can see current leases and configure dhcp reservations.

I unplugged the network cord from both the hub and the router and over a minute before plugging it back in. Even after doing that the hub isn't showing up in the list of my devices on the TP-Link page. (Even though there are some "unknown" devices on my TP-Link page they show the MAC address along with the IP address and none of the MAC addresses match my hub and they say they are wireless and not wired).

The only way the Advanced search finds it is by the MAC address. But I take little comfort in that as it said it found it using the MAC address even when the hub wasn't plugged into the router. So that doesn't seem to be really finding it.

I wanted to try using the router's IP address but I'm not sure what it means by trying to enter your local ip address range to scan this network for any hub(s). A range seems to be from number X to number Y, not just 1 number like they show as an example. I see my TP-Link is on page, which I tried putting in but that didn't work. I also tried putting in as I see all of my found devices are That didn't work either.

I found that some devices didn't want to connect to my network because I had an apostrophe in the SSID name, even though these same devices had been on the network before, so I changed the name to something simpler. I then unplugged both ends again, and waited a minute before plugging them both in. Again, nothing. doesn't find it and it isn't appearing in the list of my devices on my TP-Ling Deco management page.

So, at this point is there anything to do other than pulling the plug and hoping for the best?