New router - can’t find HE hub - IP comes back as 127.0.0.1

Searched for.this issue on the forums and came up with nothing like this.

Just switched from a Tenda AC23 router to a Tenda MW6 mesh router for better WiFi. Everything went well, considering I was able to set the SSID and password on the MW6 to be identical to the AC23.

Problem is this : I can’t find the IP of the hub (H7). It is connected and functioning because the rules and automations are happening. The LED on the front of the HE hub is solid green.

When I Find Hub in the HE app, it will be Searching for a while, and eventually it will go back from Searching to Search.

I ran Advanced Discovery at find.hubitat.com by inputting the MAC address, and that returned an IP of 127.0.0.1 (local IP). Since I am nearing a point of frustration, tried logging in to 127.0.0.1 which went nowhere of course.

Since I have the MAC address of the Hubitat hub, and looking in the Tenda app, I see a list of everything that is online except for the HE hub. I opened each devices’ info and looked at the MAC addresses (over 45) and none of them were even close on the MAC address of the HE hub. I am getting the MAC address off the label on the bottom of the hub.

The hub has been powered down several times trying anything.

The only thing that might be worth throwing in here is the IP range on the AC23 was 192.168.0.xxx and the MW6 changed it to 192.168.5.xxx

I changed it back to 192.168.0.xxx with no difference.

My knowlesge of networking is lacking, so if some of you are chuckling under your breath, let me join you once this is rectified.

Try

hubitat.local

If that doesn’t work and you can get to a command prompt you could try entering

arp -a

which should give you a list of all of the MAC addresses with associated IPs attached to the network - one of those should match the hub.

1 Like

beat me :slight_smile: the arp -a. If a tool might help, download (for windows) Download The Dude v4.0 Beta 3 (freeware) - AfterDawn: Software downloads
Dude is a form of 'sniffer' for networks. It will ID all the IP's of all devices - and will also show the MAC assigned.

I will add I'm concerned here about the multiple subnets. if there is incorrect subnetting going on, we who are trying to be helpful may be sending you awry. Are all the devices, AP's, routers, DHCP servers and workstations on the same subnet? is the subnet mask set the same and correctly for all devices? these may seem like obvious and stupid questions but it can take just one typo to send you to the loony bin!

1 Like

Sounds like the OP has a single subnet, just that when bringing new router online it changed from 192.168.0.0/24 to 192.168.5.0/24 (presumably the default of the new router).

also - another thought - you said you changed the IP of the new router from sub 192.168.5 to 192.168.0... is that router doing DHCP? you may have to also update the dhcp settings to reflect that. And since you changed the DHCP, you'll need to release/renew other devices (reboot) anything that may have picked up a bad subnet!
You can test by multihoming your NIC to both subnets. then you can see both subnets to help detect and isolate the issue.

Perhaps rebooting the hub with the DHCP reset button hidden on the bottom will get it to pick up a new IP address from the router?

2 Likes

@thebearmay

Went to a Windows PC that is wireless. arp -a returned this

image|666x500

That is my old IP range. Checked another PC on WiFi and got the same output. This is leaning more toward my mesh installation rather than a HE issue. Any ideas where I should go next? For some reason the mesh has both 192.168.0.xxx and 192.168.5.xxx

Going to change it back to 192.168.0.xxx and reboot. :crossed_fingers:

Bingo :grinning::grinning::grinning::crazy_face::crazy_face::crazy_face:. Changed the IP in the Tenda app back to 192.168.0.1 and rebooted all 3 nodes. NOW the MAC for the HE is on the list.

Many many thanks to everyone who held my hand. Again, I am a 66 year old trying to learn.

All this was caused because I did not reboot the mesh after I changed the IP from 192.168.5.xxx to 192.168.0.xxx. Lesson learned. You guys taught an old dog something today. I am grateful.

Edit: the next day the mesh router decided to change the IP of the HE hub, meaning no access to the HE hub through the app. :angry:

Rolled up my sleeves, and removed the MW6 mesh router temporarily. Reconnected the AC23 router back like it was a week ago and then connected the MW6 mesh router WAN port to one of the ports on the AC23 router. Gave the AC23 router a different SSID than the MW6. Connected HE to the AC23 so it is happy not moving IPs.

Now HE is happy once again. The TSL (Tom’s Stress Level) is inversely proportional to the WAF. When the WAF goes down, the stress level goes up.

5 Likes

Download the Hubitat app