New hub wont connect, times out

I am new to Hubitat, switching when SmartThings bricked my hub. I got my new hub yesterday and I followed the set up process. The hub did wat it was supposed to and the light is green. I used the hub finder and it finds and lists it but it times out every time I try to connect to it. I have it properly connected through my Linksys mesh router. I checked my router IPs and all devices linked to my LAN start with 10.74. but the hub finder shows the ip address of the hub as I checked devices on my router dashboard and I can not find the Hubitat in the listing. I tried discovering the hub through its mac address and got the same thing. I also checked the forums for similar issues from other users and found little to help me. I tried several of the β€œfixes” there but nothing worked. I am not that well versed with IP protocols so I have no idea what to do at this point. I have contacted customer support but you have to go through email and it could be days before I get any kind of help.

Where did you get your hubitat from? Is there a possibility that it was previously used, and configured with a static IP address?

Also, I might be wrong, but I think by default, the hub expects to be on a Class C network, whereas your setup sounds like a Class B network.

I got it from Amazon. Its supposed to be new but who knows these days.

It probably was new.

How is Hubitat connected to your router?

It is connected into a LAN port on my router, with the CAT 5 cable that came with it. I also tried a different CAT 5 cable just in case and nothing changed. Everything else I have connected that way shows up in my router device listing, except for the Hubitat hub.

What is the network mask on your network?

I am somewhat of a noob with router protocols. What is a network mask?

I guess I'm asking you how your network is subnetted? Is it one large Class B network (, or is it a Class C network? I think (but am not sure) that Hubitat expects to be on a class C network.

Tagging @bobbyD.

Ah got it. When I check my ipconfig it shows It also specifies a subnet mask of if that is any help,

Yes. So Hubitat should receive an address that is 10.74.1.x.

Ok, so assuming it is possible that you received an Amazon return that was configured with a static address, you can try this:

There's a section which describes what to do if you are accidentally blocked from accessing your hub due to an incorrect or unknown IP address setting. Follow those reset instructions.

Thanks, I'll give it a shot.

If you send me your hub's MAC address via PM, I can double check if the hub was previously registered.

1 Like

Will do. The hub now shows in my router device list. Will try to get it registered now. Thanks!


Awesome. The hub now has a usable ip has connected and I am getting it up and running.